Solved Printer doesn't work after upgrading CUPS

pkubaj

Aspiring Daemon

Reaction score: 101
Messages: 555

I have HP LaserJet Pro P1102w and 10.0-RELEASE on amd64. After upgrading CUPS from 1.5.4_1 to 1.7.1 I can no longer print. When I try to print test page from CUPS browser page I get:
Code:
Unable to print test page:

    No such file or directory
I also have hplip installed, but printing from there also doesn't work (worked before). Although I had used print/foo2zjs for PPD, I gave print/hplip-plugin a try, which didn't help. The options for print/cups-base are:
Code:
        AVAHI          : off
        DBUS           : off
        GNUTLS         : off
        LIBPAPER       : on
        LIBUSB         : off
        MDNSRESPONDER  : off
        PAM            : off
        PHP            : off
        PYTHON         : off
        XDG_OPEN       : off
When I try to print, I get:
Code:
localhost - - [31/Mar/2014:19:45:07 +0200] "POST /printers/HP_LaserJet_Professional_P_1102w HTTP/1.1" 200 267 Create-Job successful-ok
localhost - - [31/Mar/2014:19:45:07 +0200] "POST /printers/HP_LaserJet_Professional_P_1102w HTTP/1.1" 200 43002 Send-Document client-error-document-format-not-supported
localhost - - [31/Mar/2014:19:45:07 +0200] "POST /jobs/ HTTP/1.1" 200 198 Cancel-Job successful-ok
in /var/log/cups/access_log and
Code:
E [31/Mar/2014:19:44:33 +0200] cupsdLoadBanners: Unable to open banner directory "/usr/local/share/cups/banners": No such file or directory
E [31/Mar/2014:19:45:07 +0200] [Client 13] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/HP_LaserJet_Professional_P_1102w) from localhost
in /var/log/cups/error_log.

I have already uncommented
Code:
application/octet-stream
in /usr/local/etc/cups/mime.types and/usr/local/etc/cups/mime.convs.

Note that it did work before so kernel and groups are configured properly.
 

vg

New Member

Reaction score: 3
Messages: 10

Re: Printer doesn't work after upgrading CUPS

FreeBSD 10 amd64, HP LaserJet 4L
Absolutely same problem. After the CUPS updating to version 1.7.1 the printing ceased to work.
Code:
E [03/Apr/2014:18:00:01 +0700] cupsdLoadBanners: Unable to open banner directory "/usr/local/share/cups/banners": No such file or directory
E [03/Apr/2014:18:26:49 +0700] [Client 12] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/hp) from localhost
E [03/Apr/2014:18:30:12 +0700] [Client 12] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/hp) from localhost
E [03/Apr/2014:18:31:48 +0700] [Client 12] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/hp) from localhost
E [03/Apr/2014:18:32:35 +0700] [Client 12] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/hp) from localhost
E [03/Apr/2014:18:36:17 +0700] [Client 12] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/hp) from localhost
E [03/Apr/2014:18:38:33 +0700] cupsdLoadBanners: Unable to open banner directory "/usr/local/share/cups/banners": No such file or directory
E [03/Apr/2014:18:43:36 +0700] [Client 12] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/hp) from localhost
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

Re: Printer doesn't work after upgrading CUPS

Did you follow note 20140331 in /usr/ports/UPDATING?
 
OP
OP
P

pkubaj

Aspiring Daemon

Reaction score: 101
Messages: 555

Re: Printer doesn't work after upgrading CUPS

Yes, otherwise it wouldn't have installed.
 
OP
OP
P

pkubaj

Aspiring Daemon

Reaction score: 101
Messages: 555

Re: Printer doesn't work after upgrading CUPS

Thanks, printing indeed works now.
wblock@ said:
Did you follow note 20140331 in /usr/ports/UPDATING?
Since you are a FreeBSD committer, could you edit UPDATING note to indicate that print/cups-filters may need to be installed? There may be others like vg and me.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

Re: Printer doesn't work after upgrading CUPS

The print/cups maintainer would be the right one to ask. I could modify the message, but without using CUPS or testing it myself, I can't say whether that's the correct solution to the problem.
 
OP
OP
P

pkubaj

Aspiring Daemon

Reaction score: 101
Messages: 555

Re: Printer doesn't work after upgrading CUPS

wblock@ said:
The print/cups maintainer would be the right one to ask. I could modify the message, but without using CUPS or testing it myself, I can't say whether that's the correct solution to the problem.
Well, thing is, print/cups doesn't have maintainer now.
 

Chris_H

Daemon

Reaction score: 194
Messages: 1,076

Re: Printer doesn't work after upgrading CUPS

pkubaj said:
wblock@ said:
The print/cups maintainer would be the right one to ask. I could modify the message, but without using CUPS or testing it myself, I can't say whether that's the correct solution to the problem.
Well, thing is, print/cups doesn't have maintainer now.
Maybe so. But sending a pr() with the solution, is likely to get results. In fact, the port was updated because of a pr() less than a mos. ago. :)

--Chris
 

fernandel

Aspiring Daemon

Reaction score: 201
Messages: 818

Looks like that is printing solved but I don't how? I have HP business inkjet 3000, HPLIP and did update as I red. I reinstalled cup-filters too.There are no errors but printer doesn't work. Is it any options to downgrade a port, please?
Thank you.
 

cabriofahrer

Active Member

Reaction score: 9
Messages: 185

Well, glad to have found this thread because I ran into the same problem some weeks ago and I also posted a thread asking for help but nobody replied. Also think that it is very disappointing that there is no message in UPDATING warning about this. I was even doubting because of this that FreeBSD was a viable solution for a productive environment when after a simple pkg upgrade you are suddenly left without the ability to print without knowing why...
 
Last edited by a moderator:

scottro

Daemon

Reaction score: 521
Messages: 1,448

Did anyone ever file a PR? This got me again, though I'd been working around it by doing print to file, then running the resulting ps file though /usr/local/bin/lpr.
I see no mention of it in UPDATING. Anyway, once again, finally got around to looking at error logs (if I print more than once every 2 months, it's a lot), googled the error and came back to this thread, in which I had been one to post. :)
 
Top