PPPoE configured :)

Junaid

Member


Messages: 20

Hi guys,

I wanted to set up PPPoE using FreeBSD 8.2 with IPFW and NATD. I have added IPFW with the required options. I have configured PPPoE with NAT so for now I am not using natd and firewall. I am connected to DSL and have other lan computers connected now. I just want to ask a few simple things.

During the ppp config I added nat log yes line to the ppp.conf but how do I actually see that log?

When I do tail -f /var/log/ppp.log I can see LCP sending recving echo every one minute. Can I control that? Or is it ok?

I defined em0 interface for PPPoE and it created a tun0 interface with the external IP and assigned 192.168.216.11 ip to the em0 interface. Would this create problem if I enable my IPFW now?

Thank you.
 

ecazamir

Active Member

Reaction score: 29
Messages: 216

There's nothing wrong with LCP, it's a protocol used to check the link and to determine if the peer is still connected. I assume you can get rid of those messages disabling LCP log, use
Code:
set log -LCP
option of ppp in /etc/ppp.conf.

As long as you use PPPoE, it doesn't matter what IP address is assigned to the external interface, as long as it does not overlap with your LAN IP space. You could simply bring up the WAN interface by using
Code:
ifconfig_em0="up"
in /etc/rc.conf, the assigned IP address of the WAN interface is not used to reach the internet so it can be disabled safely for DSL configurations.

In my experience, the best scenario for PPPoE routers with NAT included pf. pf can adjust TCP MSS size. If the LAN client is not aware of the shorter MSS of the PPPoE link, web browsing experience will suffer.

I used
Code:
scrub in all max-mss 1440
in /etc/pf.conf to fix this problem.
 
Top