PowerPC64 Gstreamer1-plugins-bad compiler error

podexperfectussum

New Member


Messages: 4

I'm running on a power mac g5 trying to get a GUI running, KDE, XFCE, Compiz-Fusion, MATE, whatever. I keep running into an error when building gstreamer1-plugins-bad:

Code:
In file included from rtpreceiver.c:33:
rtpreceiver.h:38: error: redefinition of typedef 'GstWebRTCRTPReceiver'
../../../gst-libs/gst/webrtc/webrtc_fwd.h:42: error: previous declaration of 'GstWebRTCRTPReceiver' was here
rtpreceiver.h:39: error: redefinition of typedef 'GstWebRTCRTPReceiverClass'
../../../gst-libs/gst/webrtc/webrtc_fwd.h:43: error: previous declaration of 'GstWebRTCRTPReceiverClass' was here
gmake[17]: *** [Makefile:960: libgstwebrtc_1.0_la-rtpreceiver.lo] Error 1
gmake[17]: Leaving directory '/usr/ports/multimedia/gstreamer1-plugins-bad/work/gst-plugins-bad-1.14.4/gst-libs/gst/webrtc'
gmake[16]: *** [Makefile:821: all] Error 2
gmake[16]: Leaving directory '/usr/ports/multimedia/gstreamer1-plugins-bad/work/gst-plugins-bad-1.14.4/gst-libs/gst/webrtc'
gmake[15]: *** [Makefile:774: all-recursive] Error 1
gmake[15]: Leaving directory '/usr/ports/multimedia/gstreamer1-plugins-bad/work/gst-plugins-bad-1.14.4/gst-libs/gst'
gmake[14]: *** [Makefile:759: all-recursive] Error 1
gmake[14]: Leaving directory '/usr/ports/multimedia/gstreamer1-plugins-bad/work/gst-plugins-bad-1.14.4/gst-libs'
*** Error code 2
for funsies, I built a 12.0-Release/amd64 system and gstreamer-plugins-bad compiled just fine. Any suggestions to get past this? Something I can reconfigure to exclude? gstreamer1 doesn't seem to have any options to exclude bad plugins.

also, there's this:
uname -a
FreeBSD purifier 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC powerpc
 
Last edited by a moderator:
OP
OP
P

podexperfectussum

New Member


Messages: 4

no luck. I was getting ready to get in touch with the gstreamer maintainer, but I believe that's "multimedia@freebsd" so I was going to skip that step and go straight to the source, but I got distracted.
 

Robbin Johnson

New Member


Messages: 6

I understand that it is a Tier 2 platform; I was just hoping (against hope? :))

Last night updated the ports collection and am now running into more issues ... heavy sigh. I do not want to run Linux on this machine <insert sad face here>
 
OP
OP
P

podexperfectussum

New Member


Messages: 4

I forgot...I did download the gstreamer-plugins-bad source code and attempt to compile it. That gave the same error, so I don't think it's necessarily a FreeBSD issue.

I'll try updating my ports and see what happens. At least we'll be in the same boat.
 

acheron

Well-Known Member

Reaction score: 199
Messages: 499

It builds fine with this patch:
Code:
Index: multimedia/gstreamer1-plugins/Makefile
===================================================================
--- multimedia/gstreamer1-plugins/Makefile      (revision 493353)
+++ multimedia/gstreamer1-plugins/Makefile      (working copy)
@@ -40,7 +40,7 @@
 UGLY_DISTFILE=         ${UGLY_DISTNAME}${EXTRACT_SUFX}
 DIST?=         base
 
-USES+=         gettext gmake gnome libtool pathfix pkgconfig python tar:xz
+USES+=         gettext gmake gnome libtool pathfix pkgconfig python tar:xz compiler:c11
 WANT_GSTREAMER=        yes
 USE_GNOME+=    glib20 introspection:build libxml2
 GNU_CONFIGURE= yes
 
Top