Solved Poudriere pkg options

I am trying to get a version of the ncurses library built with debugging and trace enabled. I set the options I desired using poudriere options.
poudriere options -s -p PORTS_12_2 devel/ncurses
===> The following configuration options are available for ncurses-6.2.20210626:
     DEBUG=on: Build with debugging support
     DOCS=on: Build and/or install documentation
     EXAMPLES=on: Build and/or install examples
     MANPAGES=on: Build and/or install manual pages
     PROFILE=on: Build with profiling support
     TRACE=on: Add trace() function to all models of ncurses

However, when I install the resulting ncurses package this is what I find:
# file /usr/local/lib/
/usr/local/lib/ ELF 64-bit LSB shared object, x86-64, version 1 (FreeBSD), dynamically linked, stripped

I understand that stripped means that debugging symbols have been removed. How do I get the libraries built with debugging enabled?
ports(7) indicates that you need to add WITH_DEBUG_PORTS to whatever make.conf you're using for Poudriere. For example:
$ grep WITH_DEBUG /usr/local/etc/poudriere.d/JAILNAME-make.conf
WITH_DEBUG_PORTS+=	devel/ncurses
$ file /usr/local/lib/
/usr/local/lib/ ELF 64-bit LSB shared object, x86-64, version 1 (FreeBSD), dynamically linked, for FreeBSD 13.0 (1300139), with debug_info, not stripped

Edit: corrected /usr/local/poudriere.d to /usr/local/etc/poudriere.d


– is that not an unusual path?


% file /usr/local/poudriere.d
/usr/local/poudriere.d: cannot open `/usr/local/poudriere.d' (No such file or directory)
% cd /usr/local/etc/poudriere.d/
% file ../poudriere.conf
../poudriere.conf: ASCII text
% ls -hl ./*.conf
-rw-r--r--  1 root  wheel   340B 28 Jul 23:07 ./make.conf
% uname -KrU
14.0-CURRENT 1400026 1400026
% pkg info -x poudriere
Thanks. That solved the issue. However, on my host the jail make file is located in /use/local/etc/poudriere.d.