Solved Post 12.2 update led to touchpad reset

the3ajm

Member

Reaction score: 13
Messages: 74

I was monitoring packages being rebuilt for 12.2 on Sunday evening and saw it's done so I began the update. After I restarted my PC the first thing I noticed was my touchpad has been "reset" as tap doesn't register on my touchpad and acceleration has set back to default like the first time I've installed FreeBSD. There was no changes to the rc.conf file and it's been the same setting that worked from other previous releases, xfce mouse setting reveals both system mouse and glidepoint were detected/enabled but if I were to toggle glidepoint my cursor stopped moving leading me to think it's ignoring the system mouse. Even running the flags for moused that works once entered on the terminal doesn't work either.

I'll plan to create a file in xorg.conf.d directory to set autoadddevices as false so it doesn't load glidepoint but from suggestions moused needs to be disabled and the content should be as below:
Code:
Section "ServerFlags"
        Option          "AutoAddDevices" "false"
EndSection

Section "InputDevice"
        Identifier      "PS/2 mouse"
        MatchIsTouchpad "on"
        Option          "CorePointer"
        Option          "Tapping" "on"
        Option          "Protocol" "auto"
        Option          "Device" "/dev/psm0"
        Driver          "mouse"
EndSection

Section "InputDevice"
        Identifier      "System mouse"
        Option          "Protocol" "auto"
        Option          "Device" "/dev/sysmouse"
        Driver          "mouse"
        Option          "AutoServerLayout" "true"
EndSection

Test out if I disable both detected mouse in xfce if it change any behaviors, I'll review the devfs.conf file and try to link sysmouse to mouse as an effort listed from the handbook.

I'll report back if there's any changes.
 
OP
the3ajm

the3ajm

Member

Reaction score: 13
Messages: 74

Good news, after adding the file in xorg.conf.d I was able to get tapping working again. I tried adding edge scrolling but that didn't work but I'm satisfy with the progress I've made.
 
Top