portsnap update failed

Hi folks,

I ran into following error when updating ports, # portsnap extract update.

files/629f4dfcb9f60ae7304f44beab67766a4e45f2515336fecceb1ebd2648508ab3.gz not found -- snapshot corrupt.

Need help to work this out.

System is 13.1-RELEASE-p3

Thanks.
 
I don't think you'd normally use extract to update - I use "portsnap fetch extract" for the initial set-up and then "portsnap fetch update" from that point on.

Might be a mirror or timing thing? Wait a while and try again?
 
It failed couple of days ago. Today is the second time I try to update and fail. So it doesn't look like about timing. Mirror? In my case, connecting other mirror is snail slow.
I did try # portsnap fetch extract, no success.

I don't think you'd normally use extract to update - I use "portsnap fetch extract" for the initial set-up and then "portsnap fetch update" from that point on.

Might be a mirror or timing thing? Wait a while and try again?
 
Execute the following commands,
Code:
rm -r /usr/ports/* /usr/ports/.??*
cd /usr/ports/
git clone --branch 2022Q4 https://git.FreeBSD.org/ports.git /usr/ports
mkdir /usr/ports/distfiles
mkdir /usr/ports/packages
 
Thanks. But git is very slow down here...
I fixed the problem by removing /var/db/portsnap/INDEX. For reason I don't know, I think the INDEX file contains wrong .gz file name that mismatches what's actually fetched .gz file.

Execute the following commands,
Code:
rm -r /usr/ports/* /usr/ports/.??*
cd /usr/ports/
git clone --branch 2022Q4 https://git.FreeBSD.org/ports.git /usr/ports
mkdir /usr/ports/distfiles
mkdir /usr/ports/packages
 
Top