Port install problem

I am trying to install rsync from the ports collection.

/usr/ports/net/rsync # make install clean

I get an error:
"Ports Collection support for your FreeBSD version has ended, and no ports are
guaranteed to build on this system. Please upgrade to a supported release."

I check the version:

/usr/ports/net/rsync # freebsd-version -k and get:

which from what I can tell appears to be the latest.

What gives?
OK, I think I am mixing up installers.
I tried pkg install rsync and it worked...

For the record, I tried freebsd-version -ru and got:
Illegal option -r
usage: freebsd-version [-ku]
Yes, there is definitely more going on here. rsync seemed to work, but I have definitely monkeyed something up.


freebsd-version -u

freebsd-version -k

freebsd-version -r
Illegal option -r
usage: freebsd-version [-ku]
Did you reboot after the first freebsd-update install and then run again freebsd-update install

That's a negative Ghost Rider.

Can I reboot and run freebsd-update install to fix or is it too late for that?
Unless you messed in other ways with freebsd-update (for example edited config files) then it should still be perfectly safe.