Poor performance

Good morning,

I am new in FreeBSD from Debian. I've just installed version 10.1 and I would like to try KDE4. I have problem with very low performance in KDE and in the console also (but not as much as after X starts).

Sometimes during not very hard operation (for example ping, cd, or nano text editor), system disk LED lights and system freeze for a moment. It is not very often in console, but KDE is unusable...

I have 1 GB of ram. I have tried top(1), there is enough free space in RAM and CPU is doing nothing. I have tried disable ACPI and swap - with no effect.

KDE is booting about 10 minutes and it is freezing during logging in a lot.

Vesa vs Intel graphic driver has no effect to this problem and acceleration with Intel driver seems to work fine.

My HW is one core, dual thread Intel Atom@1,6GHz, 1GB of ram and 16GB CF card as storage. CF card should not be my bottleneck, it has speed about 50MB/s.

HW is healthy, on Debian, everything worked fine.

Do You please have any idea, what to try next? Could the problem be in CF controller driver?

Sorry for my bad English and thanks in advice for every reaction :)
You may want to try changing the kernel hertz frequency to a higher number to decrease the latency. I usually do 1000, 1500, or 2000. Without a patch, the hertz maxes out at 2499 because, at 2500, the effects reverse.

This is only one solution that will work with others.
Thank you for you reply. Could you post me some link which describes details of this problem and how to set it, please? Why it is not set to the higher frequency in default settings and why is the problem depending on my hardware?

My system freezes for about 2 - 5 seconds - is it pointing to this problem, or the latency in case of low kernel frequency is different?
My system freezes for about 2 - 5 seconds

I had/have the same issue with x11/kde4. Despite that it is a lower performing machine, I never did get convinced that lack of resources caused this. I swapped with x11-wm/xfce4 and the freezing does not happen. That was over a year ago, so in my case who knows, maybe a bad piece of code was the cause and has since been fixed.