Playing .mov results in "moov atom not found"

MarcoB

Well-Known Member

Thanks: 90
Messages: 333

#1
Hi,

My wife has an iPhone on which she created a movie from some photo's. The result is a .mov file. The file plays fine on her Windows laptop. I tried to play it on FreeBSD with mpv but this results in:
Code:
[ffmpeg/demuxer] mov,mp4,m4a,3gp,3g2,mj2: moov atom not found
[lavf] avformat_open_input() failed
[ffmpeg/demuxer] mov,mp4,m4a,3gp,3g2,mj2: moov atom not found
[lavf] avformat_open_input() failed
Failed to recognize file format.
So I thought this is some codec issue and installed VLC to see if that works better, but VLC gave the same error message. I also tried to play it on a laptop running Slackware Linux with Xine, but Xine complains about a missing "demuxer", which is probably the same problem as on FreeBSD.

So the question is if it's possible to play .mov files created on an Apple iPhone? Or is this a digital rights thing and not possible to play on an open source OS?

Regards,
Marco
 
Last edited by a moderator:

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,335
Messages: 27,504

#2
The extension .mov indicates it's a Quicktime format. But this is a container format and says nothing about the actual codecs used to encode video and audio.
 

aragats

Aspiring Daemon

Thanks: 353
Messages: 886

#3
MarcoB , if you provide a sample, most probably, the actual reason can be revealed easy.
The error message itself is not very specific, I've seen it in various situations, e.g. when an mp4 file is trimmed.
 
OP
OP
MarcoB

MarcoB

Well-Known Member

Thanks: 90
Messages: 333

#4
The movie is based on photo's of our 5-year old son and some of his friends. Don't want it to post it on a public site. The created mov file is not altered in any way btw.
 
Top