Plasma KDE blank (sort of!) login screen

In_over_my_head

New Member


Messages: 7

Good Morrow!

I am back, and reattempting to install this (hopefully) interesting operating system + desktop.

Last time I needed to install drm-legacy-kmod due to my odd graphics configuration on my old laptop (Radeon HD 6520G + Radeon 6470M). I wanted to use ZFS, but for some reason I didn't have permission to install this despite being root...

Anyway, this time I am using UFS, and things seemed to me going well, relatively.

I have so far done the following:

Installed drm-legacy-kmod (successfully) along with Xorg, sddm, kde5 & plasma5-sddm-kcm

edited /etc/rc.conf with:

kld_list="/boot/modules/radeonkms.ko"
dbus_enable="YES"
hal_enable="YES"
sddm_enable="YES"

as well as /etc/fstab with:

proc /proc procfs rw 0 0

Now to the problem. When I reboot, I get a blue login screen, which then goes black (with a cursor arrow showing). If I press return, I get the login screen back and I can enter my password.

When I do this, the screen goes blank, then black, then the login screen briefly flickers on and then goes black again with the arrow showing again. Pressing return brings the login screen back with a Login failed message. The password is very simple and is correct.

I am presuming that this is some sort of configuration error, but I have no idea what to change/adjust to get this to work properly.

I'm so close to seeing a working desktop, I can almost smell it (maybe that's my fan working overtime!).

If you can point this newbie in the right direction, I'd be very grateful indeed.

Sorry about the waffle and thank you for reading.
 

rawthey

Member

Reaction score: 19
Messages: 87

I'm seeing a similar problem after upgrading to sddm-0.19.0 today.

My workaround was to disable sddm by commenting out the sddm_enable line in /etc/rc.conf and creating .xinitrc in my home directory containing the following line

exec ck-launch-session startplasma-x11 > ~/.xsession-errors 2>&1

Then I just login and run startx
 
OP
I

In_over_my_head

New Member


Messages: 7

I'm seeing a similar problem after upgrading to sddm-0.19.0 today.

My workaround was to disable sddm by commenting out the sddm_enable line in /etc/rc.conf and creating .xinitrc in my home directory containing the following line

exec ck-launch-session startplasma-x11 > ~/.xsession-errors 2>&1

Then I just login and run startx
Thanks for the suggestion, but it doesn't work for me. I'm greeted with what looks like the Cygwin (twm?) windows manager which I've used before in MS Windows but is not the intended environment.

I'll keep probing and I'll see what I can find. Thanks again.
 

Samuel Venable

Active Member

Reaction score: 80
Messages: 108

Honestly I love KDE but i must say why can't it look nice and be stable at the same time? Why more often than not one cancels the other out in a OS or Desktop Enivironment (depending on the context). /rantover
 

Argentum

Well-Known Member

Reaction score: 164
Messages: 361

I'm seeing a similar problem after upgrading to sddm-0.19.0 today.

My workaround was to disable sddm by commenting out the sddm_enable line in /etc/rc.conf and creating .xinitrc in my home directory containing the following line

exec ck-launch-session startplasma-x11 > ~/.xsession-errors 2>&1

Then I just login and run startx

Or check my post:
 
Top