Solved pkg upgrade wants to delete 33 packages (kde related?)

dave01

New Member


Messages: 10

Some days ago I did pkg upgrade and it needs to delete 33 packages, most if not all of which are needed. This has happened in the past and I've left it for while and the problem goes away. But this time, the problem is still there, or taking longer to fix or there's some package incompatibility that has only shown up since a recent update of some package or other.

Here's the output of pkg upgrade, can anyone see anything obvious I should remove? (I assume there is something in the "packages to be upgraded" that is conflicting.)

Code:
%pkg upgrade
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking for upgrades (77 candidates): 100%
Processing candidates (77 candidates): 100%
The following 101 package(s) will be affected (of 0 checked):

Installed packages to be REMOVED:
        baloo-widgets: 20.04.2
        calibre: 4.20.0
        cantor: 20.04.2
        dolphin: 20.04.2
        gwenview: 20.04.2
        kde-baseapps: 20.04.2
        kde5: 5.19.2.20.04.2
        kdeedu: 20.04.2
        kdegraphics: 20.04.2
        kdemultimedia: 20.04.2
        kdenlive: 20.04.2
        kdepim: 20.04.2
        kdepim-addons: 20.04.2
        kf5-baloo: 5.71.0
        kf5-frameworks: 5.71.0
        kf5-kfilemetadata: 5.71.0_4
        kfind: 20.04.2
        kget: 20.04.2
        kitinerary: 20.04.2_2
        ktorrent: 5.2.0
        okular: 20.04.2_1
        plasma5-kde-cli-tools: 5.19.2
        plasma5-kdeplasma-addons: 5.19.2
        plasma5-khotkeys: 5.19.2
        plasma5-kinfocenter: 5.19.2
        plasma5-kmenuedit: 5.19.2
        plasma5-plasma: 5.19.2
        plasma5-plasma-browser-integration: 5.19.2
        plasma5-plasma-desktop: 5.19.2
        plasma5-plasma-workspace: 5.19.2
        plasma5-powerdevil: 5.19.2
        plasma5-systemsettings: 5.19.2
        poppler-qt5: 0.89.0_1

Installed packages to be UPGRADED:
        bash: 5.0.17 -> 5.0.18_1
        cups-filters: 1.27.5 -> 1.27.5_1
        curl: 7.71.0 -> 7.71.1
        dbus: 1.12.18 -> 1.12.20
        en_GB-libreoffice: 6.4.4 -> 6.4.5
        evince: 3.28.5_15 -> 3.28.5_16
        exiv2: 0.27.2,1 -> 0.27.3,1
        firefox: 78.0.1_1,1 -> 78.0.2,1
        ghostscript9-agpl-base: 9.52_5 -> 9.52_6
        gnupg: 2.2.20 -> 2.2.21
        graphviz: 2.44.0_4 -> 2.44.0_5
        help2man: 1.47.15 -> 1.47.16
        jackit: 0.125.0_9 -> 0.125.0_10
        libX11: 1.6.9_1,1 -> 1.6.9_2,1
        libaccounts-glib: 1.21_3 -> 1.25
        libaccounts-qt5: 1.13_10 -> 1.16_1
        libao: 1.2.0_4 -> 1.2.0_5
        libcec: 5.0.0 -> 6.0.0
        libconfuse: 3.2.1_1 -> 3.3
        libreoffice: 6.4.4 -> 6.4.5
        libssh2: 1.8.2,3 -> 1.9.0_2,3
        libvorbis: 1.3.7_1,3 -> 1.3.7_2,3
        libxfce4menu: 4.14.1_1 -> 4.14.1_2
        libxine: 1.2.9_12 -> 1.2.9_13
        llvm90: 9.0.1_1 -> 9.0.1_2
        mesa-dri: 19.0.8_8 -> 19.0.8_9
        mpfr: 4.0.2 -> 4.1.0
        mpg123: 1.26.1 -> 1.26.2_1
        mplayer: 1.4.0.20200621 -> 1.4.0.20200621_2
        mysql57-client: 5.7.30_2 -> 5.7.31
        mysql57-server: 5.7.30_2 -> 5.7.31
        node: 14.4.0 -> 14.5.0
        openal-soft: 1.20.1_1 -> 1.20.1_2
        openjdk8: 8.252.09.1_1 -> 8.252.09.1_2
        p5-HTTP-Message: 6.24 -> 6.25
        pciids: 20200529 -> 20200624
        poppler: 0.89.0_1 -> 0.90.0_1
        poppler-data: 0.4.9_3 -> 0.4.9_4
        poppler-glib: 0.89.0_1 -> 0.90.0_1
        poppler-utils: 0.89.0_1 -> 0.90.0_1
        popt: 1.18 -> 1.18_1
        portaudio: 19.6.0_4,1 -> 19.6.0_5,1
        py37-lxml: 4.5.1 -> 4.5.2
        qt5-buildtools: 5.14.2 -> 5.15.0
        qt5-concurrent: 5.14.2 -> 5.15.0
        qt5-core: 5.14.2_3 -> 5.15.0_1
        qt5-dbus: 5.14.2 -> 5.15.0
        qt5-qdbus: 5.14.2 -> 5.15.0
        qt5-qmake: 5.14.2 -> 5.15.0
        qt5-qtpaths: 5.14.2 -> 5.15.0
        qt5-script: 5.14.2 -> 5.15.0
        qt5-serialport: 5.14.2 -> 5.15.0
        qt5-sql: 5.14.2 -> 5.15.0
        qt5-sqldrivers-mysql: 5.14.2 -> 5.15.0
        qt5-sqldrivers-sqlite3: 5.14.2 -> 5.15.0
        qt5-testlib: 5.14.2 -> 5.15.0
        qt5-xml: 5.14.2 -> 5.15.0
        rar: 5.9.0,3 -> 5.9.1,3
        sdl: 1.2.15_14,2 -> 1.2.15_15,2
        sqlite3: 3.32.2,1 -> 3.32.3_1,1
        texlive-base: 20150521_52 -> 20150521_53
        tracker-miners: 2.0.5_18 -> 2.0.5_19
        unrar: 5.90,6 -> 5.91,6
        usbids: 20200329 -> 20200622
        xfce4-tumbler: 0.2.8_6 -> 0.2.8_7
        xkeyboard-config: 2.29 -> 2.29_1
        xterm: 356 -> 358
Installed packages to be REINSTALLED:
        libxkbcommon-0.10.0_2 (option added: X11)

Number of packages to be removed: 33
Number of packages to be upgraded: 67
Number of packages to be reinstalled: 1
 

mjollnir

Daemon

Reaction score: 832
Messages: 1,267

For some reason pkg(8) wants to remove your x11/kde5 packages. Maybe your package DB is bad. Update it with pkg update -f and then pkg upgrade -n will tell you which packages it wants to upgrade.
 
OP
D

dave01

New Member


Messages: 10

For some reason pkg(8) wants to remove your x11/kde5 packages. Maybe your package DB is bad. Update it with pkg update -f and then pkg upgrade -n will tell you which packages it wants to upgrade.

The pkg upgrade -f fixed it but I still think it was a conflict rather than a DB thing. It was happening on two of four boxes, the two which have KDE on them. Running pkg upgrade -F wanted to re-install and upgrade and not remove anything. I should have tried that, so thanks for pointing me in the right direction. Oh, and after that pkg upgrade -n now says no more upgrade required.
 

mjollnir

Daemon

Reaction score: 832
Messages: 1,267

pkg upgrade -F does only download (F for fetch). pkg upgrade -n does nothing except check & tell what would happen. A corrupted package DB catalogue is a GIGO situation.
 
OP
D

dave01

New Member


Messages: 10

Correct. I mis-read. Having said that, after trying to run a KDE based app I got the following error
Code:
Cannot mix incompatible Qt library (5.14.2) with this library (5.15.0)

I suspect that's the root cause of my woes and why the KDE related programs were about to be removed, especially since, as I said , it happened to two separate PCs at the same time.

I've now run pkg update -f, and a subsequent run of pkg upgrade reported no upgrade available. I'll run another pkg upgrade -f just in case that can sort out any remaining incompatibilities.

<sometime later>

No, a forced upgrade of packages didn't fix it, but at least no packages were deleted by pkg upgrade. I'm now considering just zapping all packages and re-install them again. Unfortunately, I have far less time on my hands now that furlogh is over and I'm back at work.
 
OP
D

dave01

New Member


Messages: 10

Additional info. I just tried rebuilding a QT5 program from ports and got this
Code:
===>>> Currently installed version: qt5-network-5.14.2
===>>> Port directory: /NEW_SLICE/usr/ports/net/qt5-network

    ===>>> This port is marked BROKEN
    ===>>> Qt5 requires Openssl 1.1.1, upgrade to FreeBSD 12.x/13.x or add DEFAULT_VERSIONS+=ssl=[openssl|libressl*] to /etc/make.conf
It's late and I need to get some sleep before work tomorrow so I'll just leave this for now. I'm guessing that I need to specify some version or other of xSSL or bite the bullet and switch to the 12.x branch.
 

monwarez

Member

Reaction score: 20
Messages: 60

Since qt5-network did not get build, but other parts of qt5 build fine, pkg correctly detect that it cannot keep package that depend of qt5-network if it has to upgrade other qt5 related component.

pkg help upgrade said:
Where a package on the work list supplies a shared library, and that
library has been updated, all packages requiring that shared library will
also be added to the work list as reinstallation jobs

The only fix is to not upgrade all port that have a dependency to qt5-network. And also all dependencies of previous port.

So when you do pkg upgrade -f, you are asking to pkg to ignore this kind of check (since you tell it to reinstall everything)

In your case, you need to change default version of openssl which should require rebuilding all port that depend on openssl from port
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,356
Messages: 33,927

I'm guessing that I need to specify some version or other of xSSL or bite the bullet and switch to the 12.x branch.
I would suggest upgrading to 12.1.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,356
Messages: 33,927

Switching to another SSL library is going to introduce problems on various other ports. And it involves building from ports to avoid weird dependency issues, which is not a problem for seasoned FreeBSD users but can be quite tricky for new users. Switching is not as easy as it sounds. To keep things simple and easily manageable upgrading to 12.1 is the best option.
 
OP
D

dave01

New Member


Messages: 10

To keep things simple and easily manageable upgrading to 12.1 is the best option.

Yes, I agree that sounds like the best option. I do have 3 or so ports locked which I re-build when a new package appears because I need specific options [dis|en]abled, but downgrading or replacing base SSL sounds like a recipe for future hair pulling. This is the push I needed to wipe the drive and start again. No, I'm not over-reacting!! I replaced the old HDD with a larger SSD some while ago and because of the partition and slice layout (dual boot), couldn't easily increase any existing slice sizes so created a new one and used symlinks to "move" stuff, ie the original HDD was quite small so running out of space was a real concern

Thanks everyone for your input. Now to go check for "gotchas" with the change 12.x. ISTR there are some :)
 
OP
D

dave01

New Member


Messages: 10

It seems any "gotchas" relating to upgrading to 12 have been resolved. The only issue I had was the keyboard appearing to send weird characters when trying to type in X. That turned out to be an xorg.conf setting to enable CTRL-ALT-BKSPC to force an exit from X in /usr/local/etc/X11/xorg.conf.d/keyboard.conf which contained
Code:
Section "InputClass"
        Identifier      "KeyboardDefaults"
        Driver          "keyboard"
        MatchIsKeyboard "on"
        Option          "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
Getting rid of that fixed the issue.
 

the3ajm

New Member


Messages: 10

I also bump into the same issue with pkg wanting to remove kde-related packages which I let it thinking that I can reinstall it later but it doesn't show up when I search for it then I looked into this thread and saw that it's best for me to upgrade: https://forums.freebsd.org/threads/...ackages-that-still-seem-to-have-a-port.76738/

After updating the packages, my resolution got downgraded so I had list the i915 module on the rc.conf file, install drm-kmod and tested out that xf86-video-intel causes a dead black screen after KDE login.
 
Top