Solved "pkg upgrade" outputs a lot of "indexinfo: Skipping: *.info: Capabilities insufficient"

quamenzullo

Active Member

Reaction score: 23
Messages: 163

Hello!

I performed this in a jail: # pkg upgrade python27 python36 librsvg2 gnutls (These packages are here just as examples, because this happens with any kind of package, since some time. Everything seems to work further fine, but I wonder what this is and how to fix it.)

Here's the start of the "Extracting" phase:

Code:
[web0] [1/21] Upgrading libxml2 from 2.9.7 to 2.9.10...
[web0] [1/21] Extracting libxml2-2.9.10: 100%
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: :
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: ldconfig_start
/etc/rc.d/ldconfig: DEBUG: checkyesno: ldconfig_insecure is set to NO.
[web0] [2/21] Upgrading readline from 8.0.0 to 8.0.4...
[web0] [2/21] Extracting readline-8.0.4: 100%
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: :
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: ldconfig_start
/etc/rc.d/ldconfig: DEBUG: checkyesno: ldconfig_insecure is set to NO.
indexinfo: Skipping: asy-faq.info: Capabilities insufficient
indexinfo: Skipping: asymptote.info: Capabilities insufficient
indexinfo: Skipping: dvipng.info: Capabilities insufficient
indexinfo: Skipping: dvips.info: Capabilities insufficient
indexinfo: Skipping: eplain.info: Capabilities insufficient
indexinfo: Skipping: epspdf.info: Capabilities insufficient
indexinfo: Skipping: fontname.info: Capabilities insufficient
indexinfo: Skipping: kpathsea.info: Capabilities insufficient
indexinfo: Skipping: latex2e-es.info: Capabilities insufficient
indexinfo: Skipping: latex2e-fr.info: Capabilities insufficient
indexinfo: Skipping: latex2e.info: Capabilities insufficient
indexinfo: Skipping: latex2man.info: Capabilities insufficient
indexinfo: Skipping: mf2pt1.info: Capabilities insufficient
indexinfo: Skipping: tds.info: Capabilities insufficient
indexinfo: Skipping: texdraw.info: Capabilities insufficient
indexinfo: Skipping: tlbuild.info: Capabilities insufficient
indexinfo: Skipping: web2c.info: Capabilities insufficient
indexinfo: Impossible to write the index file: Capabilities insufficient
indexinfo: Skipping: asy-faq.info: Capabilities insufficient
indexinfo: Skipping: asymptote.info: Capabilities insufficient
indexinfo: Skipping: dvipng.info: Capabilities insufficient
indexinfo: Skipping: dvips.info: Capabilities insufficient
indexinfo: Skipping: eplain.info: Capabilities insufficient
indexinfo: Skipping: epspdf.info: Capabilities insufficient
indexinfo: Skipping: fontname.info: Capabilities insufficient
indexinfo: Skipping: kpathsea.info: Capabilities insufficient
indexinfo: Skipping: latex2e-es.info: Capabilities insufficient
indexinfo: Skipping: latex2e-fr.info: Capabilities insufficient
indexinfo: Skipping: latex2e.info: Capabilities insufficient
indexinfo: Skipping: latex2man.info: Capabilities insufficient
indexinfo: Skipping: mf2pt1.info: Capabilities insufficient
indexinfo: Skipping: tds.info: Capabilities insufficient
indexinfo: Skipping: texdraw.info: Capabilities insufficient
indexinfo: Skipping: tlbuild.info: Capabilities insufficient
indexinfo: Skipping: web2c.info: Capabilities insufficient
indexinfo: Impossible to write the index file: Capabilities insufficient
indexinfo: Skipping: asy-faq.info: Capabilities insufficient
indexinfo: Skipping: asymptote.info: Capabilities insufficient
indexinfo: Skipping: dvipng.info: Capabilities insufficient
indexinfo: Skipping: dvips.info: Capabilities insufficient
indexinfo: Skipping: eplain.info: Capabilities insufficient
indexinfo: Skipping: epspdf.info: Capabilities insufficient
indexinfo: Skipping: fontname.info: Capabilities insufficient
indexinfo: Skipping: kpathsea.info: Capabilities insufficient
indexinfo: Skipping: latex2e-es.info: Capabilities insufficient
indexinfo: Skipping: latex2e-fr.info: Capabilities insufficient
indexinfo: Skipping: latex2e.info: Capabilities insufficient
indexinfo: Skipping: latex2man.info: Capabilities insufficient
indexinfo: Skipping: mf2pt1.info: Capabilities insufficient
indexinfo: Skipping: tds.info: Capabilities insufficient
indexinfo: Skipping: texdraw.info: Capabilities insufficient
indexinfo: Skipping: tlbuild.info: Capabilities insufficient
indexinfo: Skipping: web2c.info: Capabilities insufficient
indexinfo: Impossible to write the index file: Capabilities insufficient
pkg: POST-INSTALL script failed
[web0] [3/21] Upgrading gettext-runtime from 0.20.1 to 0.20.2...
[web0] [3/21] Extracting gettext-runtime-0.20.2: 100%
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: :
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: ldconfig_start
/etc/rc.d/ldconfig: DEBUG: checkyesno: ldconfig_insecure is set to NO.
indexinfo: Skipping: asy-faq.info: Capabilities insufficient
and it goes on and on.

The names evoke LaTeX, but as print/texlive-full had not been updated for while, I switched to using tlmgr directly. So, pkg knows nothing about my TeX Live installation. I wonder why it would have anything to do with TeX Live and even more why it would complain about it.

The "Capabilities insufficient" evoke a lack of space. But:

Code:
# df -h
Filesystem       Size    Used   Avail Capacity  Mounted on
/dev/ada0s1a      19G    9,0G    8,4G    52%    /
devfs            1,0K    1,0K      0B   100%    /dev
/dev/ada0s1b     9,5G    246M    8,5G     3%    /home
/dev/ada0s1e     873G    552G    251G    69%    /srv
procfs           4,0K    4,0K      0B   100%    /proc
fdescfs          1,0K    1,0K      0B   100%    /dev/fd
/srv/basejail    873G    552G    251G    69%    /srv/web0/basejail
devfs            1,0K    1,0K      0B   100%    /srv/web0/dev
fdescfs          1,0K    1,0K      0B   100%    /srv/web0/dev/fd
procfs           4,0K    4,0K      0B   100%    /srv/web0/proc
/srv/basejail    873G    552G    251G    69%    /srv/testmm0/basejail
devfs            1,0K    1,0K      0B   100%    /srv/testmm0/dev
fdescfs          1,0K    1,0K      0B   100%    /srv/testmm0/dev/fd
procfs           4,0K    4,0K      0B   100%    /srv/testmm0/proc
/srv/basejail    873G    552G    251G    69%    /srv/sftp0/basejail
devfs            1,0K    1,0K      0B   100%    /srv/sftp0/dev
fdescfs          1,0K    1,0K      0B   100%    /srv/sftp0/dev/fd
procfs           4,0K    4,0K      0B   100%    /srv/sftp0/proc
/srv/basejail    873G    552G    251G    69%    /srv/dev_web0_php/basejail
devfs            1,0K    1,0K      0B   100%    /srv/dev_web0_php/dev
fdescfs          1,0K    1,0K      0B   100%    /srv/dev_web0_php/dev/fd
procfs           4,0K    4,0K      0B   100%    /srv/dev_web0_php/proc
/srv/basejail    873G    552G    251G    69%    /srv/dev_web0/basejail
devfs            1,0K    1,0K      0B   100%    /srv/dev_web0/dev
fdescfs          1,0K    1,0K      0B   100%    /srv/dev_web0/dev/fd
procfs           4,0K    4,0K      0B   100%    /srv/dev_web0/proc

Also, I've tried to find out about indexinfo. print/texinfo on fresh ports says "Small utility designed to regenerate the GNU info page indexes". It seems required by a bunch of packages installed in the jail.

Any clue?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,151
Messages: 39,766

Code:
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: : 
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: ldconfig_start 
/etc/rc.d/ldconfig: DEBUG: checkyesno: ldconfig_insecure is set to NO.
I wonder why you're getting these messages.

What does freebsd-version and pkg -v tell you?
 
OP
quamenzullo

quamenzullo

Active Member

Reaction score: 23
Messages: 163

Code:
root@web0:~# pkg -v
1.14.4
root@web0:~ # freebsd-version
11.3-RELEASE-p3
root@web0:~ #

The host is up-to-date:
Code:
# freebsd-version
11.3-RELEASE-p9

As the jail does not display the correct information, I guess I've missed a step at some point. I thought the step I'm thinking about would only concern minor upgrades of the host system, but I'm gonna check this.

Also, as you wonder about this, it reminds me that maybe I should add a detail I did not think was relevant: I think I may have had a bad upgrade strategy. I didn't dare to ask about it, but reading somewhere "If it ain't broken, don't fix it" I understood it as "As long as it works, do not upgrade". Hence, except for the security updates (reported by pkg audit and the system ones that got fixed by freebsd-update fetch and freebsd-update install), I didn't upgrade anything. Might this be the source of the problem? I am a bit afraid of upgrading everything because I fear it indeed breaks something somewhere...
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,151
Messages: 39,766

I didn't upgrade anything. Might this be the source of the problem?
That's possible but pkg(8) itself is fairly self-contained. Do you get the same errors if you use pkg-static?

I am a bit afraid of upgrading everything because I fear it indeed breaks something somewhere...
Just use pkg upgrade and upgrade everything. There's always a possibility things break. Just deal with those when they happen. By only selectively updating you run the risk of getting dependencies of dependencies of dependencies (yes, this chain can get quite long) out of order. Treat the system as a whole, that will cause the least amount of problems.
 

memreflect

Well-Known Member

Reaction score: 224
Messages: 257

Looking at the source code for the latest print/indexinfo, nothing indicates the openat() call that generates the error message should be failing, though print/texlive-docs seems to have its own info directory file (.../info/dir) according to its pkg-plist file, and that's likely something indexinfo might not expect as it's the only port that has one.

I would try updating print/indexinfo to see if it resolves the problem. If that doesn't work, your next step is to uninstall and/or upgrade print/texlive-docs. Other than that, I'm out of ideas. If it's just those info files from print/texlive-docs, it's almost certainly a problem with that specific package.
 
OP
quamenzullo

quamenzullo

Active Member

Reaction score: 23
Messages: 163

Do you get the same errors if you use pkg-static?

Yes, I've just tried in another jail (quite a clone of the first one) with a random package:

Rich (BB code):
# pkg-static upgrade screen
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 3 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
    compat7x-amd64: 7.4.704000.201310.1
    perl5.26: 5.26.3

Installed packages to be UPGRADED:
    screen: 4.6.2 -> 4.8.0

Number of packages to be installed: 2
Number of packages to be upgraded: 1

The process will require 71 MiB more space.
19 MiB to be downloaded.

Proceed with this action? [y/N]: y
[dev_web0] [1/3] Fetching screen-4.8.0.txz: 100%  502 KiB 514.2kB/s    00:01  
[dev_web0] [2/3] Fetching perl5.26-5.26.3.txz: 100%   14 MiB  14.5MB/s    00:01  
[dev_web0] [3/3] Fetching compat7x-amd64-7.4.704000.201310.1.txz: 100%    5 MiB   5.2MB/s    00:01  
Checking integrity... done (0 conflicting)
[dev_web0] [1/3] Upgrading screen from 4.6.2 to 4.8.0...
[dev_web0] [1/3] Extracting screen-4.8.0: 100%
indexinfo: Skipping: asy-faq.info: Capabilities insufficient
indexinfo: Skipping: asymptote.info: Capabilities insufficient
[...]
indexinfo: Skipping: web2c.info: Capabilities insufficient
indexinfo: Impossible to write the index file: Capabilities insufficient
pkg-static: POST-INSTALL script failed
[dev_web0] [2/3] Installing perl5.26-5.26.3...
[dev_web0] [2/3] Extracting perl5.26-5.26.3: 100%
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: :
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: ldconfig_start
/etc/rc.d/ldconfig: DEBUG: checkyesno: ldconfig_insecure is set to NO.
[dev_web0] [3/3] Installing compat7x-amd64-7.4.704000.201310.1...
[dev_web0] [3/3] Extracting compat7x-amd64-7.4.704000.201310.1: 100%
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: :
/etc/rc.d/ldconfig: DEBUG: run_rc_command: doit: ldconfig_start
/etc/rc.d/ldconfig: DEBUG: checkyesno: ldconfig_insecure is set to NO.
=====
Message from perl5.26-5.26.3:
[...]
 
OP
quamenzullo

quamenzullo

Active Member

Reaction score: 23
Messages: 163

I would try updating print/indexinfo to see if it resolves the problem.
Unfortunately it's already up to date.

If that doesn't work, your next step is to uninstall and/or upgrade print/texlive-docs.
This one is not installed. That's weird. Or maybe there are leftovers from an old install? (I think I've installed some texlive related packages at some point, then removed them all: could that be, that some stuff has been left?). Also, I wonder if tlmgr could interfere with pkg?
 

memreflect

Well-Known Member

Reaction score: 224
Messages: 257

This one is not installed. That's weird. Or maybe there are leftovers from an old install?
According to r318747 (May 2013), print/texlive-texmf used to contain those files before the documentation was split into a separate package. If pkg list texlive-texmf | grep '\.info$' doesn't list anything, then it's safe to delete them.

Also, I wonder if tlmgr could interfere with pkg?
That's possible, but it's very unlikely. tlmgr, or any other command, shouldn't ever clash with pkg.
 
OP
quamenzullo

quamenzullo

Active Member

Reaction score: 23
Messages: 163

I've tried to locate them:

Code:
# find / -name "web2c.info"
/usr/local/share/info/web2c.info
/usr/local/texlive/2017/texmf-dist/doc/info/web2c.info
/usr/local/texlive/2018/texmf-dist/doc/info/web2c.info

I guess the ones to remove are the ones from /usr/local/share/info/, the other ones being from my Tex Live installation via tlmgr. So I'm gonna try to move them (before removing them).
 
OP
quamenzullo

quamenzullo

Active Member

Reaction score: 23
Messages: 163

So I'm gonna try to move them (before removing them).

Not too quick: these are actually symlinks to the 2018 TeX Live installation.

I could remove them simply via tlmgr path remove. Then the indexinfo messages seem to be gone (I've tried upgrading a few packages). The ldconfig messages are still there, though. I guess they're not related, that's two different things.

Anyway I need to have the TeX Live installation accessible by the system. Not using the symlinks automatically setup by tlmgr, I can setup some environment variables instead (as explained here). Let's see if the indexinfo messages are still gone after that...
 
OP
quamenzullo

quamenzullo

Active Member

Reaction score: 23
Messages: 163

I thought perhaps you had enabled it for some reason, which is why I didn't mention it.
Yes, I forgot it, but did it a long time ago. Thank you for that!

As to the TeX Live installation, I just need to set the environment variables (as detailed in the link of my previous post) and not use the automatic symlinks. As some other config files did point to binaries I needed in /usr/local/bin/, I added the missing symlinks myself, and it works.

So, as I do not need the /usr/local/share/info/*.info files that are installed by tlmgr's auto-symlinking feature, and as they seem to disturb the pkg operations (not too much but these messages floods are annoying), I keep them removed. I guess that's solved.
 
Top