"pkg upgrade" and conflicts

cartland

New Member


Messages: 8

"pkg upgrade" downloads about a Gig of files then gives:

"locally installed djvulibre-nox11-3.5.24 conflicts on /usr/local/share/djvu/pubtext/DjVuXML-s.dtd with - djvulibre-nox11-3.5.25.3_1"​

What's the best way of resolving this (and other conflicts) with the pkgng system?

thanks
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 944
Messages: 2,140

You must read always /usr/ports/UPDATING before any update:
[CMD=]$ less "+/djvulibre" /usr/ports/UPDATING[/CMD]
20120613:
AFFECTS: users of graphics/djvulibre and graphics/djvulibre-nox11
AUTHOR: bf@FreeBSD.org

DjVuLibre been updated to 3.5.25.3. The QT3 GUI that was in
graphics/djvulibre has been removed (users of this GUI should consider
switching to the new QT4 GUI in graphics/djview4), and
graphics/djvulibre-nox11 has been merged back into graphics/djvulibre.
To update DjVuLibre, you can use:

# pkg_delete djvulibre-\?.\*
# portmaster -o graphics/djvulibre djvulibre-nox11

You should then update any installed ports that link to the djvulibre shared
library: converters/pdf2djvu, graphics/djview4, graphics/okular, and --
if optional djvulibre support was enabled -- graphics/ImageMagick,
graphics/apvlv, and graphics/evince.
 
OP
OP
C

cartland

New Member


Messages: 8

cpu82 said:
You must read always /usr/ports/UPDATING before any update:
[CMD=]$ less "+/djvulibre" /usr/ports/UPDATING[/CMD]
Thanks.

This was my first freebsd install, and I used a combination of ports, sysinstall, and pkgng. Clearly the source of all my problems (freebsd related ;) ).

I have started again with a fresh install (virtualbox guest on Ubuntu host), carefully documenting the whole process. This time I just used pkgng which I found to be excellent. I was able to get the whole system up an running with NSF, KDE, cmake, nodejs, doxygen, etc and building my software within a day. All error free. :e :beergrin.
 
Top