pkg update does nothing with PHP56

dave

Well-Known Member

Reaction score: 24
Messages: 421

I read in UPDATING that the default version of php has bumped from 5.6 to 7.1. I would like to stay with the php56 version for now. I tried to put this in /etc/make.conf and it seems to have no effect on pkg either way:
Code:
DEFAULT_VERSIONS+= php=5.6
But...
Code:
$ sudo pkg update && pkg version -vRL= && sudo pkg upgrade
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
google-daemon-1.2.1_1              ?   orphaned: net/google-daemon
google-startup-scripts-1.2.1       ?   orphaned: net/google-startup-scripts
p5-Net-SMTP-SSL-1.04               ?   orphaned: mail/p5-Net-SMTP-SSL
php56-5.6.36_1                     <   needs updating (remote has 5.6.38)
php56-bz2-5.6.36_1                 <   needs updating (remote has 5.6.38)
php56-composer-1.6.5               <   needs updating (remote has 1.7.2)
php56-ctype-5.6.36_1               <   needs updating (remote has 5.6.38)
php56-curl-5.6.36_1                <   needs updating (remote has 5.6.38)
php56-dom-5.6.36_1                 <   needs updating (remote has 5.6.38)
php56-filter-5.6.36_1              <   needs updating (remote has 5.6.38)
php56-gd-5.6.36_1                  <   needs updating (remote has 5.6.38)
php56-hash-5.6.36_1                <   needs updating (remote has 5.6.38)
php56-iconv-5.6.36_1               <   needs updating (remote has 5.6.38)
php56-imap-5.6.36_1                <   needs updating (remote has 5.6.38)
php56-json-5.6.36_1                <   needs updating (remote has 5.6.38)
php56-mbstring-5.6.36_1            <   needs updating (remote has 5.6.38)
php56-mcrypt-5.6.36_1              <   needs updating (remote has 5.6.38)
php56-mysql-5.6.36_1               <   needs updating (remote has 5.6.38)
php56-mysqli-5.6.36_1              <   needs updating (remote has 5.6.38)
php56-opcache-5.6.36_1             <   needs updating (remote has 5.6.38)
php56-openssl-5.6.36_1             <   needs updating (remote has 5.6.38_1)
php56-pdo-5.6.36_1                 <   needs updating (remote has 5.6.38)
php56-pdo_sqlite-5.6.36_1          <   needs updating (remote has 5.6.38)
php56-pecl-intl-3.0.0_14           <   needs updating (remote has 3.0.0_15)
php56-phar-5.6.36_1                <   needs updating (remote has 5.6.38)
php56-posix-5.6.36_1               <   needs updating (remote has 5.6.38)
php56-session-5.6.36_1             <   needs updating (remote has 5.6.38)
php56-simplexml-5.6.36_1           <   needs updating (remote has 5.6.38)
php56-soap-5.6.36_1                <   needs updating (remote has 5.6.38)
php56-sqlite3-5.6.36_1             <   needs updating (remote has 5.6.38)
php56-tokenizer-5.6.36_1           <   needs updating (remote has 5.6.38)
php56-xml-5.6.36_1                 <   needs updating (remote has 5.6.38)
php56-xmlreader-5.6.36_1           <   needs updating (remote has 5.6.38)
php56-xmlwriter-5.6.36_1           <   needs updating (remote has 5.6.38)
php56-zip-5.6.36_1                 <   needs updating (remote has 5.6.38)
php56-zlib-5.6.36_1                <   needs updating (remote has 5.6.38)
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking for upgrades (33 candidates): 100%
Processing candidates (33 candidates): 100%
Checking integrity... done (0 conflicting)
Your packages are up to date.
Nothing happens to the php56 pkgs even though pkg reports they are due for upgrade.

What am I missing?

Thanks!
 

VladiBG

Aspiring Daemon

Reaction score: 252
Messages: 615

what is the output of
freebsd-version -ku
cat /etc/pkg/FreeBSD.conf | egrep -v '^$|^#'
cat /usr/local/etc/pkg.conf | egrep -v '^$|^#'
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,875
Messages: 31,140

I read in UPDATING that the default version of php has bumped from 5.6 to 7.1.
It's actually 7.2 now, 7.1 was the default for a very short period.

I tried to put this in /etc/make.conf and it seems to have no effect on pkg either way:
That's correct. That setting is only used when building from ports.
 
OP
OP
dave

dave

Well-Known Member

Reaction score: 24
Messages: 421

freebsd-version -ku
Code:
11.2-RELEASE-p4
11.2-RELEASE-p4

cat /etc/pkg/FreeBSD.conf | egrep -v '^$|^#'
Code:
FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/quarterly",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/share/keys/pkg",
  enabled: yes
}

cat /usr/local/etc/pkg.conf | egrep -v '^$|^#'
Code:
ALIAS              : {
  all-depends: query %dn-%dv,
  annotations: info -A,
  build-depends: info -qd,
  cinfo: info -Cx,
  comment: query -i "%c",
  csearch: search -Cx,
  desc: query -i "%e",
  download: fetch,
  iinfo: info -ix,
  isearch: search -ix,
  prime-list: "query -e '%a = 0' '%n'",
  prime-origins: "query -e '%a = 0' '%o'",
  leaf: "query -e '%#r == 0' '%n-%v'",
  list: info -ql,
  noauto = "query -e '%a == 0' '%n-%v'",
  options: query -i "%n - %Ok: %Ov",
  origin: info -qo,
  provided-depends: info -qb,
  raw: info -R,
  required-depends: info -qr,
  roptions: rquery -i "%n - %Ok: %Ov",
  shared-depends: info -qB,
  show: info -f -k,
  size: info -sq,
  }
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,875
Messages: 31,140

Try forcing an update of the cached repository data: pkg update -f. Sometimes things can get a bit out of sync and it would fail to notice updates.
 

VladiBG

Aspiring Daemon

Reaction score: 252
Messages: 615

I suspect that you are not using the quarterly repo which actualy has php56-5.6.38 but you are ok.
Your update process may be interrupted because of the package p5-Net-SMTP-SSL-1.04 which is orphaned and depend of the old php56-5.6.36_1 which denied further update.
You can manually delete the orphaned packages and try again but first check what packages required them using
pkg info -r p5-Net-SMTP-SSL-1.04

edit: also you can check what depend of it with
pkg info -d p5-Net-SMTP-SSL-1.04
 
OP
OP
dave

dave

Well-Known Member

Reaction score: 24
Messages: 421

I replaced the orphaned pkg with sudo pkg delete p5-Net-SMTP-SSL-1.04 and sudo pkg install p5-Net-SMTPS. No change.

Also no change after pkg update -f.

For now, I'm going to drop this as the upgrade is not critical at this time. Going to work toward the upgrade to php7. In the meantime, if I figure it out, I will post the solution. If anyone has other suggestions, I welcome them.

Thanks!
 

VladiBG

Aspiring Daemon

Reaction score: 252
Messages: 615

Check if there's anything else that is orphaned and depend of old php56 and also if there's any locked packages.
pkg lock -l

pkg upgrade -f will force the re-installation of all packages which i think is not necessary.

pkg autoremove -n will show you all orphaned packages without removing anything
 
Top