pkg(8) --chroot with packages created by poudriere, and /var/log/messages

grahamperrin

Son of Beastie

Reaction score: 793
Messages: 2,555

pkg(8) supports -c <chroot path> command-line option; try …

The package data in /usr/local/poudriere/data/packages – how best to make this available?

A symbolic link, maybe?

Code:
root@mowa219-gjp4-8570p:~ # date ; uname -v
Fri May  7 06:49:39 BST 2021
FreeBSD 14.0-CURRENT #94 main-n246499-097e8701c9f: Thu May  6 07:26:23 BST 2021     root@mowa219-gjp4-8570p:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG
root@mowa219-gjp4-8570p:~ # pkg update
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating FreeBSD-base repository catalogue...
FreeBSD-base repository is up to date.
Updating poudriere repository catalogue...
Fetching meta.conf: 100%    163 B   0.2kB/s    00:01   
Fetching packagesite.txz: 100%   21 KiB  21.0kB/s    00:01   
Processing entries: 100%
The provides database is up-to-date.
poudriere repository update completed. 74 packages processed.
All repositories are up to date.
root@mowa219-gjp4-8570p:~ # bectl list -c creation
BE                    Active Mountpoint Space Created
r357746-Waterfox      -      -          59.2G 2020-03-10 18:24
n246330-5eb9c93a20d-d -      -          4.95G 2021-05-05 08:54
n246330-5eb9c93a20d-e -      -          146M  2021-05-05 21:57
n246499-097e8701c9f-a NR     /          106G  2021-05-06 07:47
root@mowa219-gjp4-8570p:~ # bectl create n246499-097e8701c9f-b
root@mowa219-gjp4-8570p:~ # bectl mount n246499-097e8701c9f-b /tmp/up
Successfully mounted n246499-097e8701c9f-b at /tmp/up
root@mowa219-gjp4-8570p:~ # pkg --chroot /tmp/up upgrade -y
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating FreeBSD-base repository catalogue...
FreeBSD-base repository is up to date.
Updating poudriere repository catalogue...
pkg: file:///usr/local/poudriere/data/packages/main-default/meta.txz: No such file or directory
repository poudriere has no meta file, using default settings
pkg: file:///usr/local/poudriere/data/packages/main-default/packagesite.txz: No such file or directory
Unable to update repository poudriere
Error updating repositories!
root@mowa219-gjp4-8570p:~ # ls -hl /tmp/up/usr/local/poudriere/data/
total 0
root@mowa219-gjp4-8570p:~ # zfs get mountpoint copperbowl/poudriere/data/packages
NAME                                PROPERTY    VALUE                               SOURCE
copperbowl/poudriere/data/packages  mountpoint  /usr/local/poudriere/data/packages  inherited from copperbowl/poudriere/data
root@mowa219-gjp4-8570p:~ # pkg -vv | grep -A 20 Repositories
Repositories:
  FreeBSD: {
    url             : "pkg+http://pkg.FreeBSD.org/FreeBSD:14:amd64/latest",
    enabled         : yes,
    priority        : 3,
    mirror_type     : "SRV",
    signature_type  : "FINGERPRINTS",
    fingerprints    : "/usr/share/keys/pkg"
  }
  FreeBSD-base: {
    url             : "https://alpha.pkgbase.live/current/FreeBSD:14:amd64/latest",
    enabled         : yes,
    priority        : 0,
    signature_type  : "PUBKEY",
    pubkey          : "/usr/share/keys/pkg/trusted/alpha.pkgbase.live.pub"
  }
  poudriere: {
    url             : "file:///usr/local/poudriere/data/packages/main-default",
    enabled         : yes,
    priority        : 4
  }
root@mowa219-gjp4-8570p:~ # pkg info -x poudriere-devel
poudriere-devel-3.3.99.20210303_2
root@mowa219-gjp4-8570p:~ #
 
OP
grahamperrin

grahamperrin

Son of Beastie

Reaction score: 793
Messages: 2,555

Thanks. Whilst I can't conceptualise a loopback file system, I'm happy that it has the required effect:

Code:
root@mowa219-gjp4-8570p:~ # bectl list -c creation
BE                    Active Mountpoint Space Created
r357746-Waterfox      -      -          59.2G 2020-03-10 18:24
n246330-5eb9c93a20d-d -      -          4.95G 2021-05-05 08:54
n246330-5eb9c93a20d-e -      -          146M  2021-05-05 21:57
n246499-097e8701c9f-a NR     /          106G  2021-05-06 07:47
n246499-097e8701c9f-b -      /tmp/up    1.87M 2021-05-07 06:53
root@mowa219-gjp4-8570p:~ # mount_nullfs /usr/local/poudriere/data /tmp/up/usr/local/poudriere/data
root@mowa219-gjp4-8570p:~ # pkg --chroot /tmp/up upgrade -y
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating FreeBSD-base repository catalogue...
FreeBSD-base repository is up to date.
Updating poudriere repository catalogue...
pkg: file:///usr/local/poudriere/data/packages/main-default/meta.txz: No such file or directory
repository poudriere has no meta file, using default settings
pkg: file:///usr/local/poudriere/data/packages/main-default/packagesite.txz: No such file or directory
Unable to update repository poudriere
Error updating repositories!
root@mowa219-gjp4-8570p:~ # mount_nullfs /usr/local/poudriere/data/packages /tmp/up/usr/local/poudriere/data/packages
root@mowa219-gjp4-8570p:~ # pkg --chroot /tmp/up upgrade -y
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating FreeBSD-base repository catalogue...
FreeBSD-base repository is up to date.
Updating poudriere repository catalogue...
Fetching meta.conf: 100%    163 B   0.2kB/s    00:01   
Fetching packagesite.txz: 100%   21 KiB  21.0kB/s    00:01   
Processing entries: 100%
The provides database is up-to-date.
poudriere repository update completed. 74 packages processed.
All repositories are up to date.
Checking for upgrades (4 candidates): 100%
Processing candidates (4 candidates): 100%
Checking integrity... done (0 conflicting)
Your packages are up to date.
root@mowa219-gjp4-8570p:~ # pkg --chroot /tmp/up upgrade -f poudriere-devel
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating FreeBSD-base repository catalogue...
FreeBSD-base repository is up to date.
Updating poudriere repository catalogue...
poudriere repository is up to date.
All repositories are up to date.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be REINSTALLED:
        poudriere-devel-3.3.99.20210303_2 [FreeBSD]

Number of packages to be reinstalled: 1

738 KiB to be downloaded.

Proceed with this action? [y/N]: n
root@mowa219-gjp4-8570p:~ # umount /tmp/up/usr/local/poudriere/data/packages
root@mowa219-gjp4-8570p:~ # umount /tmp/up/usr/local/poudriere/data
root@mowa219-gjp4-8570p:~ # bectl umount n246499-097e8701c9f-b
root@mowa219-gjp4-8570p:~ # bectl destroy n246499-097e8701c9f-b
root@mowa219-gjp4-8570p:~ #
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,673
Messages: 39,278

Alternatively you could also set up a simple webserver and share that packages directory through that. That will also make it easier for other systems on your network to use it. Poudriere also has a nice web interface where you can keep track of its status, build runs, etc.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,673
Messages: 39,278

The reason it's not part of the BE you created is because it's on a different dataset (copperbowl/poudriere/data) that's not part of the root filesystem (probably zroot/ROOT/default). That's why the jail/chroot initially couldn't find it.

That loopback nullfs(5) trick is quite useful for many other things.
 
OP
grahamperrin

grahamperrin

Son of Beastie

Reaction score: 793
Messages: 2,555

Below, no log of the upgrade routine in /var/log/messages, so I unmounted volumes then destroyed the boot environment.

Is logging achievable with the --chroot option of pkg?

Code:
root@mowa219-gjp4-8570p:~ # bectl list -c creation
BE                    Active Mountpoint Space Created
r357746-Waterfox      -      -          59.2G 2020-03-10 18:24
n246330-5eb9c93a20d-d -      -          4.95G 2021-05-05 08:54
n246330-5eb9c93a20d-e -      -          147M  2021-05-05 21:57
n246499-097e8701c9f-a NR     /          106G  2021-05-06 07:47
root@mowa219-gjp4-8570p:~ # bectl create n246499-097e8701c9f-b
root@mowa219-gjp4-8570p:~ # bectl mount n246499-097e8701c9f-b /tmp/up
Successfully mounted n246499-097e8701c9f-b at /tmp/up
root@mowa219-gjp4-8570p:~ # mount_nullfs /var/log /tmp/up/var/log
root@mowa219-gjp4-8570p:~ # mount_nullfs /usr/local/poudriere/data /tmp/up/usr/local/poudriere/data
root@mowa219-gjp4-8570p:~ # mount_nullfs /usr/local/poudriere/data/packages /tmp/up/usr/local/poudriere/data/packages
root@mowa219-gjp4-8570p:~ # pkg --chroot /tmp/up upgrade
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating FreeBSD-base repository catalogue...
FreeBSD-base repository is up to date.
Updating poudriere repository catalogue...
poudriere repository is up to date.
All repositories are up to date.
Checking for upgrades (23 candidates): 100%
Processing candidates (23 candidates): 100%
The following 30 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        Ipopt: 3.12.13_3 [FreeBSD]
        coin-or-Clp: 1.17.3_3 [FreeBSD]
        coin-or-CoinUtils: 2.11.4_1 [FreeBSD]
        coin-or-Data-Netlib: 1.2.9 [FreeBSD]
        coin-or-Data-Sample: 1.2.12 [FreeBSD]
        coin-or-asl: 1.4.3 [FreeBSD]
        coin-or-cbc: 2.10.5_1 [FreeBSD]
        coin-or-cgl: 0.60.3_1 [FreeBSD]
        evolution-data-server: 3.40.0_1 [FreeBSD]
        gnugrep: 3.6 [FreeBSD]
        py38-importlib-metadata: 3.3.0_1 [FreeBSD]

Installed packages to be UPGRADED:
        CoinMP: 1.8.4_3 -> 1.8.4_4 [FreeBSD]
        aom: 3.0.0 -> 3.1.0 [FreeBSD]
        bpytop: 1.0.64 -> 1.0.65 [FreeBSD]
        bsdstats: 7.0 -> 7.0_1 [FreeBSD]
        debootstrap: 1.0.123_4 -> 1.0.123_5 [FreeBSD]
        firefox: 88.0_2,2 -> 88.0.1,2 [FreeBSD]
        liberation-fonts-ttf: 2.1.3,2 -> 2.1.4,2 [FreeBSD]
        libpurple: 2.14.3_2 -> 2.14.4 [FreeBSD]
        openjdk11: 11.0.10+9.1_1 -> 11.0.11+9.1 [FreeBSD]
        openjdk11-jre: 11.0.10+9.1_1 -> 11.0.11+9.1 [FreeBSD]
        openjdk8: 8.282.08.1 -> 8.292.10.1 [FreeBSD]
        pidgin: 2.14.3_2 -> 2.14.4 [FreeBSD]
        py38-markdown: 2.6.11_1 -> 3.3.4 [FreeBSD]
        stunnel: 5.58,1 -> 5.59,1 [FreeBSD]
        thunderbird: 78.10.0_1 -> 78.10.1 [FreeBSD]
        twm: 1.0.11 -> 1.0.11_1 [FreeBSD]
        wayland-protocols: 1.20 -> 1.21 [FreeBSD]
        xfce4-clipman-plugin: 1.6.1_1 -> 1.6.2 [FreeBSD]

Installed packages to be REINSTALLED:
        apache-openoffice-devel-4.2.1619649022_4,4 [FreeBSD] (needed shared library changed)

Number of packages to be installed: 11
Number of packages to be upgraded: 18
Number of packages to be reinstalled: 1

The process will require 90 MiB more space.
481 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/30] Fetching xfce4-clipman-plugin-1.6.2.txz: 100%  154 KiB 157.9kB/s    00:01    
[2/30] Fetching wayland-protocols-1.21.txz: 100%   60 KiB  61.0kB/s    00:01    
[3/30] Fetching twm-1.0.11_1.txz: 100%   89 KiB  90.6kB/s    00:01    
[4/30] Fetching thunderbird-78.10.1.txz: 100%   47 MiB   8.3MB/s    00:06    
[5/30] Fetching stunnel-5.59,1.txz: 100%  185 KiB 189.6kB/s    00:01    
[6/30] Fetching py38-markdown-3.3.4.txz: 100%  126 KiB 129.5kB/s    00:01    
[7/30] Fetching pidgin-2.14.4.txz: 100%    1 MiB   1.2MB/s    00:01    
[8/30] Fetching openjdk8-8.292.10.1.txz: 100%   81 MiB   9.4MB/s    00:09    
[9/30] Fetching openjdk11-jre-11.0.11+9.1.txz: 100%   23 MiB  12.1MB/s    00:02    
[10/30] Fetching openjdk11-11.0.11+9.1.txz: 100%  158 MiB   9.2MB/s    00:18    
[11/30] Fetching libpurple-2.14.4.txz: 100%    5 MiB   5.4MB/s    00:01    
[12/30] Fetching liberation-fonts-ttf-2.1.4,2.txz: 100%    1 MiB   1.5MB/s    00:01    
[13/30] Fetching firefox-88.0.1,2.txz: 100%   54 MiB   9.4MB/s    00:06    
[14/30] Fetching debootstrap-1.0.123_5.txz: 100%   32 KiB  33.2kB/s    00:01    
[15/30] Fetching bsdstats-7.0_1.txz: 100%    7 KiB   7.0kB/s    00:01    
[16/30] Fetching bpytop-1.0.65.txz: 100%   54 KiB  55.2kB/s    00:01    
[17/30] Fetching apache-openoffice-devel-4.2.1619649022_4,4.txz: 100%   88 MiB   9.2MB/s    00:10    
[18/30] Fetching aom-3.1.0.txz: 100%    3 MiB   3.5MB/s    00:01    
[19/30] Fetching CoinMP-1.8.4_4.txz: 100%   33 KiB  34.2kB/s    00:01    
[20/30] Fetching py38-importlib-metadata-3.3.0_1.txz: 100%   17 KiB  17.8kB/s    00:01    
[21/30] Fetching evolution-data-server-3.40.0_1.txz: 100%    4 MiB   3.9MB/s    00:01    
[22/30] Fetching gnugrep-3.6.txz: 100%  229 KiB 234.8kB/s    00:01    
[23/30] Fetching coin-or-CoinUtils-2.11.4_1.txz: 100%  584 KiB 597.9kB/s    00:01    
[24/30] Fetching coin-or-Data-Sample-1.2.12.txz: 100%  143 KiB 146.5kB/s    00:01    
[25/30] Fetching coin-or-Data-Netlib-1.2.9.txz: 100%    3 MiB   3.6MB/s    00:01    
[26/30] Fetching coin-or-Clp-1.17.3_3.txz: 100%    1 MiB   1.3MB/s    00:01    
[27/30] Fetching Ipopt-3.12.13_3.txz: 100%    7 MiB   7.2MB/s    00:01    
[28/30] Fetching coin-or-asl-1.4.3.txz: 100%  263 KiB 269.3kB/s    00:01    
[29/30] Fetching coin-or-cbc-2.10.5_1.txz: 100%  826 KiB 845.6kB/s    00:01    
[30/30] Fetching coin-or-cgl-0.60.3_1.txz: 100%  455 KiB 465.6kB/s    00:01    
Checking integrity... done (5 conflicting)
  - coin-or-CoinUtils-2.11.4_1 [FreeBSD] conflicts with CoinMP-1.8.4_3 [installed] on /usr/local/include/coin/CoinAlloc.hpp
  - coin-or-Data-Sample-1.2.12 [FreeBSD] conflicts with CoinMP-1.8.4_3 [installed] on /usr/local/libdata/pkgconfig/coindatasample.pc
  - coin-or-Clp-1.17.3_3 [FreeBSD] conflicts with CoinMP-1.8.4_3 [installed] on /usr/local/bin/clp
  - coin-or-cbc-2.10.5_1 [FreeBSD] conflicts with CoinMP-1.8.4_3 [installed] on /usr/local/bin/cbc
  - coin-or-cgl-0.60.3_1 [FreeBSD] conflicts with CoinMP-1.8.4_3 [installed] on /usr/local/include/coin/Cgl012cut.hpp
Checking integrity... done (0 conflicting)
Conflicts with the existing packages have been found.
One more solver iteration is needed to resolve them.
The following 31 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        Ipopt: 3.12.13_3 [FreeBSD]
        coin-or-Clp: 1.17.3_3 [FreeBSD]
        coin-or-CoinUtils: 2.11.4_1 [FreeBSD]
        coin-or-Data-Netlib: 1.2.9 [FreeBSD]
        coin-or-Data-Sample: 1.2.12 [FreeBSD]
        coin-or-asl: 1.4.3 [FreeBSD]
        coin-or-cbc: 2.10.5_1 [FreeBSD]
        coin-or-cgl: 0.60.3_1 [FreeBSD]
        evolution-data-server: 3.40.0_1 [FreeBSD]
        gnugrep: 3.6 [FreeBSD]
        py38-importlib-metadata: 3.3.0_1 [FreeBSD]

Installed packages to be UPGRADED:
        aom: 3.0.0 -> 3.1.0 [FreeBSD]
        bpytop: 1.0.64 -> 1.0.65 [FreeBSD]
        bsdstats: 7.0 -> 7.0_1 [FreeBSD]
        debootstrap: 1.0.123_4 -> 1.0.123_5 [FreeBSD]
        firefox: 88.0_2,2 -> 88.0.1,2 [FreeBSD]
        liberation-fonts-ttf: 2.1.3,2 -> 2.1.4,2 [FreeBSD]
        libpurple: 2.14.3_2 -> 2.14.4 [FreeBSD]
        openjdk11: 11.0.10+9.1_1 -> 11.0.11+9.1 [FreeBSD]
        openjdk11-jre: 11.0.10+9.1_1 -> 11.0.11+9.1 [FreeBSD]
        openjdk8: 8.282.08.1 -> 8.292.10.1 [FreeBSD]
        pidgin: 2.14.3_2 -> 2.14.4 [FreeBSD]
        py38-markdown: 2.6.11_1 -> 3.3.4 [FreeBSD]
        stunnel: 5.58,1 -> 5.59,1 [FreeBSD]
        thunderbird: 78.10.0_1 -> 78.10.1 [FreeBSD]
        twm: 1.0.11 -> 1.0.11_1 [FreeBSD]
        wayland-protocols: 1.20 -> 1.21 [FreeBSD]
        xfce4-clipman-plugin: 1.6.1_1 -> 1.6.2 [FreeBSD]

Installed packages to be REINSTALLED:
        apache-openoffice-devel-4.2.1619649022_4,4 [FreeBSD] (needed shared library changed)

Number of packages to be installed: 11
Number of packages to be upgraded: 17
Number of packages to be reinstalled: 1

The process will require 101 MiB more space.

Proceed with this action? [y/N]: y
[1/31] Deinstalling CoinMP-1.8.4_3...
[1/31] Deleting files for CoinMP-1.8.4_3: 100%
[2/31] Installing coin-or-Data-Sample-1.2.12...
[2/31] Extracting coin-or-Data-Sample-1.2.12: 100%
[3/31] Installing coin-or-Data-Netlib-1.2.9...
[3/31] Extracting coin-or-Data-Netlib-1.2.9: 100%
[4/31] Installing coin-or-asl-1.4.3...
[4/31] Extracting coin-or-asl-1.4.3: 100%
[5/31] Upgrading aom from 3.0.0 to 3.1.0...
[5/31] Extracting aom-3.1.0: 100%
[6/31] Installing coin-or-CoinUtils-2.11.4_1...
[6/31] Extracting coin-or-CoinUtils-2.11.4_1: 100%
[7/31] Installing Ipopt-3.12.13_3...
[7/31] Extracting Ipopt-3.12.13_3: 100%
[8/31] Installing coin-or-Clp-1.17.3_3...
[8/31] Extracting coin-or-Clp-1.17.3_3: 100%
[9/31] Upgrading openjdk8 from 8.282.08.1 to 8.292.10.1...
[9/31] Extracting openjdk8-8.292.10.1: 100%
[10/31] Installing coin-or-cgl-0.60.3_1...
[10/31] Extracting coin-or-cgl-0.60.3_1: 100%
[11/31] Installing coin-or-cbc-2.10.5_1...
[11/31] Extracting coin-or-cbc-2.10.5_1: 100%
[12/31] Upgrading libpurple from 2.14.3_2 to 2.14.4...
[12/31] Extracting libpurple-2.14.4: 100%
[12/31] Installing CoinMP-1.8.4_4...
[12/31] Extracting CoinMP-1.8.4_4: 100%
[13/31] Installing py38-importlib-metadata-3.3.0_1...
[13/31] Extracting py38-importlib-metadata-3.3.0_1: 100%
[14/31] Installing evolution-data-server-3.40.0_1...
[14/31] Extracting evolution-data-server-3.40.0_1: 100%
[15/31] Installing gnugrep-3.6...
[15/31] Extracting gnugrep-3.6: 100%
[16/31] Upgrading xfce4-clipman-plugin from 1.6.1_1 to 1.6.2...
[16/31] Extracting xfce4-clipman-plugin-1.6.2: 100%
[17/31] Upgrading wayland-protocols from 1.20 to 1.21...
[17/31] Extracting wayland-protocols-1.21: 100%
[18/31] Upgrading twm from 1.0.11 to 1.0.11_1...
[18/31] Extracting twm-1.0.11_1: 100%
[19/31] Upgrading thunderbird from 78.10.0_1 to 78.10.1...
[19/31] Extracting thunderbird-78.10.1: 100%
[20/31] Upgrading stunnel from 5.58,1 to 5.59,1...
===> Creating groups.
Using existing group 'stunnel'.
===> Creating users
Using existing user 'stunnel'.
[20/31] Extracting stunnel-5.59,1: 100%
If you are permanently removing this port, you should run rm -rf /usr/local/etc/stunnel to remove any configuration files left.
[21/31] Upgrading py38-markdown from 2.6.11_1 to 3.3.4...
[21/31] Extracting py38-markdown-3.3.4: 100%
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/Markdown-2.6.11-py3.8.egg-info/PKG-INFO
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/Markdown-2.6.11-py3.8.egg-info/SOURCES.txt
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/Markdown-2.6.11-py3.8.egg-info/dependency_links.txt
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/Markdown-2.6.11-py3.8.egg-info/entry_points.txt
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/Markdown-2.6.11-py3.8.egg-info/top_level.txt
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/__pycache__/__version__.cpython-38.opt-1.pyc
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/__pycache__/__version__.cpython-38.pyc
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/__pycache__/odict.cpython-38.opt-1.pyc
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/__pycache__/odict.cpython-38.pyc
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/__version__.py
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/extensions/__pycache__/headerid.cpython-38.opt-1.pyc
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/extensions/__pycache__/headerid.cpython-38.pyc
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/extensions/__pycache__/smart_strong.cpython-38.opt-1.pyc
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/extensions/__pycache__/smart_strong.cpython-38.pyc
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/extensions/headerid.py
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/extensions/smart_strong.py
py38-markdown-2.6.11_1: missing file /usr/local/lib/python3.8/site-packages/markdown/odict.py
[22/31] Upgrading pidgin from 2.14.3_2 to 2.14.4...
[22/31] Extracting pidgin-2.14.4: 100%
[23/31] Upgrading openjdk11-jre from 11.0.10+9.1_1 to 11.0.11+9.1...
[23/31] Extracting openjdk11-jre-11.0.11+9.1: 100%
[24/31] Upgrading openjdk11 from 11.0.10+9.1_1 to 11.0.11+9.1...
[24/31] Extracting openjdk11-11.0.11+9.1: 100%
[25/31] Upgrading liberation-fonts-ttf from 2.1.3,2 to 2.1.4,2...
[25/31] Extracting liberation-fonts-ttf-2.1.4,2: 100%
[26/31] Upgrading firefox from 88.0_2,2 to 88.0.1,2...
[26/31] Extracting firefox-88.0.1,2: 100%
[27/31] Upgrading debootstrap from 1.0.123_4 to 1.0.123_5...
[27/31] Extracting debootstrap-1.0.123_5: 100%
[28/31] Upgrading bsdstats from 7.0 to 7.0_1...
[28/31] Extracting bsdstats-7.0_1: 100%
[29/31] Upgrading bpytop from 1.0.64 to 1.0.65...
[29/31] Extracting bpytop-1.0.65: 100%
[30/31] Reinstalling apache-openoffice-devel-4.2.1619649022_4,4...
[30/31] Extracting apache-openoffice-devel-4.2.1619649022_4,4: 100%
root@mowa219-gjp4-8570p:~ # date ; uptime ; uname -v
Fri May  7 17:53:37 BST 2021
 5:53PM  up 1 day,  2:58, 4 users, load averages: 0.42, 0.60, 0.91
FreeBSD 14.0-CURRENT #94 main-n246499-097e8701c9f: Thu May  6 07:26:23 BST 2021     root@mowa219-gjp4-8570p:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG  
root@mowa219-gjp4-8570p:~ # tail -n 2 /var/log/messages
May  7 00:50:30 mowa219-gjp4-8570p kernel: [drm ERROR :btc_dpm_set_power_state] rv770_restrict_performance_levels_before_switch failed
May  7 06:07:32 mowa219-gjp4-8570p pkg[76499]: td-system-tools-1.2.0 installed
root@mowa219-gjp4-8570p:~ # umount /tmp/up/usr/local/poudriere/data/packages                                                
root@mowa219-gjp4-8570p:~ # umount /tmp/up/usr/local/poudriere/data
root@mowa219-gjp4-8570p:~ # tail -n 2 /tmp/up/var/log/messages
May  7 00:50:30 mowa219-gjp4-8570p kernel: [drm ERROR :btc_dpm_set_power_state] rv770_restrict_performance_levels_before_switch failed
May  7 06:07:32 mowa219-gjp4-8570p pkg[76499]: td-system-tools-1.2.0 installed
root@mowa219-gjp4-8570p:~ # umount /tmp/up/var/log
root@mowa219-gjp4-8570p:~ # bectl umount n246499-097e8701c9f-b
root@mowa219-gjp4-8570p:~ # bectl destroy n246499-097e8701c9f-b
root@mowa219-gjp4-8570p:~ #
 
Top