• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Pine A64+ boot problem

dorsai

New Member


Messages: 1

#1
Hey guys,

Been trying to get FreeBSD installed on the Pine A64+ (Rev B, 2016-02-24; 1GB), but have run into problems. Was hoping someone might have some pointers on how to hop over those.

I've tried a number of images but not having the TTL cable yet I'm stuck with those that show stuff on my monitor (HDMI-to-DVI converted). Luckily, the most recent images (e.g., FreeBSD-12.0-CURRENT-arm64-aarch64-PINE64-20180110-r327788.img) are amongst them. This is the output I'm getting:

Code:
U-Boot 2917.89 (Jan 11 2818 - 17:48:32 48808) Allwinner Technology
CPU:   Allwinner A64 (SUM58I)
Model: Pine64+
DRAM:  1 GiB
MMC:   SUNXI SD/MMC: 0
*** Warning - bad CRC, using default environment
In:   serial
Out:  vidconsole
Err:  vidconsole
Net:  phy interface?
eth0: ethernet@01c30000
starting USB...
USB0: USB EMCI 1.00
USB1: USB OHCI 1.0
scanning bus 0 for devices... 1 USB Device(s) found
scanning bus 1 for devices... 2 USB Device(s) found
        scanning usb for storage devices... 0 storage Device(s) found
Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found EFI removable media binary efi/boot/bootaa64.efi
reading efi/boot/bootaa64.efi
81664 bytes read in 37 ms (2.1 MiB/s)
libfdt fdt_check_header(): FDT ERR_BADMAGIC
## Starting EFI application at 40080000 ...
Scanning disks on usb...
Scanning disks on mmc...
MMC Device 1 not found
MMC Device 2 not found
MMC Device 3 not found
Found 7 disks
<-[18t<-[?25h<-[2J
>> FreeBSD EFI boot block
   Loader path: /boot/loader.efi
   Initializing modules: ZFS UFS
   Load Path: \efi\boot\bootaa64.efi
   Load Device: mmc0
   Probing 3 block devices.....* done
    ZFS found no pools
    UFS found 1 partition
<-[?25hConsoles: EFI console
Command line arguments: loader.efi
Image base: 0x76db9008
EFI version: 2.05
EFI Firmware: Das U-boot (rev 0.00)
FreeESD/arm64 EFI loader, Revision 1.1
(Thu Jan 11 10:04:43 UTC ZOIO root@releng3.nyi.freebsd.org)
EFI boot environment
Loading /boot/defaults/loader.conf
/boot/kernel/kernel text=0x8128b0 data=0xb2190+0x443f15 syms=[0x8+0x10ffb0+0x80x102800]
\
Hit (Enter] to boot immediately, or any other key for command prompt.
Booting [/boot/kernel/kernel]...
Using DTB provided by EFI at 0x48000000.
EFI framebuffer information:
addr, size     0x7e000000, ox48000000
dimensions     1680 x 1050
stride         1680
masks          0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000
After that the process hangs. Any help would be greatly appreciated.

Tommy
 
Top