Picom(any fork) make xorg slow

Vertecedoc

New Member

Reaction score: 1
Messages: 14

i've follows the guides refered on this post https://forums.freebsd.org/threads/how-to-setup-a-microphone-correctly-freebsd.82804/#post-540436 for setup my pc but now i have the problem that picom is really hunger with system recurses and instead of improving gpu acceleration makes it worse,
also my xorg conf work as well that is even better than linux, no screentearing, vsync, good acceleration, etc.
but why picom makes that to the system, is not normal, i hope you can help me
here is my xorg config
 

Attachments

  • xorg.conf
    4 KB · Views: 33

bsduck

Well-Known Member

Reaction score: 284
Messages: 305

Your "Device" section is quite messy, you should bring some order in the formatting.

Option "TearFree" "true"
Option "VSync" "true"
You don't need that if you use picom. You should set them to false, especially the TearFree one. Having that enabled in addition to picom results in a noticeable slowdown.

Do you have a ~/.config/picom.conf ?
For example I use
Code:
backend = "glx" ;
glx-no-stencil = true ;
glx-no-rebind-pixmap = true ;

vsync = true ;

shadow = true ;

wintypes:
{
        dnd     = { shadow = false } ;
        tooltip = { shadow = false } ;
        utility = { shadow = false } ;
} ;
This should work well for you too, except glx-no-rebind-pixmap which is problematic with xf86-video-intel.

By the way, picom tends to be less resource-hungry with the modesetting driver (which comes by default with drm-kmod) instead of intel (xf86-video-intel). Have you tried it?
 
OP
V

Vertecedoc

New Member

Reaction score: 1
Messages: 14

Your "Device" section is quite messy, you should bring some order in the formatting.


You don't need that if you use picom. You should set them to false, especially the TearFree one. Having that enabled in addition to picom results in a noticeable slowdown.

Do you have a ~/.config/picom.conf ?
For example I use
Code:
backend = "glx" ;
glx-no-stencil = true ;
glx-no-rebind-pixmap = true ;

vsync = true ;

shadow = true ;

wintypes:
{
        dnd     = { shadow = false } ;
        tooltip = { shadow = false } ;
        utility = { shadow = false } ;
} ;
This should work well for you too, except glx-no-rebind-pixmap which is problematic with xf86-video-intel.

By the way, picom tends to be less resource-hungry with the modesetting driver (which comes by default with drm-kmod) instead of intel (xf86-video-intel). Have you tried it?
thankyou, i've not tested the moddesetting one but i'm going to test that, ThankYou very much
 
OP
V

Vertecedoc

New Member

Reaction score: 1
Messages: 14

Your "Device" section is quite messy, you should bring some order in the formatting.


You don't need that if you use picom. You should set them to false, especially the TearFree one. Having that enabled in addition to picom results in a noticeable slowdown.

Do you have a ~/.config/picom.conf ?
For example I use
Code:
backend = "glx" ;
glx-no-stencil = true ;
glx-no-rebind-pixmap = true ;

vsync = true ;

shadow = true ;

wintypes:
{
        dnd     = { shadow = false } ;
        tooltip = { shadow = false } ;
        utility = { shadow = false } ;
} ;
This should work well for you too, except glx-no-rebind-pixmap which is problematic with xf86-video-intel.

By the way, picom tends to be less resource-hungry with the modesetting driver (which comes by default with drm-kmod) instead of intel (xf86-video-intel). Have you tried it?
only works with picom 8.2 and legacy backend, ather forks or experimetal backends shows the same performance with only accelmethod activated
 

grahamperrin

Son of Beastie

Reaction score: 1,044
Messages: 3,504

x11-wm/picom

… picom tends to be less resource-hungry with the modesetting driver (which comes by default with drm-kmod) instead of intel (xf86-video-intel). Have you tried it?

it worked but only with xf86-intel

What's the hardware?

Which version of FreeBSD, exactly?



Incidentally,


(No mention of picom in those three guides.)
 
Top