PHP5 installation problem

vamos

Member


Messages: 85

Hello, I have a problem with my FreeBSD server, I have installed apache22 but I've a problem with php5

===> Installing for pkgconf-0.8.9

===> pkgconf-0.8.9 conflicts with installed package(s):
pkg-config-0.25_1

They install files into the same place.
Please remove them first with pkg_delete(1).
*** Error code 1

Stop in /usr/ports/devel/pkgconf.
*** Error code 1

Stop in /usr/ports/lang/php5.
I've already tryed to make a pkg_delete but it's impossible, have a solution ?
Thanks. :(
 

ondra_knezour

Aspiring Daemon

Reaction score: 196
Messages: 761

Read /usr/ports/UPDATING

20120726:
AFFECTS: users of devel/pkg-config
AUTHOR: bapt@FreeBSD.org

devel/pkg-config has been replaced by devel/pkgconf

# portmaster -o devel/pkgconf devel/pkg-config
or
# portupgrade -fo devel/pkgconf pkg-config-\*

pkgng:
# pkg set -o devel/pkg-config:devel/pkgconf
# pkg install -f devel/pkgconf
 

zeissoctopus

Active Member

Reaction score: 39
Messages: 167

Please check information about devel/pkg-conf in /usr/ports/UPDATING
20120726:
AFFECTS: users of devel/pkg-config
AUTHOR: bapt@FreeBSD.org

devel/pkg-config has been replaced by devel/pkgconf

# portmaster -o devel/pkgconf devel/pkg-config
or
# portupgrade -fo devel/pkgconf pkg-config-\*

pkgng:
# pkg set -o devel/pkg-config:devel/pkgconf
# pkg install -f devel/pkgconf
devel/pkg-config had replaced by devel/pkgconf near three months.
You had better remove devel/pkg-conf and rebuild all ports which depend on new devel/pkgconf.
 
OP
OP
V

vamos

Member


Messages: 85

Hello, thanks for fast answers, but how I can do what you have say ? sorry I'm a little lost with it, thanks.
 

ondra_knezour

Aspiring Daemon

Reaction score: 196
Messages: 761

Install portmaster
# cd /usr/ports/ports-mgmt/portmaster && make install && rehash
and then use command from UPDATING
# portmaster -o devel/pkgconf devel/pkg-config
 
OP
OP
V

vamos

Member


Messages: 85

Hello, I've a problem more :s
vamos# portmaster -o devel/pkgconf devel/pkg-config
pkg: not found
pkg: not found
pkg: not found

===>>> The second argument to -o can be a package name,
or a port directory from /usr/ports

does not seem to be installed,
or listed as a dependency

===>>> No valid installed port, or port directory given
===>>> Try portmaster --help

Terminated
 
OP
OP
V

vamos

Member


Messages: 85

Hello, I will see, I'm lost, how much manip we need make for have php5 -_-
I see the wiki, thanks.
 
OP
OP
V

vamos

Member


Messages: 85

I have this error, nice update anyway...
===> License BSD accepted by the user
===> Found saved configuration for portmaster-3.14_6
===> portmaster-3.14_6 depends on file: /usr/local/sbin/pkg - not found
===> Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===> pkg-1.0.1 not supported on 7.x or early 8.0.
*** Error code 1

Stop in /usr/ports/ports-mgmt/pkg.
*** Error code 1

Stop in /usr/ports/ports-mgmt/portmaster.
*** Error code 1

Stop in /usr/ports/ports-mgmt/portmaster.
 
OP
OP
V

vamos

Member


Messages: 85

SirDice said:
Turn off PKGNG in ports-mgmt/portmaster.

It also appears you are running an old and unsupported FreeBSD version.
Hello, I use FreeBSD 7.4, I have try the 8.3, 9.0 but the problem is the same, and I need FreeBSD... I'm lost ><, I will retry with Freebsd 9.0
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,290
Messages: 29,735

No need, I said it appeared to look that way. FreeBSD 7.4 is still supported but not by PKGNG. So simply turn that off in ports-mgmt/portmaster.
 
OP
OP
V

vamos

Member


Messages: 85

I can't install php5...

===> Installing for pkgconf-0.8.9

===> pkgconf-0.8.9 conflicts with installed package(s):
pkg-config-0.25_1

They install files into the same place.
Please remove them first with pkg_delete(1).
*** Error code 1

Stop in /usr/ports/devel/pkgconf.
*** Error code 1

Stop in /usr/ports/lang/php5.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,290
Messages: 29,735

That was already answered in post #2 and #3.
 
OP
OP
V

vamos

Member


Messages: 85

SirDice said:
That was already answered in post #2 and #3.
Sure but don't fix the problem anyway...

ks26910# portmaster -o devel/pkgconf devel/pkg-config
pkg: not found
pkg: not found
pkg: not found

===>>> The second argument to -o can be a package name,
or a port directory from /usr/ports

does not seem to be installed,
or listed as a dependency

===>>> No valid installed port, or port directory given
===>>> Try portmaster --help

Terminated
ks26910# portupgrade -fo devel/pkgconf pkg-config-\*
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 51 packages found (-0 +50) .................................................. done]
[Updating the portsdb <format:bdb_btree> in /usr/ports ... - 24014 port entries found .........1000.........2000.........3000.........4000.........5000.........6000.........7000.........8000.........9000.........10000.........11000.........12000.........13000.........14000.........15000.........16000.........17000.........18000.........19000.........20000.........21000.........22000.........23000.........24000 ..... done]
** Detected a package name change: pkg-config (devel/pkgconf) -> 'pkgconf' (devel/pkgconf)
---> Downgrading 'pkg-config-0.25_1' to 'pkgconf-0.8.9' (devel/pkgconf)
---> Building '/usr/ports/devel/pkgconf'
===> Cleaning for pkgconf-0.8.9
===> License BSD accepted by the user
===> pkgconf-0.8.9 depends on file: /usr/local/sbin/pkg - not found
===> Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===> pkg-1.0.1 not supported on 7.x or early 8.0.
*** Error code 1

Stop in /usr/ports/ports-mgmt/pkg.
*** Error code 1

Stop in /usr/ports/devel/pkgconf.
---> Backing up the old version
---> Uninstalling the old version
---> Deinstalling 'pkg-config-0.25_1'
pkg_delete: package 'pkg-config-0.25_1' is required by these other packages
and may not be deinstalled (but I'll delete it anyway):
bind97-9.7.2.3
libsmi-0.4.8
libxml2-2.7.8_1
tcpdump-4.1.1
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 50 packages found (-1 +0) (...) done]
---> Installing the new version via the port
===> License BSD accepted by the user
===> pkgconf-0.8.9 depends on file: /usr/local/sbin/pkg - not found
===> Verifying reinstall for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===> pkg-1.0.1 not supported on 7.x or early 8.0.
*** Error code 1

Stop in /usr/ports/ports-mgmt/pkg.
*** Error code 1

Stop in /usr/ports/devel/pkgconf.
*** Error code 1

Stop in /usr/ports/devel/pkgconf.
===> Cleaning for pkgconf-0.8.9
---> Cleaning out obsolete shared libraries
 
OP
OP
V

vamos

Member


Messages: 85

SirDice said:
I have edit my message, look the errors, sorry I'm not a PRO, thanks.

===> php5-5.4.7 depends on file: /usr/local/sbin/apxs - found
===> php5-5.4.7 depends on file: /usr/local/bin/autoconf-2.69 - found
===> php5-5.4.7 depends on executable: pkgconf - not found
===> Verifying install for pkgconf in /usr/ports/devel/pkgconf
===> License BSD accepted by the user
===> pkgconf-0.8.9 depends on file: /usr/local/sbin/pkg - not found
===> Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===> pkg-1.0.1 not supported on 7.x or early 8.0.
*** Error code 1

Stop in /usr/ports/ports-mgmt/pkg.
*** Error code 1

Stop in /usr/ports/devel/pkgconf.
*** Error code 1

Stop in /usr/ports/lang/php5.
*** Error code 1

Stop in /usr/ports/lang/php5.
 

chatwizrd

Active Member

Reaction score: 23
Messages: 205

You have to recompile portmaster and remove pkgng support.

Uncheck the pkgng box when you do this:

# cd /usr/ports/ports-mgmt/portmaster && make config deinstall reinstall clean

Then run:

# portmaster -o devel/pkgconf devel/pkg-config
 
OP
OP
V

vamos

Member


Messages: 85

Hello,

===> Deinstalling for ports-mgmt/portmaster
/usr/local/sbin/pkg: not found
===> portmaster not installed, skipping
===> License BSD accepted by the user
===> Found saved configuration for portmaster-3.14_6
===> portmaster-3.14_6 depends on file: /usr/local/sbin/pkg - not found
===> Verifying reinstall for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===> pkg-1.0.1 not supported on 7.x or early 8.0.
*** Error code 1

Stop in /usr/ports/ports-mgmt/pkg.
*** Error code 1

Stop in /usr/ports/ports-mgmt/portmaster.
*** Error code 1

Stop in /usr/ports/ports-mgmt/portmaster.
*** Error code 1

Stop in /usr/ports/ports-mgmt/portmaster.
ks26910#
ks26910# portmaster -o devel/pkgconf devel/pkg-config
pkg: not found
pkg: not found
pkg: not found

===>>> The second argument to -o can be a package name,
or a port directory from /usr/ports

does not seem to be installed,
or listed as a dependency

===>>> No valid installed port, or port directory given
===>>> Try portmaster --help

Terminated
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,290
Messages: 29,735

Code:
cd /usr/ports/ports-mgmt/portmaster
make deinstall
make config # turn OFF PKGNG!
make install
 
Top