PHP 5.3.2 with openbasedir

blodan

Member

Reaction score: 17
Messages: 41

There seems to be some problem with open_basedir in php 5.3.2 for freebsd, i used the 5.2 branch before and the exact same config worked fine then.

open_basedir reports failure eventhough im within the allowed paths

Include paths in php.ini:
Code:
include_path = ".:/usr/local/share/pear:/usr/local/lib/php/include"
Testhost in apache:
Code:
<VirtualHost *:80>
    DocumentRoot "/home/customers/produktion203/testin.se"
    ServerName testin.se
    php_admin_value open_basedir /home/customers/produktion203/testin.se:/usr/local/share/pear:/usr/local/lib/php/include:/var/tmp
</VirtualHost>

Test script:
---------------
Code:
<?php
phpinfo();
Gives:
---------------
Code:
Warning: Unknown: open_basedir restriction in effect. File() is not within the allowed path(s): 
(/home/customers/produktion203/testin.se:/usr/local/share/pear:/usr/local/lib/php/include:/var/tmp) in Unknown on line 0

Fatal error: Can't load /home/customers/produktion203/testin.se/nfo.php, open_basedir restriction. in Unknown on line 0
Has anyone been able to fix this? Or know how to fix it, im currently running without open_basedir on a production server waiting for 5.3.3 hoping its fixed there
 
OP
OP
blodan

blodan

Member

Reaction score: 17
Messages: 41

After getting some pointers on what to debug it turned out to be eaccelerator that *beep**beep**beep**beep*ed everything up.

To solve the problem you have to add --without-eaccelerator-use-inode to your configargs in your Makefile for eaccelerator and reinstall and it will all be working like a charm again

** How do i mark the thread as solved? I cant seem to be able to edit my original post
 
Top