PF pfctl -p device "Operation not supported"

I had read the "PF: Firewall Management" by dhartmei in OpenBSD journal ( and then I tried create other device to pfctl operation.

[2.3.2-RELEASE][root@frw01.localhost]/root: id
uid=0(root) gid=0(wheel) groups=0(wheel),2(kmem),3(sys),4(tty),5(operator),20(staff),31(guest),1998(all),1999(admins
[2.3.2-RELEASE][root@frw01.localhost]/root: mknod pf c 73 0
[2.3.2-RELEASE][root@frw01.localhost]/root: pfctl -p /root/pf -s info
pfctl: /root/pf: Operation not supported
[2.3.2-RELEASE][root@frw01.localhost]/root: ls -lah pf
crw-------  1 root  wheel  0x4900 Sep 28 13:08 pf

When I try use the pfctl -p "device" option, I received an error "Operation not supported" is there any recommended action to troubleshooting this problem? Is there any material to guide me solve this problem?

Thank you!
Your reply is just about the wrong forum, or is about some problem in the FreeBSD's PF implementation?

Although I see your point about other platforms and the concerns about don't crash running OS, I tried right now this procedure in FreeBSD 10.3 and the problem happens too.


I just tried it because in the man page we have option -p to set other device, and I need set other permissions to a specific user, and I cant change the actual permissions of /dev/pf.

Thank you!
The article you're using is really old and also OpenBSD specific. FreeBSD moved to a dynamically generated /dev filesystem devfs(8) a long time ago and user created static device nodes are not guaranteed to work, especially the device major/minor numbers you're taking from OpenBSD are never going to work on FreeBSD.