• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

pecl-geoip with PHP7.1

razsnic

New Member


Messages: 5

#1
Hello,

I am running Piwik using Apache/PHP71.
I would like to install pecl-geoip, however I noticed that it is dependent on PHP56.
Since I do not want to downgrade to PHP56 just for pecl-geoip, is there any way to install pecl-geoip using PHP71?

Thank you!
Raz
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,491
Messages: 25,656

#3
Build from ports, then you can deviate from the default (the default is 5.6). To make sure your dependencies are correct add to /etc/make.conf:
Code:
DEFAULT_VERSIONS+= php=7.1
That will make sure if you build something that depends on PHP it's going to depend on 7.1.