1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[PCBSD] "dd error on install" on Thinkpad T400 with PCBSD9

Discussion in 'Installing and Upgrading FreeBSD' started by juedan, Nov 2, 2012.

  1. juedan

    juedan New Member

    Thanks Received:
    Hello forum,

    yesterday I wanted to install PCBSD9 on an Thinkpad T400 parallel to my Fedora installation from an USB stick (amd64 live system). The first three slices are used by Fedora, so for the fourth (ada0s4) slice was reserved for PCBSD.
    After the Gnome desktop was fully displayed I double clicked on install icon on the desktop for installation. After choosing the right slice and entering the wished data the process started and ended with the following error messages:
    kern.geom.debugflags: 0 -> 16
    Running part modify on /dev/ada0
    Running: part modify -t freebsd -i 4 /dev/ada0
    ada0s4 modified
    Cleaning up /dev/ada0s4
    Running dd if=/dev/zero of=/dev/ada0s4 count=1024
    dd: /dev/ada0s4: Operation not supported
    EXITERROR: Error 1: dd if=/dev/zero of=/dev/ada0s4 count=1024

    First I thought it is an problem with HAL and therefore I stopped HAL (/usr/local/etc/rc.d/hald stop) and checked that no disk slice/partition is mounted.
    Then I restarted the installation process and got the same result.
    I did not select GPT for creating the slice and partition.

    How can this problem solved?

    Thanks in advance for the answers.

    Best regards

  2. wblock@

    wblock@ Administrator Staff Member Administrator Moderator Developer

    Thanks Received:
    First off, PCBSD has a different installer from FreeBSD. Us FreeBSD people may or may not be familiar with the PCBSD stuff. Usually, you should ask them first.

    That code is trying to erase the first 1024 512-byte blocks of the target slice. No idea why a disk (or SSD?) would say "operation not supported" to that.

    That code also sets debugflags, which is generally bad.