• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[PC-BSD] Why PC-BSD looks corrupted and how to fix it?

Nicushor

Member


Messages: 32

#1
I have two systems, and Linux Mint looks way more cleaner and well done. What is the reason for this? How can I make BSD look more like Mint or any other Linux?



 

gofer_touch

Active Member

Thanks: 119
Messages: 246

#4
Hmm. First of all you are comparing two different desktop environments. Install MATE on the PCBSD system and then do a comparison. The moderator is also right. This isn't PC-BSDs forum.
 

lme@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 293
Messages: 775

#7
Why is this a problem?
 

Nicushor

Member


Messages: 32

#8
Why is this a problem?
Because my eyes hurt after a while looking at this text, unfortunately I'm not a big expert (I wish I was) in typography and typefaces - it's not necessary to be windows-like aliasing, but to at least make it not to hurt (and read how else the text can become). Anyway, I want to adapt my bsd desktop to creative stuff like music making and photos, so this things require an aesthetic environment (for inspiration, duhhh).
 

Nicushor

Member


Messages: 32

#9
Hmm. First of all you are comparing two different desktop environments. Install MATE on the PCBSD system and then do a comparison. The moderator is also right. This isn't PC-BSDs forum.
I don't think what you wrote is relevant, I started a thread about making the text more readable and offered a comparison. The MATE on PC-BSD looks also as if it was fitted there with an axe... thank you.
 

Maxnix

Well-Known Member

Thanks: 161
Messages: 283

#10
Perhaps this is a stupid question, but the recognised screen resolution is the same on both OSes?
 

Maxnix

Well-Known Member

Thanks: 161
Messages: 283

#12
These are images from Google, not my own screenshots.
Yeah, I had already noticed. ;) I was wondering if the text looks ugly for a screen resolution problem rather than other.

Apart from this, have you already checked if your DE (KDE, MATE... which one is irrelevant) has correct settings for antialiasing?
 

Nicushor

Member


Messages: 32

#13
Yeah, I had already noticed. ;) I was wondering if the text looks ugly for a screen resolution problem rather than other.

Apart from this, have you already checked if your DE (KDE, MATE... which one is irrelevant) has correct settings for antialiasing?
Yup, they all look 'ugly'.
 

Maxnix

Well-Known Member

Thanks: 161
Messages: 283

#14
So the problem is neither antialiasing nor screen resolution.
Uhm, there are (at least) two other things to try:
- Check which font PC-BSD is using and if the font type is the same even. (I.E. book, bold condensed...). In my experience this can affect readability.
- Look at this: http://www.rawcomputing.co.uk/linux/linuxtips3.html. Perhaps the font rendering details can be useful.​
 

tankist02

Well-Known Member

Thanks: 29
Messages: 281

#15
Nicushor you can try to play with text settings: anti-aliasing, hinting, etc. I tried PC BSD a few times and didn't like how it renders text. I get a better picture in FreeBSD, but it takes time and efforts to get there. :)
 

tobik@

Daemon
Developer

Thanks: 1,318
Messages: 1,896

#16
What solved my own font rendering issues:
  1. Create /usr/local/etc/fonts/conf.d/99-desktoprc.conf (I'm not using a desktop environment, so I don't know if these will take if you do). These are basically the same settings as the ones posted in the linked PC-BSD Forums thread:
    Code:
    <?xml version='1.0'?>
    <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
    <fontconfig>
        <match target="font">
            <edit mode="assign" name="antialias">
                <bool>true</bool>
            </edit>
            <edit mode="assign" name="hinting">
                <bool>true</bool>
            </edit>
            <edit mode="assign" name="hintstyle">
                <const>hintslight</const>
            </edit>
            <edit mode="assign" name="lcdfilter">
                <const>lcddefault</const>
            </edit>
            <edit mode="assign" name="rgba">
                <const>rgb</const>
            </edit>
        </match>
    </fontconfig>
  2. ln -s /usr/local/etc/fonts/conf.avail/70-no-bitmaps.conf /usr/local/etc/fonts/conf.d/70-no-bitmaps.conf
  3. installing x11-fonts/croscorefonts-fonts-ttf and setting them up as default fonts by saving https://raw.githubusercontent.com/t...desktoprc/files/99-desktoprc-croscore.conf.in as /usr/local/etc/fonts/conf.d/99-desktoprc-croscore.conf
  4. Restart all applications to test
EDIT: Fixed paths. Thanks lme@!
 

lme@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 293
Messages: 775

#18

dlegrand

Active Member

Thanks: 43
Messages: 154

#19
I am using a Window Manager only (x11-wm/fvwm2) and my font configuration file is located in my home directory :
~/.config/fontconfig/fonts.conf

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- $XDG_CONFIG_HOME/fontconfig/fonts.conf for per-user font configuration -->

<fontconfig>

  <!--
  Private font directory
  -->
  <dir prefix="xdg">fonts</dir>

  <!-- Replace Courier with a better-looking font -->
  <match target="pattern">
  <test name="family" qual="any">
  <string>Courier</string>
  </test>
  <edit name="family" mode="assign">
  <!-- Other choices - Courier New, Luxi Mono -->
  <string>Bitstream Vera Sans Mono</string>
  </edit>
  </match>

  <!-- Reject bitmap fonts in favour of Truetype, Postscript, etc. -->
  <selectfont>
  <rejectfont>
  <pattern>
   <patelt name="scalable"><bool>false</bool></patelt>
  </pattern>
  </rejectfont>
  </selectfont>

  <!--
  <match target="pattern" >
  <test name="family" qual="any" >
  <string>Helvetica</string>
  </test>
  <edit binding="strong" mode="prepend" name="family">
  <string>Arial</string>
  </edit>
  </match>
  -->

  <!-- default quality settings -->
  <match target="font">
  <edit mode="assign" name="rgba">  <const>none</const> </edit>
  <edit mode="assign" name="antialias"> <bool>true</bool> </edit>
  <edit mode="assign" name="autohint">  <bool>true</bool> </edit>
  <edit mode="assign" name="hinting">  <bool>true</bool> </edit>
  <edit mode="assign" name="hintstyle"> <const>hintfull</const> </edit>
  </match>

  <!-- reduce ringing ==> requires freetype2 'WITH_LCD_FILTERING=yes' -->
  <match target="font">
  <edit mode="assign" name="lcdfilter"> <const>lcdlight</const> </edit>
  </match>

  <!-- disable autohinting for bold fonts -->
  <match target="font">
  <test compare="more" name="weight">  <const>medium</const> </test>
  <edit mode="assign"  name="autohint"> <bool>false</bool> </edit>
  </match>

  <!-- disable autohinting for fonts that don't need it -->
  <match target="pattern">
  <test qual="any" name="family"> <string>Andale Mono</string> </test>
  <test qual="any" name="family"> <string>Arial</string> </test>
  <test qual="any" name="family"> <string>Arial Black</string> </test>
  <test qual="any" name="family"> <string>Comic Sans MS</string> </test>
  <test qual="any" name="family"> <string>Courier New</string> </test>
  <test qual="any" name="family"> <string>Georgia</string> </test>
  <test qual="any" name="family"> <string>Impact</string> </test>
  <test qual="any" name="family"> <string>Trebuchet MS</string> </test>
  <test qual="any" name="family"> <string>Tahoma</string> </test>
  <test qual="any" name="family"> <string>Times New Roman</string> </test>
  <test qual="any" name="family"> <string>Verdana</string> </test>
  <test qual="any" name="family"> <string>Webdings</string> </test>
  <edit mode="assign" name="hinting">  <bool>true</bool> </edit>
  <edit mode="assign" name="autohint"> <bool>false</bool> </edit>
  </match>

</fontconfig>
All is looking very good. Better than with some DE.
 

Nicushor

Member


Messages: 32

#20
I am using a Window Manager only (x11-wm/fvwm2) and my font configuration file is located in my home directory :
~/.config/fontconfig/fonts.conf

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- $XDG_CONFIG_HOME/fontconfig/fonts.conf for per-user font configuration -->

<fontconfig>

  <!--
  Private font directory
  -->
  <dir prefix="xdg">fonts</dir>

  <!-- Replace Courier with a better-looking font -->
  <match target="pattern">
  <test name="family" qual="any">
  <string>Courier</string>
  </test>
  <edit name="family" mode="assign">
  <!-- Other choices - Courier New, Luxi Mono -->
  <string>Bitstream Vera Sans Mono</string>
  </edit>
  </match>

  <!-- Reject bitmap fonts in favour of Truetype, Postscript, etc. -->
  <selectfont>
  <rejectfont>
  <pattern>
   <patelt name="scalable"><bool>false</bool></patelt>
  </pattern>
  </rejectfont>
  </selectfont>

  <!--
  <match target="pattern" >
  <test name="family" qual="any" >
  <string>Helvetica</string>
  </test>
  <edit binding="strong" mode="prepend" name="family">
  <string>Arial</string>
  </edit>
  </match>
  -->

  <!-- default quality settings -->
  <match target="font">
  <edit mode="assign" name="rgba">  <const>none</const> </edit>
  <edit mode="assign" name="antialias"> <bool>true</bool> </edit>
  <edit mode="assign" name="autohint">  <bool>true</bool> </edit>
  <edit mode="assign" name="hinting">  <bool>true</bool> </edit>
  <edit mode="assign" name="hintstyle"> <const>hintfull</const> </edit>
  </match>

  <!-- reduce ringing ==> requires freetype2 'WITH_LCD_FILTERING=yes' -->
  <match target="font">
  <edit mode="assign" name="lcdfilter"> <const>lcdlight</const> </edit>
  </match>

  <!-- disable autohinting for bold fonts -->
  <match target="font">
  <test compare="more" name="weight">  <const>medium</const> </test>
  <edit mode="assign"  name="autohint"> <bool>false</bool> </edit>
  </match>

  <!-- disable autohinting for fonts that don't need it -->
  <match target="pattern">
  <test qual="any" name="family"> <string>Andale Mono</string> </test>
  <test qual="any" name="family"> <string>Arial</string> </test>
  <test qual="any" name="family"> <string>Arial Black</string> </test>
  <test qual="any" name="family"> <string>Comic Sans MS</string> </test>
  <test qual="any" name="family"> <string>Courier New</string> </test>
  <test qual="any" name="family"> <string>Georgia</string> </test>
  <test qual="any" name="family"> <string>Impact</string> </test>
  <test qual="any" name="family"> <string>Trebuchet MS</string> </test>
  <test qual="any" name="family"> <string>Tahoma</string> </test>
  <test qual="any" name="family"> <string>Times New Roman</string> </test>
  <test qual="any" name="family"> <string>Verdana</string> </test>
  <test qual="any" name="family"> <string>Webdings</string> </test>
  <edit mode="assign" name="hinting">  <bool>true</bool> </edit>
  <edit mode="assign" name="autohint"> <bool>false</bool> </edit>
  </match>

</fontconfig>
All is looking very good. Better than with some DE.
Can you paste a screenshot here?
 

gonubana

New Member

Thanks: 1
Messages: 2

#23
Just being random:
Generally speaking, the more you work on $something the nicer it appear to become.
So, given enough time, you could eventually appreciate most things through working on them.
 

ivosevb

Member

Thanks: 7
Messages: 30

#24
I'm using Openbox. Initially after install yes fonts looks little ugly. Everything is very good for me with this ~/.config/fontconfig/fonts.conf
Code:
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
<match target="font">
  <edit mode="assign" name="rgba">
  <const>rgb</const>
  </edit>
</match>
<match target="font">
  <edit mode="assign" name="hinting">
  <bool>true</bool>
  </edit>
</match>
<match target="font">
  <edit mode="assign" name="hintstyle">
  <const>hintfull</const>
  </edit>
</match>
<match target="font">
  <edit mode="assign" name="antialias">
  <bool>true</bool>
  </edit>
</match>
</fontconfig>
And screenshot ...
 

Attachments

Top