Parallels compatible display driver?

Manoli

New Member

Reaction score: 1
Messages: 19

Hello guys,

does anyone have an idea please, which driver has to be installed to support graphics for xorg while on Parallels Desktop 15 and I'm talking about FreeBSD 12.1-RELEASE.

My installation under Parallels basically works fine in text mode in ttys, but I'm not able to startx, always complains about the driver. Thank you very much for pointing right direction, have good day everyone, bye...
 

trev

Aspiring Daemon

Reaction score: 275
Messages: 994

To get Xorg working with the latest version of Parallels 15, I had to move to the scfb video driver for wsdisplay framebuffer device. man scfb for details.
 
OP
Manoli

Manoli

New Member

Reaction score: 1
Messages: 19

To get Xorg working with the latest version of Parallels 15, I had to move to the scfb video driver for wsdisplay framebuffer device. man scfb for details.
Thanks a lot man!!! Works nicely. 👍

Just one more thing, i'm still getting an error after boot-up in dmesg

Code:
module_register_init: MOD_LOAD (vesa, 0xffffffff8112e0f0, 0) error 19

As I guess I don't need 'vesa' in this case (and it doesn't load anyway). Is it possible to stop loading this mod at all somewhere? I can't find it either in /etc/rc.conf nor /boot/loader.conf I tried even 'vesa_load="NO"' in /boot/loader.conf without any effect.

Thank you, bye.
 

trev

Aspiring Daemon

Reaction score: 275
Messages: 994

I think you'll find that the vesa driver is part of the GENERIC kernel:

Code:
options      VESA                    # Add support for VESA BIOS Extensions (VBE)
 

ranvel

New Member

Reaction score: 1
Messages: 10

This post is old, but it was super helpful for getting me started. When I used the scfb driver, it only came up in 1024x768, which was a non-starter. I found a workaround, and so I thought I would add my findings to help fellow travellers (or myself in the future):
1. The VESA driver can be skipped (without rebuilding the kernel) by adding the line vesa_load="NO" to your /boot/loader.conf
2. I was able to get a much larger resolution by setting the following in /boot/loader.conf: efi_max_resolution="1080p"
There are additional modes listed in loader.conf(5)
 

outpaddling

Active Member

Reaction score: 44
Messages: 131

You can also just add the following to, e.g., /etc/X11/xorg.conf.d/10-parallels-scfb.conf:

Code:
Section "Device"
        ### Force SCFB driver for Parallels 15+
        Identifier  "Card0"
        Driver      "scfb"
        BusID       "PCI:1:0:0"
EndSection

I'm adding this to the next release of sysutils/desktop-installer along with Parallels detection (via sysctl kern.vm_guest).

Thanks for sharing your discoveries!
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,618
Messages: 37,958

You can also just add the following to, e.g., /etc/X11/xorg.conf.d/10-parallels-scfb.conf:
Move that stuff to /usr/local/etc/X11, it doesn't belong in /etc/.
 
Top