Solved paprefs (pulseaudio) - core dumped with GLib-GIO-ERROR:Settings schema 'org.freedesktop.pulseaudio.module-group' is not installed

Abraham79

Member

Reaction score: 6
Messages: 62

This is on FreeBSD-12.1. I installed paprefs (Pulseaudio preferences) and it is crashing with error:
Code:
:~% paprefs

(paprefs:76944): GLib-GIO-ERROR **: 12:19:44.019: Settings schema 'org.freedesktop.pulseaudio.module-group' is not installed
zsh: trace trap (core dumped)  paprefs
I searched for org.freedesktop.pulseaudio.module-group in /usr/local/share/glib-2.0/schemas/ , did not find any. However, org.freedesktop.pulseaudio.gschema.xml file is also missing in the schemas directory. (I'm not an expert on this).
 
OP
Abraham79

Abraham79

Member

Reaction score: 6
Messages: 62

I downloaded pulseaudio source from freedesktop website (https://www.freedesktop.org/wiki/Software/PulseAudio/) and extracted the archive to copy org.freedesktop.pulseaudio.gschema.xml to the directory /usr/local/share/glib-2.0/schemas/ .
Then, ran:
Code:
:~% doas glib-compile-schemas /usr/local/share/glib-2.0/schemas/
Thanks to the article written in https://darrengoossens.wordpress.co...ngs-schema-somethingorother-is-not-installed/

No error messages. It worked! However, I am in doubt, should report this to bug tracking system or leave as it is? The problem is clearly, the missing pulseaudio schemas file.
 

monwarez

Member

Reaction score: 20
Messages: 59

It is stated on the description of the port audio/paprefs
Description: PulseAudio Preferences (paprefs) is a simple GTK based configuration dialog for the PulseAudio sound server. Please note that this program can only configure local servers, and requires that a special module module-gsettings is loaded in the sound server. (This require to build the audio/pulseaudio port with option GSETTINGS).
If the problem persist after building audio/pulseaudio with GSETTINGS option on, then this can be reported to the bug tracking system related to audio/pulseaudio.
 
OP
Abraham79

Abraham79

Member

Reaction score: 6
Messages: 62

It is stated on the description of the port audio/paprefs

If the problem persist after building audio/pulseaudio with GSETTINGS option on, then this can be reported to the bug tracking system related to audio/pulseaudio.
Oh. So, this configures only local sound server. I am not building from ports, and hence cannot validate if gsettings enabled option will work. Marking the thread as solved.
 
Top