Overclocking on RPI

NT1036

New Member


Messages: 1

Hello, I am a new and proud member of the FreeBSD community. I am hosting a small website on my RPI with FreeBSD. One question is, where is the overclocking configuration for RPI? The closest answer I got is from this website https://lists.freebsd.org/pipermail/freebsd-arm/2014-October/009448.html, but most of the links led to Japanese websites and doesn't say where the configuration file is located. I have been looking all over for it, but I can't find it.



Thank You,

Nicholas
 

OJ

Daemon

Reaction score: 401
Messages: 1,255

Welcome NT1036. Unfortunately I run Debian on my RPi and also not a fan of overclocking. However, are there not the regular options in /boot/config.txt? I'm thinking this. Anyway, good luck.
 

Juha Nurmela

Well-Known Member

Reaction score: 121
Messages: 401

I tried sysctl hw.cpufreq.arm_freq=80000000 on an idle raspberry, 700 to 80 MHz, and an idle system turned into 25.8%Sys 4.9%Intr 8.8%User 0.0%Nice 60.4%Idle.

sysctl hw.cpufreq.arm_freq=800000000 (800 MHz) and it's back at 97%Idle.

Code:
FreeBSD aspi 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r291495: Tue Dec  1 08:23:29 UTC 2015  root@releng2.nyi.freebsd.org:/usr/obj/arm.armv6/usr/src/sys/RPI-B  arm

I'm also blind, among other faults. Sorry. 800 above was overridden to 700.

However, adding a line
Code:
arm_freq=800
into /boot/msdos/config.txt and sysctl dev.cpu.0.freq=800
seems to work. A test compile took 12 seconds on original config and now takes 11 seconds on 800 MHz raspi. I lost patience waiting the compile on 70 MHz setting. minutes.

Juha
 
Top