Option XkbLayout down't work on Xorg 7.4

graudeejs

Son of Beastie

Reaction score: 706
Messages: 4,617

I installed Xorg 7.4 from ports without much problems, but here's one

Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        [color="Red"]Option      "XkbLayout"    "lv"[/color]
EndSection

XkbLayout doesn't seam to have effect, when i start X.
If i open geany, i can't type in my native.

Of corse i can add a line that changes laguage in fvwm startup file or .xinitrc, but, why doesn't this work.
On all previous versions it was fine
 

ale

Daemon

Reaction score: 169
Messages: 1,059

I don't have xorg-server built with hal, but it that is your case, maybe this [post=10924]post[/post] may help
 

axbat

New Member

Reaction score: 1
Messages: 9

Try inserting into ~/.xinitrc the following:
setxkbmap "us,lv" ",winkeys" "grp:caps_toggle" &
 

Sinister

New Member

Reaction score: 1
Messages: 2

input devices from xorg.conf may be ignored when xorg was installed with HAL support.

In this case exist three ways:
first - use xml HAL configs
second - disable HAL
third - use features of .xsessionrc, .xinitrc
 
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 706
Messages: 4,617

I know i can work around it (and i already did).
 

kamikaze

Well-Known Member

Reaction score: 76
Messages: 365

Actually the
Code:
	Option		"AllowEmptyInput"	"off"
setting in the ServerFlags-Section of xorg.conf suffices. You do not have to turn off hald-support.
 
Top