Opera

pkg search opera gives

linux-opera-12.16_3

As far as I remember, there was a FreBSD version of that opera, and 20 years ago there was the latest opera as linux binary.

In my linux emulation with debian binaries opera makes segmentation fault.

Is anyone here running an recent version of opera?
 
Also with vivaldi I get segmentation fault:

Code:
$ vivaldi
[10037:10037:0727/205136.848313:ERROR:socket.cc(45)] setsockopt: Protocol not available (92)
Segmentation fault
 
I have best experience in linux emulation with brave browser and
—no-sandbox option up to now.
But still trying.
 
pkg search opera gives

linux-opera-12.16_3

Code:
amw@t430 ~> sudo pkg install linux-opera-12.16_3            
Password:
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 28 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
    linux-c7-atk: 2.28.1_1
    linux-c7-cairo: 1.15.12_1
    linux-c7-dri: 18.3.4_4
    linux-c7-elfutils-libelf: 0.176_2
    linux-c7-expat: 2.1.0_4
    linux-c7-fontconfig: 2.13.0
    linux-c7-freetype: 2.8_2
    linux-c7-fribidi: 1.0.2_1
    linux-c7-gdk-pixbuf2: 2.36.12
    linux-c7-graphite2: 1.3.10
    linux-c7-gtk2: 2.24.31
    linux-c7-harfbuzz: 1.7.5
    linux-c7-jasper-libs: 1.900.1_5
    linux-c7-jbigkit-libs: 2.0_2
    linux-c7-jpeg: 1.2.90_4
    linux-c7-libdrm: 2.4.97
    linux-c7-libglvnd: 1.0.1
    linux-c7-libpciaccess: 0.14
    linux-c7-libpng: 1.5.13_3
    linux-c7-libthai: 0.1.14_1
    linux-c7-libtiff: 4.0.3_5
    linux-c7-pango: 1.42.4_1
    linux-c7-pixman: 0.34.0
    linux-c7-sqlite: 3.7.17_2
    linux-c7-wayland: 1.15.0
    linux-c7-xorg-libs: 7.7_9
    linux-opera: 12.16_3
    linux_base-c7: 7.9.2009

Number of packages to be installed: 28

The process will require 585 MiB more space.
129 MiB to be downloaded.

Proceed with this action? [y/N]:

Seems to be meant for the 'original Linuxulator'.

There is an opera clone: otter-browser

Maybe this is of help, at least it was for me.
 
Maybe this is of help, at least it was for me.
Thanks, now we know that those browsers work. But instead of running as root a script that I find somewhere,
I would like to know why the debian installed did not run.

Opera-12 is too old.
 
Top