OpenVAS Install - gpgme

juaromu

New Member


Messages: 4

Hi there:

Just installed OpenVAS 9 from packages (FreeBSD 11-2) and after updating NVTs, Cert Data, etc:
Code:
greenbone-nvt-sync
greenbone-scapdata-sync
greenbone-certdata-sync
openvasmd --rebuild
The manager module fails to start throwing following error (/var/log/openvas/openvasmd.log):
Code:
md   main:MESSAGE:2019-01-27 00h12.13 utc :95900:    OpenVAS Manager version 7.0.2 (DB revision 184)
base gpgme:MESSAGE:2019-01-27 00h12.13 utc :95901: Setting GnuPG dir to '/var/lib/openvas/openvasmd/gnupg'
base gpgme:WARNING:2019-01-27 00h12.13 utc :95901: Setting GnuPG dir failed: Invalid crypto engine <GPGME>
md  crypt:CRITICAL:2019-01-27 00h12.13 utc :95901: lsc_crypt_new: can't continue w/o a gpgme context
GnuPG version installed is "gpgme-1.12.0_2"

Any ideas?
Thanks!
Juan.
 
Last edited by a moderator:

asghar_h

New Member

Reaction score: 1
Messages: 1

Hello,

I just ran into this same issue and was able to get around this by linking /usr/local/bin/gpg2 to /usr/bin/gpg2 as follows:

ln -s /usr/local/bin/gpg2 /usr/bin/gpg2

There are some helpful programs for gpgme available here (engine errors listing etc):

https://github.com/seiyak/GPGME-sample-code/blob/master/t-engine-info.c

In general, I am trying to run OpenVAS on FreeBSD because since late 2019 the regular Linux and Kali Linux installs are failing with openvas-scanner errors (no logs thanks to systemd).

Hope this helps someone.

Thanks.

-Asghar
 
Top