OpenOffice.org 3.1.1 i686 packages for FreeBSD-8.0-RELEASE

Status
Not open for further replies.

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

World is against me. Yesterday there were power flickering.....
Today, power will be cut off for 1hours....
I hope current package will be completed by that time..... it's already being compiled for many hours
 

SIFE

Well-Known Member

Reaction score: 17
Messages: 472

i have gnome2.26 , i fail when i add openoffice :
Code:
Package 'en-openoffice.org-US-3.0.0' depends on 'kbproto-1.0.3' with 'x11/kbproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'inputproto-1.4.2.1' with 'x11/inputproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'fixesproto-4.0' with 'x11/fixesproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'damageproto-1.1.0_2' with 'x11/damageproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'compositeproto-0.4' with 'x11/compositeproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'font-util-1.0.1' with 'x11-fonts/font-util' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'encodings-1.0.2,1' with 'x11-fonts/encodings' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'expat-2.0.1' with 'textproc/expat2' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnome_subr-1.0' with 'sysutils/gnome_subr' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'dmidecode-2.9' with 'sysutils/dmidecode' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'pciids-20081012' with 'misc/pciids' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'hicolor-icon-theme-0.10_2' with 'misc/hicolor-icon-theme' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnomehier-2.3_10' with 'misc/gnomehier' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'python25-2.5.2_3' with 'lang/python25' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'xcb-proto-1.2' with 'x11/xcb-proto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'perl-5.8.8_1' with 'lang/perl5.8' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'png-1.2.33' with 'graphics/png' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libdrm-2.3.1' with 'graphics/libdrm' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libdaemon-0.12' with 'devel/libdaemon' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'icu-3.8.1_1' with 'devel/icu' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gdbm-1.8.3_3' with 'databases/gdbm' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libiconv-1.11_1' with 'converters/libiconv' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'samba-libsmbclient-3.0.32_1' with 'net/samba-libsmbclient' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libxml2-2.6.32_2' with 'textproc/libxml2' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'dbus-1.2.1' with 'devel/dbus' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gettext-0.17_1' with 'devel/gettext' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnome-mime-data-2.18.0_3' with 'misc/gnome-mime-data' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'glib-2.16.5' with 'devel/glib20' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gamin-0.1.9_2' with 'devel/gamin' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gio-fam-backend-2.16.5' with 'devel/gio-fam-backend' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'desktop-file-utils-0.15_1' with 'devel/desktop-file-utils' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'dbus-glib-0.76' with 'devel/dbus-glib' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'avahi-app-0.6.23' with 'net/avahi-app' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'policykit-0.9_1' with 'sysutils/policykit' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'consolekit-0.2.10_3' with 'sysutils/consolekit' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'hal-0.5.11_1' with 'sysutils/hal' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libIDL-0.8.11' with 'devel/libIDL' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'ORBit2-2.14.14' with 'devel/ORBit2' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'shared-mime-info-0.51' with 'misc/shared-mime-info' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'pango-1.20.5' with 'x11-toolkits/pango' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libgpg-error-1.6_1' with 'security/libgpg-error' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libgcrypt-1.4.1_1' with 'security/libgcrypt' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnutls-2.4.2_1' with 'security/gnutls' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'cups-base-1.3.9' with 'print/cups-base' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'atk-1.22.0_1' with 'accessibility/atk' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gtk-2.12.11_1' with 'x11-toolkits/gtk20' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gconf2-2.22.0_1' with 'devel/gconf2' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnome-vfs-2.22.0_2' with 'devel/gnome-vfs' origin.
 - already installed.
pkg_add: 1 package addition(s) failed
is there solution .
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

I think it's because packages, that you already have are older, than OOO package, that I build....

check if your ports are up to date...

Frankly I haven't seen this error before


EDIT:
but wouldn't pkg_add say, that???
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

I need someone to host FreeBSD packages.
I will make packages for all languages.....
Some 10-15GB may be needed.
Unfortunately I can't upload this to failiem.lv.... If I'd want to I'd have to pay some 30$, which I don't have.

Also I've e-mailed different organizations, hopefully someone will take care of ftp hosting.


Please someone help
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

I've finished building OOO packages for ALL languages....
Now waiting for some developer to verify them, so I can upload to ftp server of Linux Center of Latvia University

Some stats:
Code:
Compiling: about 30h
Packaging: about 19h
Roughly based on my observation

Code:
Total time 49h based on uptime
Package total size: 14GB
Space necessary to build: 60+GB
My system:
Code:
CPU: Pentium 4 HTT @3GHz
RAM: 2.5GB @ 400Mhz
HDD: geli encrypted (AES-256) with zfs on top
Using ccache for long time

ccache stats (including everything I compiled with ccache):
Code:
killasmurf86 $ ccache -s
cache directory                     /var/db/ccache
cache hit                         227422
cache miss                        371111
called for link                    35836
multiple source files                143
compile failed                      8902
ccache internal error                  5
preprocessor error                  5314
couldn't find the compiler             5
not a C/C++ file                   27426
autoconf compile/link              60928
unsupported compiler option         2144
no input file                      20235
files in cache                    333775
cache size                           5.2 Gbytes
max cache size                       6.0 Gbytes
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

Here's temp sollution.
It's my home box, so it may be up and down... etc
ftp://83.241.11.135/Pub/FreeBSD-8-CURRENT/OpenOffice.org/3.1.1/i686/packages/

you can use axel to download files faster.... (not sure how fast it will be)
I have 100MB/s internet

Also it's my first ftp server setup, so if you see something wrong, or something vulnerable, please do let me know.

EDIT
If you can't connect to ftp, try:
http://83.241.11.135:81/

don't be shy to press ------------------------------------------------------------------------------------------------------------ button --------\/
 

SIFE

Well-Known Member

Reaction score: 17
Messages: 472

i don't see any thing intersting in portmaster --check-depends ,plus i don't install any previous version of openoffice.org .
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

I don't know what you mean.
Look at source ;)
/usr/ports/editors/openoffice.org-3/Makefile
it has all the answers
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

My server is down for now....
I'm uploading files to server in France...
Hopefully in 2 days It'll be finished
 

SIFE

Well-Known Member

Reaction score: 17
Messages: 472

i try to install it but i am still in the some above msg i had post ,do you build it in FreeBSD 7.x ?
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

killasmurf86 said:
Yesterday I started building OpenOffice.org-3.1.1 i686 (pentium2 or newer) packages for FreeBSD-8.0-RELEASE
No it's for 8-RELEASE only
 

SIFE

Well-Known Member

Reaction score: 17
Messages: 472

i have custom stable kernel 8 ,any suggestion to make openoffice running again ?
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

SIFE said:
i have custom stable kernel 8 ,any suggestion to make openoffice running again ?
Custom kernel has nothing to do with OOO. I use custom kernel as well

SIFE said:
i have gnome2.26 , i fail when i add openoffice :
Code:
Package 'en-openoffice.org-US-3.0.0' depends on 'kbproto-1.0.3' with 'x11/kbproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'inputproto-1.4.2.1' with 'x11/inputproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'fixesproto-4.0' with 'x11/fixesproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'damageproto-1.1.0_2' with 'x11/damageproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'compositeproto-0.4' with 'x11/compositeproto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'font-util-1.0.1' with 'x11-fonts/font-util' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'encodings-1.0.2,1' with 'x11-fonts/encodings' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'expat-2.0.1' with 'textproc/expat2' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnome_subr-1.0' with 'sysutils/gnome_subr' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'dmidecode-2.9' with 'sysutils/dmidecode' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'pciids-20081012' with 'misc/pciids' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'hicolor-icon-theme-0.10_2' with 'misc/hicolor-icon-theme' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnomehier-2.3_10' with 'misc/gnomehier' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'python25-2.5.2_3' with 'lang/python25' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'xcb-proto-1.2' with 'x11/xcb-proto' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'perl-5.8.8_1' with 'lang/perl5.8' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'png-1.2.33' with 'graphics/png' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libdrm-2.3.1' with 'graphics/libdrm' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libdaemon-0.12' with 'devel/libdaemon' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'icu-3.8.1_1' with 'devel/icu' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gdbm-1.8.3_3' with 'databases/gdbm' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libiconv-1.11_1' with 'converters/libiconv' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'samba-libsmbclient-3.0.32_1' with 'net/samba-libsmbclient' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libxml2-2.6.32_2' with 'textproc/libxml2' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'dbus-1.2.1' with 'devel/dbus' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gettext-0.17_1' with 'devel/gettext' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnome-mime-data-2.18.0_3' with 'misc/gnome-mime-data' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'glib-2.16.5' with 'devel/glib20' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gamin-0.1.9_2' with 'devel/gamin' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gio-fam-backend-2.16.5' with 'devel/gio-fam-backend' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'desktop-file-utils-0.15_1' with 'devel/desktop-file-utils' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'dbus-glib-0.76' with 'devel/dbus-glib' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'avahi-app-0.6.23' with 'net/avahi-app' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'policykit-0.9_1' with 'sysutils/policykit' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'consolekit-0.2.10_3' with 'sysutils/consolekit' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'hal-0.5.11_1' with 'sysutils/hal' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libIDL-0.8.11' with 'devel/libIDL' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'ORBit2-2.14.14' with 'devel/ORBit2' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'shared-mime-info-0.51' with 'misc/shared-mime-info' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'pango-1.20.5' with 'x11-toolkits/pango' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libgpg-error-1.6_1' with 'security/libgpg-error' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'libgcrypt-1.4.1_1' with 'security/libgcrypt' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnutls-2.4.2_1' with 'security/gnutls' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'cups-base-1.3.9' with 'print/cups-base' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'atk-1.22.0_1' with 'accessibility/atk' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gtk-2.12.11_1' with 'x11-toolkits/gtk20' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gconf2-2.22.0_1' with 'devel/gconf2' origin.
 - already installed.
Package 'en-openoffice.org-US-3.0.0' depends on 'gnome-vfs-2.22.0_2' with 'devel/gnome-vfs' origin.
 - already installed.
pkg_add: 1 package addition(s) failed
is there solution .
I've just noticed, that you try to install OOO-3.0.0 what does that have to do to current thread about OOO-3.1.1 ? Where did you even get it?

Currently my server is down. i'm uploading to server in France...
I can upload one of my packages to failiem.lv. (I actually suggest you to try it)

Download it and show me output of pkg_add ....
 

SIFE

Well-Known Member

Reaction score: 17
Messages: 472

i think you build your ooo with RELEASE kernel ,for that does not work for me .
i had try your package from failiem.lv and i am in some problem .
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

Show me output of pkg_add

custom/generic kernel has nothing to do with OOO packages.... absolutely
 

Voltar

Active Member

Reaction score: 24
Messages: 191

Did you ever find a place to host these packages? I'm getting speeds so slow from failiem.lv (32 KBps) that I almost think I could compile it faster.
 
OP
OP
graudeejs

graudeejs

Son of Beastie

Reaction score: 690
Messages: 4,615

Yes I found... They will be hosted on server in France once I finish uploading...

sorry for speed
 

Voltar

Active Member

Reaction score: 24
Messages: 191

killasmurf86 said:
Yes I found... They will be hosted on server in France once I finish uploading...

sorry for speed
Not a problem, I was going to offer if you hadn't found anywhere.
 
Status
Not open for further replies.
Top