• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Openldap server Bus Error

Xavier Humbert

New Member

Thanks: 1
Messages: 6

#1
Hello,

Code:
[root@numenor ~]# uname -a
FreeBSD numenor.groumpf.org 11.1-STABLE FreeBSD 11.1-STABLE #46 r326459: Sat Dec  2 09:23:57 CET 2017
root@numenor.groumpf.org:/usr/obj/usr/src/sys/XAVIER  amd64
My Openldap server won't launch. The process slapd aborts with a bus error.
Here is truss output :

https://www.groumpf.org/vrac/truss.txt

My slapd.conf file :
Code:
#
# See slapd.conf(5) for details on configuration options.
# This file should NOT be world readable.
#
include       /usr/local/etc/openldap/schema/core.schema

# Define global ACLs to disable default read access.

# Do not enable referrals until AFTER you have a working directory
# service AND an understanding of referrals.
#referral   ldap://root.openldap.org

pidfile       /var/run/openldap/slapd.pid
argsfile   /var/run/openldap/slapd.args

# Load dynamic backend modules:
modulepath   /usr/local/libexec/openldap
moduleload   back_mdb
moduleload   back_ldap

# Ajout de log verbeux
loglevel 256

database   mdb
maxsize       1073741824
suffix       "dc=groumpf,dc=org"
rootdn       "cn=admin,dc=groumpf,dc=org"
rootpw       {SSHA}XXXXXXXXXXdirectory   /var/db/openldap-data
index   objectClass   eq
Despite loglevel 256, I have nothing useful in /var/log/slapd.log (just a line saying slapd is starting, evan no indication of the crash)

Can someone help, please ?
TIA,
Xavier
 

Snurg

Aspiring Daemon

Thanks: 262
Messages: 716

#2
Do the same things you are used to do when you encounter a SIGSEGV. (Short background and possibly useful info here)
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,509
Messages: 25,699

#3

Xavier Humbert

New Member

Thanks: 1
Messages: 6

#5
[SOLVED]
Apprently, the problem was related to openldap-client, which was build from previous install with WITH_FETCH options. Dunno if it is the root of the problem, but reinstalling from scratch with default options the couple openladp-server/client fixed the problem
Thanks for the help, anyway