Solved openldap-dependency with powerdns

hannsmattes

New Member


Messages: 1

Hi,

I'd like to install powerdns-server, built with poudriere, with the ldap-backend. The server is running openldap25 server and client on Freebsd-13, but powerdns insists on openldap24-client and pkg-install wants to delete openldap25-server and openldap25-client.
I wonder where the dependency on openldap24-client comes from, I don't see anything related in the ports-directory and using
Code:
 make build-depends-list && make run-depends-list

Can I somehow force the usage of openldap25*? I've tried with DEFAULT_VERSION to no avail.

Regards Hanns
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,685
Messages: 39,278

Not sure if this works but try setting in your poudriere make.conf:
Code:
DEFAULT_OPENLDAP_VER=	25

There hasn't been a need for a default LDAP version because for a long time 2.4 was the only version that was available. But looking at /usr/ports/Mk/bsd.ldap.mk that does seem to be configurable now. It doesn't seem to have found its way into /usr/ports/Mk/bsd.default-versions.mk yet.

I wonder where the dependency on openldap24-client comes from
Code:
OPENLDAP_USE=		OPENLDAP=YES
OPENLDAP_CXXFLAGS=	-DLDAP_DEPRECATED=1
OPENLDAP_VARS=		MODULES+=ldap
This pulls in Mk/bsd.ldap.mk, which in turn is set to use 2.4 by default. Thus enabling LDAP would always pull in openldap24-client.
 

T-Daemon

Daemon

Reaction score: 929
Messages: 1,816

Can I somehow force the usage of openldap25*?
This pulls in Mk/bsd.ldap.mk, which in turn is set to use 2.4 by default. Thus enabling LDAP would always pull in openldap24-client.
It should build with OpenLDAP version 25 when set to
/usr/ports/Mk/bsd.ldap.mk
Code:
# WITH_OPENLDAP_VER
#                - User defined variable to set OpenLDAP version
Code:
# pwd
/usr/ports/dns/powerdns
# make showconfig | grep -i openldap
     OPENLDAP=on:   OpenLDAP backend

# setenv WITH_OPENLDAP_VER 25
# make missing | grep openldap
net/openldap25-client
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,685
Messages: 39,278

Ideally this should be configurable through DEFAULT_VERSIONS, just like other defaults. Something like DEFAULT_VERSIONS = ldap=2.5. That hasn't been implemented yet though.
 
Top