I want to convert from using Mageia 5 to BSD.

A critical application I use every day is openCpn. That because I work and live aboard a ship.
The source is available.
How different will the compilation be from a linux compilation?
Suggestions please to [Mod: email address redacted].....

The link there in that post did not work for me.

Try This:
git clone /OpenCPN
Thank you for your attention to my problem.........
The snippet of code mentioned in one reference is a sub-routine expressly testing the availability of a serial port.

Use of the serial port is somewhat archaic. It is used to communicate with a GPS receiver, external to the computer running openCpn, and with autopilots. The program runs fine in it's absence. Today few computers come with serial ports, and communication is mostly via USB.

The answer lies in how you test existence of a serial port in BSD...... It's been a long time......... but isn't that a simple task involving a call??

The PR 211199 post contains a makefile...... not mentioned explicitly is the version of openCpn to which this applies.... also openCpn is available as a tarball......
one would only use GitHub to get bleeding edge stuff.

If anyone knows the version used....... I'll try to compile it........ or will try installing the version in the tbz....... which ever is recommended.

BTW......... I use openCpn everyday........... I have worldwide charts for it.......... I have navigated the world with it.........


The PR 211199 post contains a makefile...... not mentioned explicitly is the version of openCpn to which this applies.... also openCpn is available as a tarball...... One would only use GitHub to get bleeding edge stuff.
Looks like you're not understanding our ports system.


I highly recommend reading the Porter's Handbook to understand how ports are made.
I did a search for a port labeled OpenCPN in the "misc" category........
However nothing comes up................
Does this port exist???
If not...........
It would seem that I need to build myself my own private executible.......
No, it doesn't exist. That's what the PR is for, to add it.
So, is my interim move best a move to DebianKfreeBSD????


Do I have a shot at compiling it???
Try the port in the PR and report any issues you have with it. That way it can be improved and, eventually, be added to the ports system.

Please note that ports are a community effort. Nobody is getting paid to create ports, it's all voluntary.
So just right-click the hyperlink titled "Port skeleton" on the PR to download the diff file.

Then run this:
patch -u < ./OpenCPN.diff

It will create a port skeleton which you can run make install on under the /usr/OpenCPN directory.
I have trouble with the port. First it error-ed out on wxSVG then I installed that via pkg and it got further along but dropped at more wx stuff. Something about a pi-plugin. If I knew more I would say drop the plugin from the build and it might work somewhat.
I got the build to continue until it errored out building the plugins.........
Apparently a header file is missing or corrupt, because the same error occurs in multiple builds

I'm going to try the other port

PS: Just to make sure.......... I git cloned the latest from OpenCPN and sucessfully built it on my Mageia 5 system, then sucessfully installed it there. So the Makefile and files distributed by the vendor work on Linux.
That sounds like the same spot I ran into. Being a plugin I wonder if we could plow past it.

Have you commented on the PR page?? The author could help. All you need to do is sign up. All relevant comments welcome. Use supporting documentation if possible. Yell if you need help.
Are you going to write this up or do you want me to help you? The port's author may have no idea anything is wrong unless someone speaks up.
I don't mind commenting if you don't want to.

All you really need to do is include a snip of the last dozen lines of text including the errors..
One question is -have you tried this on FreeBSD 10.3? My testing was done on FreeBSD 11 RC2.
Before complaining I like to have my facts in line. Will try it myself if not.

I am assuming the earlier port version you tried did not build as well?
Looking good. Still trying to figure out how to use a cellular modems GPS signal with it. Looks like maybe via GPSD.