OpenBSD: ip after startup gone ?!?

Wat3rboy

New Member


Messages: 2

Hello!
i've a new/old openBSD 4.4 installed!
that was no problem.
i want no dynamic ipv4 addressing an so i use the command ifconfig for static ip!
but everytime when i start the pc it search for a dhcp_offer or anything! and when the system is up, there is no static ip...;(
what can i do to solve this

thx
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,719
Messages: 39,309

Err.. Wrong forum dude
This forum is about FreeBSD, not OpenBSD :beergrin
 

danger@

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 408
Messages: 1,010

You should direct your questions related to OpenBSD to OpenBSD mailing lists....

However, this might help you.
 

Oko

Daemon

Reaction score: 796
Messages: 1,620

Wat3rboy said:
Hello!
i've a new/old openBSD 4.4 installed!
that was no problem.
i want no dynamic ipv4 addressing an so i use the command ifconfig for static ip!
but everytime when i start the pc it search for a dhcp_offer or anything! and when the system is up, there is no static ip...;(
what can i do to solve this

thx
Look your question. You said you want to use only static address but then you are looking for dhcp offer. Do you see how ridiculus is that statement. If the router is configured to work in the static mode then DHCP server is turned off. You have to
configure manually interface /etc/host.interface with IP address.
You also need manually to enter your DNS server.

SirDice said:
Err.. Wrong forum dude
This forum is about FreeBSD, not OpenBSD :beergrin

Please, what is the big deal? It is a BSD for GOD's sake just a
little bit simpler than FreeBSD.
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

Most ridiculous is that OP problem is not OpenBSD specific. It could happen on any POSIX OS.
 

quintessence

Active Member

Reaction score: 42
Messages: 190

cliedo said:
did you do an edit to your rc.conf if not do ee /etc/rc.conf then enable the nic


there is no ee in OpenBSD :)

Wat3rboy, in OpenBSD by default dhcpd server is not running , so probably your network configuration is wrong and you have to disable PXE booting :)
 
Top