[Openbox] wbar first and last icon is not working

emka81

Member


Messages: 28

Hello guys,

a very, very strange thing on my wbar happened.

I usually start wbar in the autostart.sh from my openbox config directory (.config/openbox/autostart.sh )

it is working, no problem, but the command for the first and the last icon is not !

Code:
killall wbar

and then i run the same command as it stands in the autostart.sh file in xterm for examples

Code:
wbar &

then the first and the last icon is WORKING. It is the same config file, and i don't know where the fault is.

my config file:
Code:
#The Bar && Font
i: /home/gargamel/.config/openbox/wbar/osxbarback.png
c:
t: /home/gargamel/.config/openbox/wbar/font/16

#Filemanager
i: /home/gargamel/.config/openbox/wbar/nautilus.png
c: krusader
t: Krusader

#Youtube
i: /home/gargamel/.config/openbox/wbar/psi.png
c: minitube
t: Minitube

#Firefox
i: /home/gargamel/.config/openbox/wbar/firefox.png
c: firefox3
t: Firefox
 
and so on ....

summary:
starting in autostart.sh not working but the same icons, and everything looks the same
starting in xterm it is working ...

I hope someone could have the right answer ...

greets Martin
 
OP
E

emka81

Member


Messages: 28

I solved the problem.

The problem was, i have slim (graphical login manager) and slim ignores /etc/login.conf and ~/.login_conf so my PATH variable was not up-to-date when starting wbar. I have to say, it is only a guess but since i wrote my PATH variable to ~/.xinitrc everything has been working

greets Martin
 
Top