Only one monitor shows up in the xrandr command. I have three monitors plugged in. How do I get the other two to work?

Foomf

New Member


Messages: 1

I recently installed freebsd (12.2-RELEASE). I'm using an amd graphics card (5500xt with amdgpu module). I know all the monitors are plugged in correctly and work because they all work fine on windows and linux installs. Where do I begin troubleshooting a problem like this? Thank you!
 

Watitsthis

New Member

Reaction score: 13
Messages: 18

I recently installed freebsd (12.2-RELEASE). I'm using an amd graphics card (5500xt with amdgpu module). I know all the monitors are plugged in correctly and work because they all work fine on windows and linux installs. Where do I begin troubleshooting a problem like this? Thank you!
/usr/local/etc/X11/xorg.conf.d

Need to add the Monitors .conf and the Video card drivers.

Another config location.

I use xrandr to wrap the monitor positioning + size = again not sure if that is norm just works for me.
 
Last edited:

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,742
Messages: 36,545

After that

/etc/X11/xorg.conf
Remove that file. For starters, it doesn't belong there, it should be /usr/local/etc/X11/xorg.conf if you must use it. Second, Xorg does a good job auto-detecting most hardware these days. If you need to tweak the configuration because the auto-detection missed something add configuration 'snippets' to /usr/local/etc/X11/xorg.conf.d. There's really no need for a xorg.conf to exist nowadays.
 

Watitsthis

New Member

Reaction score: 13
Messages: 18

Remove that file. For starters, it doesn't belong there, it should be /usr/local/etc/X11/xorg.conf if you must use it. Second, Xorg does a good job auto-detecting most hardware these days. If you need to tweak the configuration because the auto-detection missed something add configuration 'snippets' to /usr/local/etc/X11/xorg.conf.d. There's really no need for a xorg.conf to exist nowadays.
So after doing another installation in a new computer Desktop... I realize that what SirDice says is soo true.... FREEBSD has been trying to move away from /etc/X11/xorg.conf and BOZOS like me suggesting that old config is useless. Anyways I saw the light O:‑)😅.... In new installation I deleted all /etc/X11/ = Literally this thing can be empty....

and did all of the config on

/usr/local/etc/X11/

All that is needed now is the CARD driver config. No need to mess with monitor, and extra things....

Anyways...

This is all you need in:

/usr/local/etc/X11/

In a .conf file

If you know Bus... pciconf -l
Code:
Section "Device"
  Identifier "Card0"
  Driver "nvidia"
  BusID "PCI:2:0:0"
  Option "DPMS"
EndSection
or
Code:
Section "Device"
  Identifier "Card0"
  Driver "nvidia"
EndSection

It's truly amazing..... NO more nvidia-xconfig or none of that BS.

don't forget
/boot/loader.conf
Code:
nvidia_load="YES"
nvidia-modeset_load="YES"
 
Top