olwm

nedry

Active Member

Thanks: 8
Messages: 238

#1
Hi i just tried to compile olwm on an 64bit system and I get the following error:
Code:
root@bsdbox:~ # cd /usr/ports/x11-wm/olvwm
root@bsdbox:/usr/ports/x11-wm/olvwm # make install clean
===>   olvwm-4.2_1 depends on executable: imake - found
===>   olvwm-4.2_1 depends on executable: tradcpp - found
===>   olvwm-4.2_1 depends on file: /usr/local/libdata/pkgconfig/xpm.pc - found
===>   olvwm-4.2_1 depends on shared library: libxview.so - not found
===>  xview-3.2.1.4.19c_3 is only for i386, while you are running amd64.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/x11-toolkits/xview
*** Error code 1

Stop.
make: stopped in /usr/ports/x11-wm/olvwm
root@bsdbox:/usr/ports/x11-wm/olvwm #
Does anyone know how hard it would be to solve this issue?
thanks
nedry
 

Crivens

Moderator
Staff member
Moderator

Thanks: 684
Messages: 1,639

#2
Very. I tried and gave up after some days. You may build it in a 32 bit env and use the binaries in the 64 bit system. Or use The open-look theme for xfce.
 

MarcoB

Well-Known Member

Thanks: 92
Messages: 337

#4
The original olwm is 32 bit only. To run it you'll need the 32 bit libraries. To compile it maybe you can try it in a poudriere i386 jail and install the built packages..
 
Top