olvwm wm compile error

Hello, during doing a make install in /usr/ports/x11-wm/olvwm I get the following error:


I am going to try and compile xview separately and see if it will install.
OK, just tried a make install in /usr/ports/x11-toolkits/xview and I get the same error about it being a 64bit system and xview is only i386


I guess it would take a re-write to fix this :(
According to svn blame this was added in 2008:
r217128 | miwi | 2008-07-19 19:27:39 +0200 (Sat, 19 Jul 2008) | 7 lines

- Set only i386 -  Attempting to launch any application
  that uses xview on amd64 causes a segmentation dump
  (signal 10, bus error).
I tried adding amd64 to ONLY_FOR_ARCHS and it compiled fine. But olvwm still segfaults. The XView homepage has this to say, so you're probably right.
There is no 64-bit version of XView, and it is unlikely that one will be produced. Although a port of XView to 64-bit architectures was reported in progress as of April 2006, this effort appears to have stalled. Unfortunately, the changes that would be required to create a 64-bit version are very extensive, requiring an effort that would be similar to starting from scratch. Fortunately, 64-bit platforms can run XView in 32-bit compatibility mode.