okular printing problem

lbol

Member

Reaction score: 10
Messages: 70

Hi, I have a problem printing from graphics/okular to a remote printer. The message from graphics/okular is
Code:
/usr/local/bin/lpr-cups: No such file or directory
/usr/local/bin/lpr-cups is installed from print/cups
Printing to a local USB printer is working without any issues.

I am on FreeBSD 11.2-RELEASE-p4 with okular-18.08.1 and cups-2.2.8_1
Any ideas what could be the issue?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,087
Messages: 29,244

What's the first line of /usr/local/bin/lpr-cups? You can get the same confusing error message if the shebang line is not correct and pointing to a non-existing interpreter or shell.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,087
Messages: 29,244

Scratch that. It's a binary. But on the system I did a quick install on /usr/local/bin/lpr-cups is actually a symlink to lpr. You mentioned the file does exist but is it a symlink? And does /usr/local/bin/lpr exist?
Code:
root@molly:~ # ll /usr/local/bin/lpr-cups
lrwxr-xr-x  1 root  wheel  3 Oct 22 00:24 /usr/local/bin/lpr-cups@ -> lpr
root@molly:~ # ll /usr/local/bin/lpr
-r-xr-xr-x  1 root  wheel  23688 Oct 22 00:24 /usr/local/bin/lpr*
 
OP
OP
L

lbol

Member

Reaction score: 10
Messages: 70

/usr/local/bin/lpr exists
Code:
# ll /usr/local/bin/lpr-cups
lrwxr-xr-x  1 root  wheel  3 Jul  3 11:48 /usr/local/bin/lpr-cups -> lpr
# ll /usr/local/bin/lpr
-r-xr-xr-x  1 root  wheel  13096 Jul  3 11:48 /usr/local/bin/lpr
It's very strange that printing to a local printer is working. I would assume that /usr/local/bin/lpr-cups would also be used in this case.
 

hwagemann

Active Member

Reaction score: 32
Messages: 106

Hello,

I've a similar issue some weeks ago. After installing further stuff from cups on remote FreeBSD system (which works as printserver) like cups-filters and cups-pdf, the issue has gone and remote printing from okular now works.

Kind regards
Holger
 
OP
OP
L

lbol

Member

Reaction score: 10
Messages: 70

The remote printserver is a Raspberry Pi running Linux. cups-filters was installed on that system. I also installed cups-pdf but this did not solve the issue.
 
Top