okular: cups and lpd mismatch?

Hi all!

I'm using the standard lpd() to print.
While the print/cups-client combined into print/cups can't use the standard lpd only from commandline.
When I want to print from graphics/okular it prints into stdout (or stderr):
lpr-cups: Bad file descriptor

I think it calls /usr/local/bin/lpr and it causes an error because the cupsd not running. My PATH is:
Note that the /usr/local/bin (directory of cups's lpr) is the last.

How can I print from okular?
Most current PostScript printers actually understand PDF natively. In theory, anyway.

Does okular offer any configuration of the command it uses to print, like graphics/xpdf does?
I don't know about Qt based applications but gtk3 removed LPD support in the print dialogs. My work around is to print to a file (*ps vs *pdf). If you have a pdf you can convert to postscript pdf2ps, print/ghostscript9-base, or pdftops, graphics/poppler-utils The latter command renders better for me. Another option is to open the pdf in something like graphics/xpdf and use that print dialog.
And do you print from command line (using /usr/bin/lpr generated.ps)? I don't want this because my girlfriend uses graphics/okular and she doesn't like CLI ;)
Yes, I print from the command line or non-gtk3 applications (Firefox-esr). The lack of direct printing to LPD is an upsteam decision for gtk3 that I found on a Redhat/Fedora mailing list.
The grandfather of okular/evince is print/gv, it will open pdfs/postscript files and has a "print" button.
I did a quick web search and found this. Not sure if the workaround is still an option. If not then you may have to use cups to keep peace.