Oidentd bad IRC Ident ~

enCyde

Member


Messages: 31

Can't get my ident on IRC to work (~)

I have searched the forum for an answer but none of the threads has solved my problem, maybe I just don't understand. Anyway here is my problem.

Oidentd installed. Port 113 is open.
Code:
oidentd_enable="YES"
is added.

Here is my oidentd.conf:

Code:
default {
        default {
                allow spoof
                deny spoof_all
                deny spoof_privport
                allow random_numeric
                allow numeric
                allow hide
        }
}

global { Reply "hello" }

user root {
        default {
                force reply "UNKNOWN"
        }
}

What have I missed? I'm doing something wrong, I know that.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,346
Messages: 38,863

If you're behind a router you need to make sure port 113 is forwarded on it.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,346
Messages: 38,863

Run a tcpdump(1) on your server and see if packets are actually arriving.

Something like this should do the trick:
# tcpdump -Xn port 113
 
OP
enCyde

enCyde

Member


Messages: 31

Code:
Listening on bgd0, link-type EN10MB (ethernet) capture size 65535 bytes.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,346
Messages: 38,863

When tcpdump(1) is running elicit an ident check. You should see the connection being built. If there's nothing being printed (besides the first line you showed) there's nothing coming in. Either your forwarding isn't working correctly or the IRC server isn't sending an ident request.
 
OP
enCyde

enCyde

Member


Messages: 31

Hmm, is there anything else that can cause it? Except the firewall. Anything in the hosts file? Or the network setup? I will take a look when I get home.
 
OP
enCyde

enCyde

Member


Messages: 31

I have no idea why I don't get a response on port 113. It's all open in the firewall.
 

Abriel

Active Member

Reaction score: 23
Messages: 119

Try
[CMD="tcpdump"] -l -i your_internet_interface | grep auth[/CMD]
because
[CMD="tcpdump"]-Xn port 113[/CMD]
don't work.

I remember I had a problem with D-Link routers and forwarding. After I kicked it from my network, everything started to work.

This
Code:
global { Reply "hello" }

doesn't work in my config, try disabling it and run oidentd.
 
OP
enCyde

enCyde

Member


Messages: 31

Thanks for the reply. But that did not solve my problem.

I was looking into /var/log/messages and I found this
Code:
inetd[1623]: /etc/inetd.conf: too many arguments for service auth

Maybe this is the problem. I'm not sure
 
OP
enCyde

enCyde

Member


Messages: 31

Code:
#auth   stream  tcp     nowait  root    internal
#auth   stream  tcp6    nowait  root    internal

#  auth stream  tcp     nowait  root    internal        auth -r -f -n -o UNKNOWN -t 30
#  auth stream  tcp6    nowait  root    internal        auth -r -f -n -o UNKNOWN -t 30

I have those lines.

---

And another thing is: my oidentd.conf is located in /usr/local/etc/oidentd.conf, isn't that wrong? Isn't it supposed to be located like /etc/oidentd.conf ?
 
OP
enCyde

enCyde

Member


Messages: 31

And when I run [cmd-]tcpdump -l -i bge0 | grep auth[/cmd] and connect to an IRC server that is trying to get my ident it shows this:

Code:
11:06:45.885338 IP 192.168.1.3.auth > irc.dal.net.56767: Flags [S.],
 seq 3121924455, ack 3002587242, win 65535, options [mss 1460,nop,wscale 6,sackOK,eol], length 0

Is that telling me something is wrong or what?
 

Abriel

Active Member

Reaction score: 23
Messages: 119

/usr/local/etc/oidentd.conf is correct.

Show me:
[CMD="ps"]aux | grep oidentd[/CMD]
 
OP
enCyde

enCyde

Member


Messages: 31

Code:
4m3rz# ps aux | grep oidentd
root    9381   0.0  0.1   9748   1228   0  R+   12:52PM   0:00.00 grep oidentd

that is what I get.

Abriel:
You fixed yours. Is there anything I need to edit in /etc/inetd.conf ?
 
OP
enCyde

enCyde

Member


Messages: 31

Code:
l4m3rz# /usr/local/etc/rc.d/oidentd rcvar
# oidentd
#
oidentd_enable="YES"
#   (default: "")

There you go.
 

Abriel

Active Member

Reaction score: 23
Messages: 119

[CMD="/usr/local/etc/rc.d/oidentd"]start[/CMD]
and
[CMD="ps"]aux | grep oidentd[/CMD]
 
OP
enCyde

enCyde

Member


Messages: 31

Code:
l4m3rz# /usr/local/etc/rc.d/oidentd start
oidentd already running? (pid=9020).

ps aux | grep oidentd
l4m3rz# root    9500   0.0  0.1   9748   1228   0  R+    1:30PM   0:00.00 grep o
 

Abriel

Active Member

Reaction score: 23
Messages: 119

Weird, you should have something like this
Code:
root     1695   0.0  0.0  10052   1496  ??  Is   12:40PM     0:00.00 /usr/local/sbin/oidentd -C /usr/local/etc/oidentd.conf
 

Abriel

Active Member

Reaction score: 23
Messages: 119

No, but you can try turn off inetd
[CMD="/etc/rc.d/inetd"]stop[/CMD]
and then
[CMD="/usr/local/etc/rc.d/oidentd"]restart[/CMD]
 
OP
enCyde

enCyde

Member


Messages: 31

Code:
l4m3rz# /etc/rc.d/inetd stop
Stopping inetd.
Waiting for PIDS: 9213.
l4m3rz# /usr/local/etc/rc.d/oidentd restart
Stopping oidentd.
Starting oidentd.
l4m3rz# ps aux | grep oidentd
root    9660   0.0  0.1   9748   1240   1  RL+   2:38PM   0:00.00 grep oidentd
 
OP
enCyde

enCyde

Member


Messages: 31

Okey I did a chmod on oidentd.conf and did.

Code:
l4m3rz# ps aux | grep oidentd
root    9760   0.0  0.1   9540   1324  ??  Is    3:05PM   0:00.00 /usr/local/sbin/oidentd -C /usr/local/etc/oidentd.conf
root    9776   0.0  0.1   9748   1276   1  S+    3:07PM   0:00.00 grep oidentd

I think I got the correct output now, right?
 
OP
enCyde

enCyde

Member


Messages: 31

I don't know what the heck is wrong. I still get
Code:
*** No Ident response
I don't know what to look at next.
 
Top