Oh no! Something has gone wrong (GNOME3)

Dan Barowy

New Member


Messages: 5

#1
I installed GNOME3 last week (from ports) and used it successfully all week. Worked great.

Unfortunately, I went away for the weekend and turned off my desktop. I must have changed something the last time I used my machine because now, after I enter my login in GDM, I get a white screen that says "Oh no! Something has gone wrong." with a button that says "Log Out".

Now here's the puzzling part: gnome-shell appears to be running just fine. If I press the Windows key on my keyboard, I get the GNOME3 dock and workspace manager. I can start apps, etc. I just have to move them to my second display, because the primary display is covered by this "Oh no!" screen. I am, in fact, using Firefox on the machine right now.

Anyway, I can't think of anything that I might have changed.

Here are some puzzling entries in /var/log/messages:

Code:
Apr  2 19:36:15 computer dbus[648]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.29" (uid=92 pid=1119 comm="gnome-shell --mode=gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.1" (uid=0 pid=741 comm="/usr/local/sbin/console-kit-daemon --no-daemon ")
Apr  2 19:36:23 computer last message repeated 6 times
Apr  2 19:36:26 computer gdm[765]: Failed to remove greeter program access to the display. Trying to proceed.
Apr  2 19:36:26 computer gnome-keyring-daemon[1133]: couldn't register in session: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Apr  2 19:36:27 computer pulseaudio[1181]: [(null)] pid.c: Daemon already running.
Apr  2 19:36:27 computer pulseaudio[1179]: [(null)] oss-util.c: '/dev/dsp0' doesn't support full duplex
Apr  2 19:36:27 computer pulseaudio[1179]: [(null)] oss-util.c: '/dev/dsp1' doesn't support full duplex
Apr  2 19:36:27 computer pulseaudio[1179]: [(null)] oss-util.c: '/dev/dsp2' doesn't support full duplex
Apr  2 19:36:27 computer pulseaudio[1179]: [(null)] oss-util.c: '/dev/dsp3' doesn't support full duplex
Apr  2 19:36:28 computer pulseaudio[1179]: [(null)] oss-util.c: '/dev/dsp6' doesn't support full duplex
Apr  2 19:37:57 computer gnome-session-binary[1136]: WARNING: Application 'gnome-settings-daemon.desktop' failed to register before timeout
Apr  2 19:37:59 computer dbus[648]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.97" (uid=1001 pid=1187 comm="/usr/local/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.1" (uid=0 pid=741 comm="/usr/local/sbin/console-kit-daemon --no-daemon ")
Apr  2 19:37:59 computer dbus[648]: [system] Activating service name='org.freedesktop.GeoClue2' (using servicehelper)
Apr  2 19:37:59 computer dbus[648]: [system] Successfully activated service 'org.freedesktop.GeoClue2'
Apr  2 19:38:00 computer dbus[648]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.97" (uid=1001 pid=1187 comm="/usr/local/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.1" (uid=0 pid=741 comm="/usr/local/sbin/console-kit-daemon --no-daemon ")
Apr  2 19:38:00 computer dbus[648]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.98" (uid=0 pid=1198 comm="/usr/local/libexec/geoclue -t 5 ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination="org.freedesktop.DBus" (bus)
Apr  2 19:38:01 computer dbus[648]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.97" (uid=1001 pid=1187 comm="/usr/local/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.1" (uid=0 pid=741 comm="/usr/local/sbin/console-kit-daemon --no-daemon ")
Apr  2 19:38:02 computer last message repeated 4 times
And here are the most recent logs in /var/log/gdm, first :2-greeter.log:

Code:
** (gnome-settings-daemon:1109): WARNING **: Ignoring unknown module 'org.gnome.settings-daemon.plugins.orientation'

(gnome-settings-daemon:1109): media-keys-plugin-WARNING **: Unable to inhibit keypresses: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .service files

(gnome-settings-daemon:1109): color-plugin-WARNING **: failed to obtain org.freedesktop.color-manager.create-profile auth

(gnome-settings-daemon:1109): color-plugin-WARNING **: failed to obtain org.freedesktop.color-manager.create-profile auth
Gjs-Message: JS LOG: No permission to trigger offline updates: Polkit.Error: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.packagekit.trigger-offline-update is not registered
Gjs-Message: JS LOG: Could not get properties from org.freedesktop.locale1

(gnome-settings-daemon:1109): power-plugin-WARNING **: Unable to inhibit suspend: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .service files

(gnome-settings-daemon:1109): color-plugin-WARNING **: failed to create device: failed to obtain org.freedesktop.color-manager.create-device auth

(gnome-settings-daemon:1109): color-plugin-WARNING **: failed to create device: failed to obtain org.freedesktop.color-manager.create-device auth

(ibus-daemon:1120): GVFS-RemoteVolumeMonitor-WARNING **: Owner of volume monitor org.gtk.vfs.HalVolumeMonitor disconnected from the bus; removing drives/volumes/mounts

(ibus-daemon:1120): GVFS-RemoteVolumeMonitor-WARNING **: Owner of volume monitor org.gtk.vfs.GPhoto2VolumeMonitor disconnected from the bus; removing drives/volumes/mounts

(ibus-daemon:1120): GVFS-RemoteVolumeMonitor-WARNING **: Owner of volume monitor org.gtk.vfs.AfcVolumeMonitor disconnected from the bus; removing drives/volumes/mounts

(gnome-settings-daemon:1109): GLib-GIO-WARNING **: Invalid id 4 passed to g_bus_unown_name()
and then :2.log:

Code:
X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 11.0-RELEASE-p8 amd64
Current Operating System: FreeBSD computer 11.0-RELEASE-p8 FreeBSD 11.0-RELEASE-p8 #0: Wed Feb 22 06:12:04 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
Build Date: 14 March 2017  12:56:09PM
Current version of pixman: 0.34.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.2.log", Time: Sun Apr  2 19:36:09 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) Not automatically adding GPU devices
(==) Max clients allowed: 256, resource mask: 0x1fffff
(==) FontPath set to:
   /usr/local/share/fonts/misc/,
   /usr/local/share/fonts/TTF/,
   /usr/local/share/fonts/OTF/,
   /usr/local/share/fonts/Type1/,
   /usr/local/share/fonts/100dpi/,
   /usr/local/share/fonts/75dpi/
(==) ModulePath set to "/usr/local/lib/xorg/modules"
(WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(--) PCI:*(0:1:0:0) 10de:1380:19da:1346 rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/65536
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
(II) NVIDIA GLX Module  375.26  Thu Dec  8 18:20:58 PST 2016
(II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
(II) NVIDIA dlloader X Driver  375.26  Thu Dec  8 17:59:41 PST 2016
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(--) Using syscons driver with X support (version 549739036674.0)
(++) using VT number 9

(II) Loading /usr/local/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
   compiled for 1.18.4, module version = 1.0.0
(II) Loading /usr/local/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
   compiled for 1.18.4, module version = 1.0.0
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling 2D acceleration
(--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
(--) NVIDIA(0):     CRT-0
(--) NVIDIA(0):     DFP-0 (boot)
(--) NVIDIA(0):     DFP-1
(--) NVIDIA(0):     DFP-2
(--) NVIDIA(0):     DFP-3
(II) NVIDIA(0): NVIDIA GPU GeForce GTX 750 Ti (GM107-A) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 2097152 kBytes
(--) NVIDIA(0): VideoBIOS: 82.07.32.00.8e
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(GPU-0): CRT-0: disconnected
(--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): Internal TMDS
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-1: disconnected
(--) NVIDIA(GPU-0): DFP-1: Internal TMDS
(--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-2: disconnected
(--) NVIDIA(GPU-0): DFP-2: Internal TMDS
(--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): Internal DisplayPort
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): 960.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(==) NVIDIA(0):
(==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) NVIDIA(0):     will be used as the requested mode.
(==) NVIDIA(0):
(II) NVIDIA(0): Validated MetaModes:
(II) NVIDIA(0):     "DFP-0:nvidia-auto-select,DFP-3:nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 4480 x 1440
(--) NVIDIA(0): DPI set to (88, 89); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(--) Depth 24 pixmap format is 32 bpp
(II) NVIDIA: Reserving 12288.00 MB of virtual memory for indirect memory
(II) NVIDIA:     access.
(II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select,DFP-3:nvidia-auto-select"
(==) NVIDIA(0): Disabling shared memory pixmaps
(==) NVIDIA(0): Backing store enabled
(==) NVIDIA(0): Silken mouse enabled
(**) NVIDIA(0): DPMS enabled
(II) NVIDIA(0): [DRI2] Setup complete
(II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
(--) RandR disabled
(II) Initializing extension GLX
(II) Indirect GLX disabled.
(II) config/devd: probing input devices...
(II) config/devd: adding input device (null) (/dev/kbdmux)
(II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
   compiled for 1.18.4, module version = 1.9.0
(II) Using input driver 'kbd' for 'kbdmux'
(**) kbdmux: always reports core events
(**) kbdmux: always reports core events
(II) XINPUT: Adding extended input device "kbdmux" (type: KEYBOARD, id 6)
(II) config/devd: kbdmux is enabled, ignoring device ukbd0
(II) config/devd: kbdmux is enabled, ignoring device ukbd1
(II) config/devd: kbdmux is enabled, ignoring device atkbd0
(II) config/devd: adding input device (null) (/dev/sysmouse)
(II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
   compiled for 1.18.4, module version = 1.9.2
(II) Using input driver 'mouse' for 'sysmouse'
(**) sysmouse: always reports core events
(==) sysmouse: Protocol: "Auto"
(**) sysmouse: always reports core events
(==) sysmouse: Emulate3Buttons, Emulate3Timeout: 50
(**) sysmouse: ZAxisMapping: buttons 4 and 5
(**) sysmouse: Buttons: 5
(II) XINPUT: Adding extended input device "sysmouse" (type: MOUSE, id 7)
(**) sysmouse: (accel) keeping acceleration scheme 1
(**) sysmouse: (accel) acceleration profile 0
(**) sysmouse: (accel) acceleration factor: 2.000
(**) sysmouse: (accel) acceleration threshold: 4
(II) config/devd: device /dev/ums0 already opened
(II) config/devd: device /dev/ums1 already opened
(II) config/devd: device /dev/ums2 already opened
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): Internal DisplayPort
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): 960.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): CRT-0: disconnected
(--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): Internal TMDS
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-1: disconnected
(--) NVIDIA(GPU-0): DFP-1: Internal TMDS
(--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-2: disconnected
(--) NVIDIA(GPU-0): DFP-2: Internal TMDS
(--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): Internal DisplayPort
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): 960.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(II) NVIDIA(0): Setting mode "DVI-I-1: nvidia-auto-select @1920x1200 +2560+0 {ViewPortIn=1920x1200, ViewPortOut=1920x1200+0+0}"
(II) NVIDIA(0): Setting mode "DP-1: nvidia-auto-select @2560x1440 +0+0 {ViewPortIn=2560x1440, ViewPortOut=2560x1440+0+0}, DVI-I-1: nvidia-auto-select @1920x1200 +2560+0 {ViewPortIn=1920x1200, ViewPortOut=1920x1200+0+0}"
(--) NVIDIA(GPU-0): CRT-0: disconnected
(--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): Internal TMDS
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-1: disconnected
(--) NVIDIA(GPU-0): DFP-1: Internal TMDS
(--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-2: disconnected
(--) NVIDIA(GPU-0): DFP-2: Internal TMDS
(--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): Internal DisplayPort
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): 960.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): CRT-0: disconnected
(--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): Internal TMDS
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-1: disconnected
(--) NVIDIA(GPU-0): DFP-1: Internal TMDS
(--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-2: disconnected
(--) NVIDIA(GPU-0): DFP-2: Internal TMDS
(--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): Internal DisplayPort
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): 960.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(II) NVIDIA(0): Setting mode "DP-1: nvidia-auto-select @2560x1440 +0+0 {ViewPortIn=2560x1440, ViewPortOut=2560x1440+0+0}, DVI-I-1: nvidia-auto-select @1920x1200 +0+0 {ViewPortIn=1920x1200, ViewPortOut=1920x1200+0+0}"
(II) NVIDIA(0): Setting mode "DP-1: nvidia-auto-select @2560x1440 +1920+0 {ViewPortIn=2560x1440, ViewPortOut=2560x1440+0+0}, DVI-I-1: nvidia-auto-select @1920x1200 +0+0 {ViewPortIn=1920x1200, ViewPortOut=1920x1200+0+0}"
(--) NVIDIA(GPU-0): CRT-0: disconnected
(--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): Internal TMDS
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VK266H (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-1: disconnected
(--) NVIDIA(GPU-0): DFP-1: Internal TMDS
(--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): DFP-2: disconnected
(--) NVIDIA(GPU-0): DFP-2: Internal TMDS
(--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): connected
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): Internal DisplayPort
(--) NVIDIA(GPU-0): Ancor Communications Inc ASUS PB278 (DFP-3): 960.0 MHz maximum pixel clock
(--) NVIDIA(GPU-0):
 
OP
OP
D

Dan Barowy

New Member


Messages: 5

#2
Posting config files separately since I went over the 20k character limit... ;)

Here is my /etc/rc.conf:

Code:
kld_list="fuse"

clear_tmp_enable="YES"
syslogd_flags="-ss"
sendmail_enable="NONE"
ifconfig_re0="DHCP"
sshd_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
powerd_flags="-a hiadaptive -i 25"
dumpdev="AUTO"

# for X/GNOME3
zfs_enable="YES"
moused_enable="YES"
dbus_enable="YES"
hald_enable="YES"
gdm_enable="YES"
gnome_enable="YES"

# for virtualbox
vboxnet_enable="YES"
devfs_system_ruleset="system"

# for printing
lpd_enable="NO"
cupsd_enable="YES"

# for FUSE
fusefs_enable="YES"
My xorg.conf is pretty vanilla, but here it is just in case:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 367.35  (root@110amd64-quarterly-job-04)  Mon Dec 12 07:11:53 UTC 2016

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Module"
    Load           "freetype"
    Load           "bitmap"
    Load           "type1"
    Load           "glx"
EndSection
Oh, lastly, here's my .xinitrc. I do not have an .xsession.

Code:
exec /usr/local/bin/gnome-session
Any ideas?
 
OP
OP
D

Dan Barowy

New Member


Messages: 5

#3
OK, I've narrowed the causes. After finding this very useful post about the very issue I'm having, the issue is definitely with gnome-settings-daemon. By changing the /usr/local/share/gnome-session/sessions/gnome.session file so that

Code:
[GNOME Session]
Name=GNOME
RequiredComponents=gnome-shell;gnome-settings-daemon;
is now

Code:
[GNOME Session]
Name=GNOME
RequiredComponents=gnome-shell;
I no longer get the "Oh no!" message. However, whatever issue is popping up with gnome-settings-daemon still occurs. In fact, it takes well over a minute to login once I enter my credentials into the GDM login screen.

I am going to see if I can somehow reset my GNOME settings. Suggestions appreciated.
 

wezm

New Member

Thanks: 4
Messages: 7

#4
I'm experiencing the same issue. GNOME ran fine since about September later year but a recent update seems to have broken it.

Did resetting your settings make any difference?

Edit: I have worked around the issue for the moment by installing Xfce
 

fernandel

Aspiring Daemon

Thanks: 131
Messages: 629

#5
I had a problem a few weeks ago and I rebuilt GNOME3 and gnome-shell. It works but I do not use GDM (just startx) and in .xinitrc I have
Code:
exec dbus-launch --exit-with-session /usr/local/bin/gnome-session >.xsession-e
rrors 2>&1
 

Michael Harding

New Member

Thanks: 2
Messages: 7

#6
I am running into the same issue - I build my own ports tree with poudriere, and use the nvidia-driver.

If I delete some of the ~/. files, like .cache, .login, it will work fine the next login.

When I see a failure I see a messages in ~/.cache/gdm/session.log like

(gnome-settings-daemon:44241): media-keys-plugin-WARNING **: Unable to inhibit keypresses: GDBus.Error:eek:rg.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .service files

** (gnome-settings-daemon:44241): WARNING **: Unable to register client: GDBus.Error:eek:rg.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

...

gnome-session-binary[1171]: WARNING: Application 'gnome-settings-daemon.desktop' failed to register before timeout

I set up a virtualbox using the same packages, and it works fine.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,523
Messages: 27,957

#8
It's not a bug, it's a local configuration issue.

Code:
Current Operating System: FreeBSD computer 11.0-RELEASE-p8 FreeBSD 11.0-RELEASE-p8 #0: Wed Feb 22 06:12:04 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
Upgrade your system, FreeBSD 11.0-RELEASE has been End-of-Life since November 2017.

Remove these two from /etc/rc.conf for the time being:
Code:
gdm_enable="YES"
gnome_enable="YES"
That will allow you to test more easily. Before running startx verify if DBus started correctly.
 

malco_2001

Member

Thanks: 21
Messages: 63

#9
Removing gnome-settings-daemon from session file as mentioned earlier in this thread works for me to make gnome-shell work. This only affects one system I have that uses an nvidia graphics card. I have tried 11.1-RELEASE. The scfb driver works fine with this same hardware. It crashes if nvidia-driver is used unless I stop gnome-settings-daemon from loading.
 

Michael Harding

New Member

Thanks: 2
Messages: 7

#11
So, if I 'rm -rf ~/.cache ~/.config' from the console or ssh, I can log into a Gnome session -once- from gdm.

I've had this happen a few times over the years, where the nvidia driver seems to be causing problems with Gnome.
Big time sink, I have even removed all of the installed software and reinstalled it, and it doesn't fix the base issue.
Then there's a new release, and bam! it starts working.

I had just upgraded to a i7-8700 and GTX 1050ti and now I can't use this machine as my daily driver w/FreeBSD.
I certainly willing to help debug if needed. Mostly I chimed in so people know that they are not the only one
having this issue.

I've been building FreeBSD from source since the mid 90's, hopefully that doesn't make me a clueless newbie!
 

wezm

New Member

Thanks: 4
Messages: 7

#12
I have even removed all of the installed software and reinstalled it, and it doesn't fix the base issue.
This is the approach I ended up taking. I ended taking the nuclear option and uninstalled all packages. I then reinstalled gnome3-lite, gdm, gnome-terminal, xorg-minimal, nvidia-driver and it's working again... Still not sure what the root cause was att this point. Just happy to have a working HiDPI friendly desktop back again.
 

wezm

New Member

Thanks: 4
Messages: 7

#13
Argh so having it working was short lived. I rebooted and the old behavior returned. With this .xinitrc it seems to work reliably:

exec gnome-session --failsafe --debug > .xsession-errors 2>&1

If I remove the failsafe argument it hangs. The documentation for --failsafe says:

Run in fail-safe mode. User-specified applications will not be started.
The debug logs for a failed session vs. a hung one can be seen in this gist. The non-failsafe one runs a bunch more stuff although both sessions run gnome-settings-daemon, despite it seeming to be the cause of the hung session.
 

wezm

New Member

Thanks: 4
Messages: 7

#14
Further investigation shows that it appears to be some sort of race condition. I edited /usr/local/libexec/gnome-settings-daemon-localeexec and changed the exec line to use truss in order to try to trace where it was getting stuck.

truss -o /home/wmoore/Documents/gnome-settings-daemon-truss.out exec /usr/local/libexec/gnome-settings-daemon

However after that change the hang stopped, even with --failsafe removed from .xinitrc. Suspecting the slight delay introduced by truss I then changed gnome-settings-daemon-localeexec to the following and that seems to have the same effect:

Code:
sleep 1
exec /usr/local/libexec/gnome-settings-daemon
 
M

mrredeyeflight

Guest


#16
Hello
I am trying to get Gnome3 running on my Dell Precision T3600. I get the same error message.
I am using xterm/ I have had no luck. Gnome 3 ran once, and I have not been able to get it running since. I have xterm running now.
Gnome 3 runs well on my other Dell T3600 I have Ubuntu 17.10 running. I wont post what I think of 17.10. The gdm/session log has some errors listed
Can someone point me in the right direction?

Thank you
 

wezm

New Member

Thanks: 4
Messages: 7

#17
Hello
I am trying to get Gnome3 running on my Dell Precision T3600. I get the same error message.
I am using xterm/ I have had no luck. Gnome 3 ran once, and I have not been able to get it running since. I have xterm running now.
Gnome 3 runs well on my other Dell T3600 I have Ubuntu 17.10 running. I wont post what I think of 17.10. The gdm/session log has some errors listed
Can someone point me in the right direction?

Thank you
Try adding a sleep to /usr/local/libexec/gnome-settings-daemon-localeexec as described in the post above.
 
B

BSDAppentic3

Guest


#18
The problem is already solved? I had a similar trouble using Gnome with no-root. Perhaps it could be the cause of your fails.
 
B

BSDAppentic3

Guest


#19
It's not a bug, it's a local configuration issue.

Code:
Current Operating System: FreeBSD computer 11.0-RELEASE-p8 FreeBSD 11.0-RELEASE-p8 #0: Wed Feb 22 06:12:04 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
Upgrade your system, FreeBSD 11.0-RELEASE has been End-of-Life since November 2017.

Remove these two from /etc/rc.conf for the time being:
Code:
gdm_enable="YES"
gnome_enable="YES"
That will allow you to test more easily. Before running startx verify if DBus started correctly.
That's was exactly what I was thinking when I saw that line.
I use 11.1 and have no troubles.
But before I downloaded and burned it on a DVD, I was fighting to trying to install and use 10.3.
 
B

BSDAppentic3

Guest


#20
Dan Barowy
I think the same that SirDice. You should download and install the latest version of this system. If not, and if you know how to make a full upgrade of the system, then you could download the sources (and the kernel, etc) to compile your own kernel. With this last it's too much complex if you don't have the knowing nor experience about it.
Besides, I will add something: when I launch Gnome, I run the first 5 principal services by my own. Maybe I will make a post explaining it.
Edit: forget it. I can't explain it right here.
 
M

mrredeyeflight

Guest


#22
Try adding a sleep to /usr/local/libexec/gnome-settings-daemon-localeexec as described in the post above.
Hello.
Thanks anyway. I am going to get rid of Freebsd.
Thank you anyway. On the idential Dell T3600 6 core cpu and same video card. Gmone runs excellent under Ubuntu 17.10
I will try FreeBSD again in a few years.

good luck
 
B

BSDAppentic3

Guest


#23
Hello.
Thanks anyway. I am going to get rid of Freebsd.
Thank you anyway. On the idential Dell T3600 6 core cpu and same video card. Gmone runs excellent under Ubuntu 17.10
I will try FreeBSD again in a few years.

good luck
Good bye. I don't know if it'll be the right thing for you. We don't need you. But if you already gave up instead of fight to use it, it speaks a lot about you. Perhaps you are a smart person and you'll study this (in that case, well, there are at least 7-10 years of study). Or simply you gave up because it is too much for you and you want some easy-use (but that doesn't mean that it will be a good OS). In the second case, I can understand you. I've fight one time and again with this OS.
But you know what's the difference between you and me? I never gave up. I will be still here, but you not. Think about it.
But if you say that maybe in a few years you'll try to use it, well, there's no guarantee about that.
 
M

mrredeyeflight

Guest


#24
No there is no guarantee about anything. Ubuntu may not be perfect, at least Gnome works excellent. I cna't say that about Freebsd (how old is FreeBSD ? 30 years? hmmm

take care.
 
Top