• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

NVIDIA madness - no screens found

mrmarbury

Member

Thanks: 4
Messages: 45

#1
Hi,

I'm currently freaking out over x configuration with the latest nvidia driver available in the FreeBSD 9 ports collection. The machine is a Sony Vaio VPCF13 which is fully working with Gentoo linux and the same nvidia-driver version and a slightly older xorg version.

Anyway, whatever I try I always get the following message:

Code:
Screen(s) found, but none have a usable configuration.
My current configuration is:

/etc/rc.conf
Code:
dbus_enable="YES"
hald_enable="YES"
linux_enable="YES"
/boot/loader.conf
Code:
nvidia_load="YES"
kldstat
Code:
Id Refs Address            Size     Name
 1   36 0xffffffff80200000 11c54c0  kernel
 2    1 0xffffffff813c6000 1049bb0  nvidia.ko
 3    4 0xffffffff82410000 45090    linux.ko
 4    1 0xffffffff82612000 a12      linsysfs.ko
 5    1 0xffffffff82613000 42a0     linprocfs.ko
 6    1 0xffffffff82618000 328d     ng_ubt.ko
 7    1 0xffffffff8261c000 8b3d     ng_hci.ko
 8    3 0xffffffff82625000 a79      ng_bluetooth.ko
 9    5 0xffffffff82626000 8e12     netgraph.ko
10    1 0xffffffff8262f000 b4a2     ng_l2cap.ko
11    1 0xffffffff8263b000 1695e    ng_btsocket.ko
12    1 0xffffffff82652000 1ba9     ng_socket.ko
13    1 0xffffffff82654000 ac65     ext2fs.ko
I currently have agp removed from the kernel but that didn't help either.

xorg config and the X-log are attached.

I tried (almost) everything I have found by googling. Read FreeBSD doc and tried it. Read nvidia doc and tried it. Read xorg doc and tried what looked reasonable. I even booted up my gentoo which is on a different HDD, configured for the Vaio (where X worked out of the box) and copied the H- and VSync stuff from the Xorg log of gentoo. I even tried the xorg.conf from there. Didn't work either *sigh*

The Modeline in the attached conf was created with gtf but it doesn't work with or without the modeline either. Same for the UseEDID option.

I dont't know what to do anymore. I'm trying this for 4 days now and might go nuts :pP
It is working with VESA but I don't want to use 800x600 on a 1920x1080 screen ^^

I hope you can help me?

Cheers,
Stefan
 

Attachments

numpad5

Member

Thanks: 2
Messages: 40

#2
Have you tried running Xorg -configure then changing the driver back to "nvidia" from the usually detected "nv"? The Xorg log is kind of scary though as it says at the end nothing is attached to the videocard, which might mean a buggy driver :<
 

mrmarbury

Member

Thanks: 4
Messages: 45

#3
Hi,

yes the attached config is the outcome of an X -configure. I even ran nvidia-xconfig which doesn't change anything at all ^^
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,125
Messages: 27,000

#4
Try and use mine:
Code:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
EndSection

Section "Files"
        ModulePath   "/usr/local/lib/xorg/modules"
        FontPath     "/usr/local/lib/X11/fonts/misc/"
        FontPath     "/usr/local/lib/X11/fonts/TTF/"
        FontPath     "/usr/local/lib/X11/fonts/OTF"
        FontPath     "/usr/local/lib/X11/fonts/Type1/"
        FontPath     "/usr/local/lib/X11/fonts/100dpi/"
        FontPath     "/usr/local/lib/X11/fonts/75dpi/"
        FontPath     "/usr/local/lib/X11/fonts/bitstream-vera/"
        FontPath     "/usr/local/lib/X11/fonts/cyrillic/"
        FontPath     "/usr/local/lib/X11/fonts/webfonts/"
        FontPath     "/usr/local/lib/X11/fonts/dejavu/"
        FontPath     "/usr/local/lib/X11/fonts/terminus-font/"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        #BoardName   "G73 [GeForce 7600 GT]"
        #BusID       "PCI:1:0:0"
EndSection
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
 

mrmarbury

Member

Thanks: 4
Messages: 45

#5
SirDice said:
Try and use mine:
Hmm the only thing different from the default is the viewport, isn't it? You really think that will help? I mean I'm catching a straw anyway so I will try it. But I don't think it'll work. Or am I overlooking something?

Cheers,
Stefan
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,125
Messages: 27,000

#6
I noticed a lot of things in yours that shouldn't be there. Stuff like AllowEmptyInput and turning EDID off.
 

mrmarbury

Member

Thanks: 4
Messages: 45

#8
@SirDice:
The AllowEmptyInput Off is there because it is said in the BSD docs that it should be there, and the EDID ignore was a test. But as stated in the initial posting, it doesn't matter if both options are there or not. Except that if AllowEmptyInput is missing I get a warning in the logs that the option should be set to off ;o)

@Thuglife:
nvidia-xconfig does nothing for me. I already tried that (see initial posting).
And thanks for the link. The EDID stuff is kind of a last resort but unfortunately nvidia-settings (the only way for me to aquire an edid) is generating corrupted EDID files :x
And "read-edid" is not working with 64bit systems :\
So I would need to repair the EDID file generated by nvidia-settings with a Hex editor which I don't find that easy. When using the unrepaired EDID file I get "0 edid's found" in the Xorg logs and setting the output to DFP (or DFP-0; the screen is shown as DFP-0 in Linux) X starts but I get effects that do not look healthy.

But I think I've seen the complete EDID-Hex code in the gentoo xorg-logs yesterday when I was starting with -logverbose 6. I will compare the hex code to the nvidia-generated code. Hopefully it differs and I don't have to fix anything - which I doubt.

I report back.

Cheers,
Stefan
 

mrmarbury

Member

Thanks: 4
Messages: 45

#9
Well, it's working :)

Added the edid.bin one again. But this time I told the driver:
Code:
Option "ConnectedMonitor" "DFP"
Now I have to figure out how external monitors work once I can use nvidia-settings :)

Thanks for your time. Much appreciated. Now my transition from Gentoo to FreeBSD can continue ;)

Cheers,
Stefan
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 3,607
Messages: 13,850

#11
mrmarbury said:
@SirDice:
The AllowEmptyInput Off is there because it is said in the BSD docs that it should be there,
Please specify which "BSD docs" say to use AllowEmptyInput. On FreeBSD, there was one day in 2009 that it was needed, and it has stuck around like an unwanted house guest ever since. See AllowEmptyInput, FreeBSD, and Xorg Input for more sickening detail.

Except that if AllowEmptyInput is missing I get a warning in the logs that the option should be set to off ;o)
Please show that warning.
 
Top