Other NTFS automount

I have a problem with NTFS automount. If I connect my NTFS formatted drive to the PC, it isn't mounted, and if I mount it from the command line, I receive this error when I try to access to it from the file manager
An error occurred while accessing 'USB_STICK', the system responded: org.freedesktop.Hal.Device.Volume.UnknownFailure: mount: illegal option -- u usage: mount [-t fstype] [-o options] target_fs mount_point
. My desktop is KDE if you need to know.
You'll need sysutils/fusefs-ntfs, add fuse_load="YES" to /boot/loader.conf or use kldload fuse to load the kernel module need by the application. To mount a NTFS partition use # ntfs-3g /dev/[I]disk-partition[/I] [I]mount-point[/I]. Using this method you get a rw NTFS partition mounted but you need to mount manually at every boot

Also, when you mount it to a specific location, you should access it in the file manager directly (the file manager will try to mount it if you click in the device directly) so mounting to /mnt/my-disk you access it going to the /mnt/my-disk folder
I installed sysutils/fusefs-ntfs and the module is already loaded. I wrote that if I try to mount the USB (with ntfs-3g /dev/x /mnt, the file manager gives me that error. I can access it from the command line however.
Each file manager has its own configurations options, and clicking the device directly he will try to mount it. Did you tried going to the /mnt folder? This error happens when you click the device or access the folder?
Last edited by a moderator:
When I click on the device. If I go to /mnt there is a file with the name of the device and if I click on it it says that there is no programma associate with that file type.
That's strange. Here are some things you can do to try to find where and what is the error.

1st: What cat outputs when trying to read the file with the device name?
2nd: Did you tried mounting anywhere else? Try creating a specific folder to this device (lets say, /media/ntfs-partition) and mounting it there
3rd: Did you tried mounting it with the native mount command (it mounts the device on read-only mode, but if the partition has data inside it, you should be able to read it.) There's probably an error with ntfs-3g or a rw mount(?) (use # mount -t ntfs /dev/device mounting-point)
4th: Can you mount it correctly inside another operating system? Linux, Windows, maybe?
5th: If everything fails, try backing up the data of the partition/device (if the above test succeeds) and formatting it on FreeBSD (you can use gpart or fdisk to do that) and try mounting it again
6th: The last one, just to make sure its not a simple mistake: Do you use the device name or the partition name to the command? I have no doubt of your knowledge, but the problem can be easier to solve if all the right questions are made. To mount a device you should specify the device name (lets say /dev/ada0) and the partition (s for slices and p for partitions, so /dev/ada0s1 first slice and /dev/ada0p1 first partition. I'm not sure but I think a disk cannot have both).

Good luck, I hope you find the right answer/solution. If something interesting or at least strange appears on the above (or on your own) tests, post it here. I'll be glad to help you trying to solve your problem. Try asking a mailing list too, you can find your solution there.
I have this problem only with NTFS formatted disks, my fat USB is automounted correctly (I don't need to mount it from the terminal) and I can access it from the file manager, with NTFS disks I need to mount them manually and I can't access them from the file manager, only from the command line. The decide is mounted correctly on other operating systems. I mount the decide specifing the partiti on (/deve/da0s1 in my case). I'll try to mount using the mount command instead of ntfs-3g, bit I'd like automount instead of doing it manually
Using mount
sudo mount -t ntfs-3g /dev/da0s1 /mnt
mount: /dev/da0s1: Operation not supported by device
I hope it isn't too late for an answer... but I suggest you try the following command instead:
sudo ntfs-3g /dev/da0s1 /mnt
and to unmount:
sudo umount /mnt
That should do the trick ;)