Not getting latest version of package with pkg

molofishy

Member

Reaction score: 3
Messages: 52

I currently have the package:
ocaml-4.05.0_1
Yet the latest version since February 2020 is:
ocaml-4.10.0_1
When I execute the following,
Bash:
pkg upgrade -f ocaml
I am asked if I want to reinstall ocaml-4.05.0_1.
I am running version 1.14.6 of pkg.
 

rigoletto@

Daemon
Developer

Reaction score: 1,130
Messages: 2,196

This is because OCaml have not been updated since a while. It has been very problematic to maintain it because of the other OCaml ports make stuff too complicated (FreeBSD isn't fully supported).

Last year I've put someone involved with the OCaml (and MirageOS) development in contact with the project in order to improve the things but I don't know how that is evolving.
 
Top