Solved Not able to update mail/postfix

Mayhem30

Well-Known Member

Reaction score: 26
Messages: 461

I'm not able to update mail/postfix.

Any suggestions?

Code:
postfix-3.6.2_1,1                  <   needs updating (port has 3.6.3,1)

$ sudo gitup ports
# Scanning local repository...
# Host: git.freebsd.org
# Port: 443
# Repository Path: /ports.git
# Target Directory: /usr/ports
# Have: b6c28aeee7ed01d90ae6cae5879e3cdff7edaa1c
# Want: 89577b73d15584e55f3a213b469774b6d42cbbaf
# Branch: main
# Action: pull
 * /usr/ports/devel/RStudio
# Done.

$ sudo synth status
Querying system about current package installations.
Installed package ignored, mail/postfix package unmatched
Stand by, comparing installed packages against the ports tree.
Scanning existing packages.
These are the ports that would be built ([N]ew, [R]ebuild, [U]pgrade):
Total packages that would be built: 0
The complete build list can also be found at:
/var/synth/synth_status_results.txt

$ sudo synth prepare-system
Querying system about current package installations.
Installed package ignored, mail/postfix package unmatched
Stand by, comparing installed packages against the ports tree.
Scanning existing packages.
After inspection, it has been determined that there are no packages that
require rebuilding; the task is therefore complete.
Stand by, prescanning existing packages.
Stand by, recursively scanning 184 ports serially.
Scanning existing packages.
Packages validated, rebuilding local repository.
Local repository successfully rebuilt

$ sudo pkg upgrade
Updating Synth repository catalogue...
Fetching meta.conf: 100%    163 B   0.2kB/s    00:01   
Fetching packagesite.pkg: 100%   59 KiB  60.0kB/s    00:01   
Processing entries: 100%
Synth repository update completed. 184 packages processed.
All repositories are up to date.
Checking for upgrades (0 candidates): 100%
Processing candidates (0 candidates): 100%
Checking integrity... done (0 conflicting)
Your packages are up to date.
 
OP
M

Mayhem30

Well-Known Member

Reaction score: 26
Messages: 461

Solved.

Had to remove postfix from the system along with the .pkg file in /var/synth/live_packages/All/ and reinstall with using the flavor @default.

It would have helped if /usr/ports/UPDATING was updated to reflect that the www/postfix port was moved to flavors.
 
Top