Noob problems with xorg.conf glxservernidia module does not exist

Forgive me, I'm a FreeBSD noob, but I've been searching online for an answer and keep hitting a brick wall. I installed FreeBSD last Friday and i get a default resolution of 1024x760 and no other options. The laptop is a HP OMEN running an Nvidia GeForce RTX 2060. I'm running version 13.2 Release of the OS. and i'm struggling to find out why is keeps telling me (ee) failed to load module glxservernvidia (module does not exist). I installed the latest nvidia drivers and even ran nvidia-config which just made things worse. I get a black screen with a cursor and no movement. I even tried running Xorg -configure and it created a detailed xorg.conf file but I got the same result. I've uninstalled and reinstalled the nvidia driver. I followed the advice online and put the appropriate entries in the rc.conf and loader.conf files but nothing is happening. I'm at a loss for what to try next and any help would be appreciated. Thank you for reading this far and thank you in advance.
 

Attachments

  • rc.conf
    398 bytes · Views: 74
  • loader.conf
    18 bytes · Views: 50
Nvidia driver not working on HP Omen Laptop

Forgive my last attempt at not using formatting in my previous post. When I startup X I get a default resolution of 1024 x 768 with no other options.

Here is my /etc/rc.conf

Code:
hostname="OMEN"
ifconfig_re0="DHCP"
create_args_wlan0="country CA regdomain FCC"
sshd_enable="YES"
ntpd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
wlans_iwlwifi0="wlan0"
ifconfig_wlan0="WPA DHCP"
defaultrouter=192.168.0.1
kld_list="nvidia-modeset"
snd_hda="YES"

This is my /boot.loader.conf

Code:
nvidia_load="YES"
linux_enable="YES"

A friend asked me to run some commands and post the output.

Code:
dmesg | grep -i nvidia

Code:
nvidia0: <NVIDIA GeForce RTX 2060> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io
hdac0: <NVIDIA (0x10f9) HDA Controller> mem 0x78080000-0x78083fff at device 0.1 on pci1
xhci0: <NVIDIA TU106 USB 3.1 controller> mem 0x6042000000-0x604203ffff,0x6042040000-0x604204ffff at device 0.2 on pci1
hdacc0: <NVIDIA (0x0093) HDA CODEC> at cad 0 on hdac0
hdaa0: <NVIDIA (0x0093) Audio Function Group> at nid 1 on hdacc0
pcm0: <NVIDIA (0x0093) (HDMI/DP 8ch)> at nid 4 on hdaa0
pcm1: <NVIDIA (0x0093) (HDMI/DP 8ch)> at nid 6 on hdaa0
pcm2: <NVIDIA (0x0093) (HDMI/DP 8ch)> at nid 7 on hdaa0
nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  525.116.03  Wed Apr 19 23:11:38 UTC 2023

Code:
pkg info | grep -i nvidia

Code:
nvidia-driver-525.116.03       NVidia graphics card binary drivers for hardware OpenGL rendering

So far I've tried running Xorg -configure to no success, manually create a /etc/xorg.conf, uninstalling and reinstalling nvidia-driver and downgrading to a previous version of the driver. The machine seems to be picking up the driver but X is not. Is this a known bug? Any help to resolve this issue would be greatly appreciated. Thank you in advance.
 
Thank you for the response, I will read those sections and update you with what I find.
 
I also rand the following command:

Code:
pciconf -lv | grep -B4 VGA

Code:
vgapci1@pci0:0:2:0:    class=0x030000 rev=0x05 hdr=0x00 vendor=0x8086 device=0x9bc4 subvendor=0x103c subdevice=0x878a
    vendor     = 'Intel Corporation'
    device     = 'CometLake-H GT2 [UHD Graphics]'
    class      = display
    subclass   = VGA
--
vgapci0@pci0:1:0:0:    class=0x030000 rev=0xa1 hdr=0x00 vendor=0x10de device=0x1f15 subvendor=0x103c subdevice=0x878a
    vendor     = 'NVIDIA Corporation'
    device     = 'TU106M [GeForce RTX 2060 Mobile]'
    class      = display
    subclass   = VGA

I read the section 5.4.3 in the handbook and created the file /usr/local/etc/X11/xorg.conf.d/20-nvidia-conf and wasn't able to get X up and running.
 
Have you removed nvidia_load="YES" in /boot/loader.conf?
What is the result of kldstat and the content of /var/log/Xorg0.log? (use the "spoiler" tag or post it as attached file).
 
I just tried removing nvidia_load="YES" and I got the same result.

When i ran
Code:
kldstat
I got this":

Code:
Id Refs Address                Size Name
 1   88 0xffffffff80200000  1f3e2d0 kernel
 2    1 0xffffffff82610000   10f2f0 nvidia-modeset.ko
 3    1 0xffffffff82800000  33aa138 nvidia.ko
 4    2 0xffffffff82720000    31a80 linux.ko
 5    3 0xffffffff82752000     be88 linux_common.ko
 6    1 0xffffffff8275e000    14b98 netlink.ko
 7    1 0xffffffff82773000     3378 acpi_wmi.ko
 8    1 0xffffffff82777000     3250 ichsmb.ko
 9    1 0xffffffff8277b000     2180 smbus.ko
10    1 0xffffffff85bab000    880c8 if_iwlwifi.ko
11    1 0xffffffff8277e000     5ecc ig4.ko
12    1 0xffffffff82784000     2110 pchtherm.ko
13    1 0xffffffff82787000     3340 uhid.ko
14    1 0xffffffff8278b000     4350 ums.ko
15    1 0xffffffff82790000     3380 usbhid.ko
16    6 0xffffffff82794000     31f8 hidbus.ko
17    1 0xffffffff82798000     4d00 ng_ubt.ko
18    3 0xffffffff8279d000     aac8 netgraph.ko
19    2 0xffffffff827a8000     a238 ng_hci.ko
20    2 0xffffffff827b3000     25a8 ng_bluetooth.ko
21    1 0xffffffff827b6000     3220 iichid.ko
22    1 0xffffffff827ba000     21e8 hms.ko
23    1 0xffffffff827bd000     30a8 hidmap.ko
24    1 0xffffffff827c1000     3328 hmt.ko
25    1 0xffffffff827c5000     22b0 hconf.ko
26    1 0xffffffff827c8000     2a08 mac_ntpd.ko

please find my Xorg.0.log attached
 

Attachments

  • Xorg.0.log.txt
    19.4 KB · Views: 59
What is the content of /usr/local/etc/X11/xorg.conf.d/20-nvidia-conf?
If you added something about BusID, just remove this line and retry.
 
/usr/local/etc/X11/xorg.conf.d/20-nvidia-conf

Code:
Section "Device" 
        Identifier "Card0" 
        Driver     "nvidia" 
EndSection

There was a bus id in there. I removed and rebooted the machine X still wouldn't start. It said fatal server error, no screens found.
 
Looking at your xorg log file it seems it's using only scfb driver. I would start with proper xorg.conf configuration. Attaching my working config. Just change BusID in Device section and maybe details in InputDevice section. My /etc/rc.conf contains "kld_list="nvidia-modeset nvidia", nothing specific in /boot/loader.conf. kldstat shows nvidia and nvidia-modeset modules loaded.
 

Attachments

  • xorg.conf
    1.2 KB · Views: 88
Looking at your xorg log file it seems it's using only scfb driver. I would start with proper xorg.conf configuration. Attaching my working config. Just change BusID in Device section and maybe details in InputDevice section. My /etc/rc.conf contains "kld_list="nvidia-modeset nvidia", nothing specific in /boot/loader.conf. kldstat shows nvidia and nvidia-modeset modules loaded.
Thank you for the link, but I can't seem to download or read your file
 
Thank you to Emrion and 3301 for your help today, unfortunately everything that has been recommended hasn't been successful. I'm taking a break from this, at least for the night. Thank you again
 
Thank you to Emrion and 3301 for your help today, unfortunately everything that has been recommended hasn't been successful. I'm taking a break from this, at least for the night. Thank you again

i tried the xorg.conf file from 3301 and another xorg.conf file from https://bsd-hardware.info/?probe=fc81710889&log=xorg.conf

neither worked I just get fatal server error no screens found. in /var/log/Xorg0.log It sees the NVIDIA drivers and loads them but nothing happens. It still can't see glxserver_nvidia. Is there anything left for me to try?
 

Attachments

  • Xorg.1.log.txt
    23.2 KB · Views: 74

I'm not sure why it shows a Monitor0 and a Monitor1...

Code:
[  2664.664] (==) ServerLayout "X.org Configured"
[  2664.664] (**) |-->Screen "Screen0" (0)
[  2664.664] (**) |   |-->Monitor "Monitor0"
[  2664.665] (**) |   |-->Device "Card0"
[  2664.665] (**) |-->Screen "Screen1" (1)
[  2664.665] (**) |   |-->Monitor "Monitor1"
[  2664.665] (**) |   |-->Device "Card1"
[  2664.665] (**) |-->Input Device "Mouse0"
[  2664.665] (**) |-->Input Device "Keyboard0"
[  2664.665] (==) Automatically adding devices
[  2664.665] (==) Automatically enabling devices
[  2664.665] (==) Automatically adding GPU devices


It doesn't seem to be picking up a display at all here...

Code:
[  2664.716] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[  2664.716] (--) NVIDIA(0):     DFP-0
[  2664.716] (--) NVIDIA(0):     DFP-1
[  2664.716] (--) NVIDIA(0):     DFP-2
[  2664.716] (--) NVIDIA(0):     DFP-3
[  2664.716] (--) NVIDIA(0):     DFP-4
[  2664.716] (--) NVIDIA(0):     DFP-5


Just for the fun of it, I don't suppose you have an external monitor you could hook up?
 
Yes, that's the problem: no plugged monitor has been found. But, the nvidia card is well detected and modules are loaded, so this is an improvement comparing to the beginning.

For example, on a machine with a nvidia card, I get this:
[ 9.379] (--) NVIDIA(GPU-0): Samsung S22B150 (CRT-0): connected
[ 9.379] (--) NVIDIA(GPU-0): Samsung S22B150 (CRT-0): 400.0 MHz maximum pixel clock

You can explore what you can do with x11/nvidia-xconfig (read man page). Or try to use you Intel GPU (drm-kmod) if that works better. And/or, as i1045 suggested, plug an external monitor to see if it gets detected.


I'm not sure why it shows a Monitor0 and a Monitor1...

Code:
[  2664.664] (==) ServerLayout "X.org Configured"
[  2664.664] (**) |-->Screen "Screen0" (0)
[  2664.664] (**) |   |-->Monitor "Monitor0"
[  2664.665] (**) |   |-->Device "Card0"
[  2664.665] (**) |-->Screen "Screen1" (1)
[  2664.665] (**) |   |-->Monitor "Monitor1"
[  2664.665] (**) |   |-->Device "Card1"
[  2664.665] (**) |-->Input Device "Mouse0"
[  2664.665] (**) |-->Input Device "Keyboard0"
[  2664.665] (==) Automatically adding devices
[  2664.665] (==) Automatically enabling devices
[  2664.665] (==) Automatically adding GPU devices
I get the same with my config so that's not the point.
 
Hi Trogg, I've always found setting up x11/xorg to be a pain, particularly on laptops. Don't despair -- you will get it working 😁 Your NVIDIA card looks to be supported, having looked at the NVIDIA driver page.

Try specifying the BusIDs for both cards. I would also echo i1045 's suggestion of plugging in an external monitor as in the past I have managed to get an external screen showing before finding the right configuration for the internal one.

I have looked at the logs and pciconf(8) output you posted and believe the BusIDs I've specified in the minimal xorg.conf file below (can be split into multiple files as per the X Windows section of the FreeBSD handbook) are the ones you need, though once you're up and running you'll likely want to adapt the other sections, add desired extensions etc.
Code:
Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "TU106M [GeForce RTX 2060 Mobile]"
    BusID          "PCI:1@0:0:0"
EndSection

Section "Device"
    Identifier     "Card1"
    Driver         "intel"
    VendorName     "Intel Corporation"
    BoardName      "CometLake-H GT2 [UHD Graphics]"
    BusID          "PCI:0@0:2:0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Option         "DPMS" "true"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "true"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier     "nVidia as primary"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

You should also ensure that /etc/rc.conf contains the line to load drivers for both graphics cards in case the one connected to the laptop screen is not the one you expect!
Code:
kld_list="nvidia-modeset i915kms"
 
I have good news, and not so good news. I followed the advice of Emrion and installed drm-kmod and put the i914ms in /etc/rc.conf and rebooted. When i did that it rebooted and loaded a much larger screen resolution. When I tried startx it gave me a larger screen with a mouse pointer against a black background but no movement. I tried fiddling with the xorg.conf files through manual editing andorg - configure, which i know is a bad thing but i was out of options. That didn't resolve anything, but then I decided to follow the advice to plug in another monitor. I rebooted and started X. The monitor was the same grey immovable mouse pointer with a black background but the external screen loaded with a resolution of 1920x1080. So I have part of what I was looking for, but no idea why the laptop screen is unusable. I am elated that I have a working display so thank you to everyone who helped. However I'm greedy and would like to get the other screen up and running as well. Its currently running the modified xorg.conf
file. What other information is needed?

After talking with a friend about this, he recommended that I post my my /var/log/Xorg0.log file If you see anything of note please let me know
 

Attachments

  • xorg.conf
    3.2 KB · Views: 53
  • Xorg.0.log.txt
    27.7 KB · Views: 48
I have some concerns about the values in the xorg.conf file you posted:
  • You have listed two separate Device sections using the same BusID value, which I don't believe is valid as it would mean that you are trying to attach two drivers to one physical device
  • I don't believe that i195kms is a valid value for the Driver; I think it should be intel.
For further diagnosis, your configuration files and Xorg.0.log log files for any configuration close to working would be helpful (and ideally posted in code blocks rather than as an attached file). I am reasonably hopeful the Device sections in the configuration file I posted for you are correct. Did you try them?
 
as requested here is my /etc/X11/xorg.conf

Code:
Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "TU106M [GeForce RTX 2060 Mobile]"
    BusID          "PCI:1@0:0:0"
EndSection

Section "Device"
    Identifier     "Card1"
    Driver         "intel"
    VendorName     "Intel Corporation"
    BoardName      "CometLake-H GT2 [UHD Graphics]"
    BusID          "PCI:0@0:2:0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Option         "DPMS" "true"
   
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "true"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
   
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier     "nVidia as primary"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

I tried posting Xorg.0.log but the page would let me it exceecded the message limitations. Hope this helps you out
 

Attachments

  • Xorg.0.log.txt
    27.7 KB · Views: 58
A friend referred me to a xorg.conf found online dealing with a multi-monitor setup

Code:
 1 Section "ServerLayout" 
  2     Identifier     "Default Layout"
  3     Screen      0  "Screen0" 0 0
  4     Screen      1  "Screen1" RightOf "Screen0"
  5     InputDevice    "Keyboard0" "CoreKeyboard"
  6     InputDevice    "Mouse0" "CorePointer"
  7     Option         "Xinerama" "0"
  8 EndSection
  9 
 10 Section "InputDevice"
 11     # generated from default
 12     Identifier     "Keyboard0"
 13     Driver         "kbd"
 14 EndSection
 15 
 16 Section "InputDevice"
 17     Identifier     "Mouse0"
 18     Driver         "mouse"
 19     Option         "Protocol" "auto"
 20     Option         "Device" "/dev/psaux"
 21     Option         "Emulate3Buttons" "no"
 22     Option         "ZAxisMapping" "4 5"
 23 EndSection
 24 
 25 Section "Monitor"
 26     Identifier     "Monitor0"
 27 EndSection
 28 
 29 Section "Monitor"
 30     Identifier     "Monitor1"
 31 EndSection
 32 
 33 Section "Device"
 34     Identifier     "nvidia"
 35     Driver         "nvidia"
 36 
 37     BusID          "PCI:1@0:0:0"
 38 EndSection
 39 
 40 Section "Device"
 41     Identifier     "Device0"
 42     Driver         "nvidia"
~/xorghideway/xorg.conf[xf86conf]                                                                                                           <unknown> words, 1/82 lines, Top
-- VISUAL LINE --
 41     Identifier     "Device0"
 42     Driver         "nvidia"
 43     Screen          0
 44     BusID          "PCI:1@0:0:0"
 45 EndSection
 46 
 47 Section "Device"
 48     Identifier     "Device1"
 49     Driver         "nvidia"
 50     Screen          1
 51     BusID          "PCI:1@0:2:0"
 52 EndSection
 53 
 54 Section "Screen"
 55     Identifier     "Default Screen"
 56     Device         "nvidia"
 57 EndSection
 58 
 59 Section "Screen"
 60     Identifier     "Screen0"
 61     Device         "Device0"
 62     Monitor        "Monitor0"
 63     DefaultDepth    24
 64     Option         "TwinView" "0"
 65     Option         "metamodes" "HDMI-0: nvidia-auto-select +0+0"
 66     SubSection     "Display"
 67         Depth       24
 68     EndSubSection
 69 EndSection
 70 
 71 Section "Screen"
 72     Identifier     "Screen1"
 73     Device         "Device1"
 74     Monitor        "Monitor1"
 75     DefaultDepth    24
 76     Option         "TwinView" "0"
 77     Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
 78     SubSection     "Display"
 79         Depth       24
 80     EndSubSection
 81 EndSection

It fails when I try to run it and I get the following message
Code:
EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices

is this something that can be tweaked?
 
In general it looks like you are moving in the right direction. Have you tried plugging in a USB mouse to see whether it is just an issue with the touchpad configuration at this point?

Responding to your posts, let me take your latest ones in order. Regarding Xorg.0.log, a good place to start is to restrict what you're looking at to errors and warnings:
grep -E 'WW|EE' Xorg.0.log gives:
Code:
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    28.106] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    28.106] (WW) Disabling Keyboard0
[    28.106] (WW) Disabling Mouse0
[    28.136] (WW) Warning, couldn't open module intel
[    28.136] (EE) Failed to load module "intel" (module does not exist, 0)
[    28.187] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    29.388] (WW) NVIDIA: No DRM device: Direct render devices found but none could be
[    29.388] (WW) NVIDIA:     used.
[    30.398] (WW) NVIDIA(0): Option "NoLogo" is not used
[    30.402] (II) Initializing extension MIT-SCREEN-SAVER

You can then start searching the web to find out what is going on, starting with errors and moving to warnings.

The error line relates to not being able to find the intel driver. You are planning to use your NVIDIA card so may not care about this. However, from the X Windows section of the FreeBSD handbook, I believe you need to install graphics/drm-kmod to provide this driver for your Intel graphics card:
pkg install graphics/drm-kmod

An easy warning to fix is the Option "NoLogo" one, which is my bad as I copied it from a configuration from an old NVIDIA driver. You can just remove this option from your config file.

I'm afraid I can't offer anything on the Hotplugging message without doing some more research, though I found the same in my own X11 log file and my laptop's internal keyboard and trackpad as well as my external keyboard and trackpad work just fine.

Regarding your second post, for multiple monitors I use xrandr(1) without issue. This also lets me plug and unplug external monitors and reconfigure on the fly. The configuration you posted is using Xinerama, which makes X11 treat your multiple screens like one big one. I will let you decide what will work better for you but would suggest that this is the sort of configuration decision that can wait until you have a working X11 environment.
 
Hello,

Sorry for the delay in getting back to you i've been trying lots of things. I did install drm-kmod and that didn't change anything it was still looking for an intel driver so after reading a post in the Arch forums i installed
Code:
xf86-intel-driver
It didn't work but in the Xorg log it did pick up the intel driver and loaded. I did get an error message though
Code:
[  1220.537] (WW) intel(G0): Disabling Xv because no adaptors could be initialized.

Further research led me to look gor the output
Code:
xrandr --listproviders
Code:
Providers: number : 2
Provider 0: id: 0x1b7 cap: 0x0 crtcs: 4 outputs: 6 associated providers: 0 name:NVIDIA-0
Provider 1: id: 0x1fe cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 3 outputs: 1 associated providers: 0 name:Intel

So it knows there is something there.

I will attach my xorg.conf and my Xorg log file to see if there's anything something simple that could be corrected
 

Attachments

  • twomontiorxorg.txt
    27.5 KB · Views: 43
  • xorg.conf.txt
    1.3 KB · Views: 62
Does this indicate that the intel-driver is trying to configure Monitor0?

Code:
[  1220.427] (II) intel(G0): Output eDP-1 using monitor section Monitor0
[  1220.428] (II) intel(G0): EDID for output eDP-1

If so, this could be an issue:

Code:
[  1220.812] (II) GLX: Another vendor is already registered for screen 0


Could both drivers be trying to grab onto Monitor0? If so, maybe it could be resolved in xorg.conf
 
I managed to get my laptop screen working at optimal resolution. Its using the intel card and not the nvidia. The external monitor doesn't work now, Is there a way to get the laptop montior working with the NVIDIA card? This is my current /etc/X11/xorg.conf
I tried to get the second monitor working with second screen but it failed, but loaded the laptop display anyway.
Code:
Section "Device"
    Identifier     "Card1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "TU106M [GeForce RTX 2060 Mobile]"
    BusID          "PCI:1@0:0:0"
EndSection

Section "Device"
    Identifier     "Card0"
    Driver         "intel"
    VendorName     "Intel Corporation"
    BoardName      "CometLake-H GT2 [UHD Graphics]"
    BusID          "PCI:0@0:2:0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Option         "DPMS" "true"
   
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    #Option         "NoLogo" "true"
    SubSection     "Display"
        Depth       24
       # Modes      "nvidia-auto-select"
   
    EndSubSection
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    Option         "DPMS" "true"
   
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Card1"
    Monitor        "Monitor1"
    DefaultDepth    24
    #Option         "NoLogo" "true"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
   
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier     "nVidia as primary"
    Screen      0  "Screen0" 0 0
    Screen     1  "Screen1" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Attached is the my /var/log/Xorg.0.log
 

Attachments

  • Xorg.0.log.txt
    26.9 KB · Views: 54
Hmmm... Is it possible your laptop uses NVIDIA Optimus, which is meant to switch between graphics cards on-the-fly?

Your easiest option might be to try to disable one graphics card and just use the other. Are there any settings in the BIOS that would allow that?

Alternatively to make Optimus work, these ports might be relevant though are outside of my experience:
Possibly relevant recent threads:
 
Back
Top