no wired or wireless connection

i set up FreeBSD several months ago and I couldn't get my wired connection working but wireless worked like a charm. The problem is I haven't been able to use this laptop in over a month and now wireless doesn't work. I haven't changed anything and I've gone through step by step on the FreeBSD documents and everything is correct. I know I can't provide much information because I'm typing from another computer. Please if you can point me in the right direction I'll try anything.

Without anything to go by, this will be impossible to debug. I understand that it is difficult for you to "cut and paste". Perhaps you can take a picture of console output and attach it.

On the sick machine, give us the output of ifconfig. In particular, look for lines like "media:" and "status:" in there. In the output of dmesg, look for error messages relating to those devices (they may have names like "em0" for wired). If the wired ethernet has indicator lights (either on this machine, or on your switch/router/bridge), tell us what they are showing. Try pinging this machine from another machine on the network, while running tcpdump on one or the other, and see what you find.
I know this is a stupid question but how do upload the jpeg? i even tried pastebin.
Do you have access to some publicly visible web server? Or some picture hosting site (like Google Photos)? Or even Facebook? Any way to make pictures you took visible to the world-wide web? If yes, get the picture there. Then in the editing menu here, click on the "Image" button in the tool bar(immediately to the right of the smiley), and put a link to the picture there. That is the easiest way I know of. As far as I can see, there is no way to upload files directly to this forum (but some admin or moderator might correct me if I'm wrong). Below is a picture of a tree in our garden ... not because it's relevant to this discussion, but to show how it's done on the forum end (if you quote this post, you can see the BB code).

Now switching topics: I don't know about Dell Inspiron, but I have a handful of old IBM and Lenovo ThinkPads sitting around. On them, if my memory serves me right, the wired Ethernet uses the em(4) driver. For wireless there are options, but it seems to me that the majority of my ThinkPads used the ath(4) driver (and in the case of the most recently used one, a model T60p, I have a log file). So if you boot your machine and grep the output of dmesg for "em" and for "ath", you should find stuff. On the Dell, you can grep that output for "pci", and look for anything that smells of network among the pci-connected devices. Making sure the hardware is present and recognized is a good first step. Once you have the hardware, the steps that getopt proposed are also very good, as is the output of ifconfig.

Sorry: Google photos gives me: "404. That’s an error. The requested URL was not found on this server. That’s all we know."

I don't have any Thinkpad as new as a X220. But em0 is good, that's the standard Intel ethernet driver, old and very reliable. Can you maybe type in the output of ifconfig? Here is an example, and I have highlighted the important things with ***:
em0: ***flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    description: LR house internal
    ether 00:30:18:a6:82:8c
    ***inet netmask 0xffffff00 broadcast
    ***media: Ethernet autoselect (100baseTX <full-duplex>)
    ***status: active

I don't have ay FreeBSD machine with wireless available at the moment. If I remember right, for every generic wlan(4) device, there is a low-level hardware device; on my machine it was "ath0", on your machine it might be different. Hopefully someone who has recent experience with wireless on FreeBSD (haven't used it since Christmas, and then it just worked out of the box, most boring thing ever) can help debug that part. When in doubt, type in the output of ifconfig for wlan0, and tell use what other network devices you see in ifconfig (there should also be lo0, and probably that other low-level wireless device).
Running pciconf -l -v should let you know if the system's seen your network card. Ethernet cards are usually the last few items. This will show if the system at least sees the card.
pciconf -l -v |egrep 'vendor|device' gives me something like
device   = 'Realtek Semiconductor Co., Ltd.'
device   = 'RTL811/8168/8411 PCI Express Gigabit Ethernet Controller'
If wireless worked and now doesn't, I wonder if there's a possibility that it was either disabled in BIOS or perhaps has a hardware switch (or key combo) that was accidentally put into play.
Another option is to download a Linux distribution with a live version, and see if you can find the wired and wireless drivers that way with pciconf -k . Mint is a bigger download than some others, but very good on hardware recognition. If it doesn't see wired or wireless connections, there's a reasonable chance that something's wrong with the hardware.
If wireless worked and now doesn't, I wonder if there's a possibility that it was either disabled in BIOS or perhaps has a hardware switch (or key combo) that was accidentally put into play.
Darn it! I should have thought of that earlier. Excellent suggestion.

Most ThinkPad models have some sort of hardware thing to disable all wireless. Let me run to the dungeon to find an old laptop ... OK, on the first one I pulled out, it was function + F5. Don't know whether this still applies to the X220. In the really old days (maybe the T20 or T600), there was also a slide switch on the side that disables all non-wired communication for secure areas. I don't know whether this disconnects the device from the PCI bus (in which case a reboot is probably required), or whether it only disables the antenna.

You have to remember that IBM is famously paranoid, and the (pre-Lenovo) ThinkPads were the favorite laptops for employees of non-existing agencies.
pciconf -l -v didn't work? I don't see typos. (I could be wrong). That was a lower case L, not the numeral one by the way, in case it wasn't clear.
If you mean they didn't give you any results about the cards, that would indicate the system doesn't see them, which could be FreeBSD's lacking of drivers or the hardware being damaged. Let us know what Mint shows you.
I see from the pictures that you have an ethernet card which is not connected. Surely if you connect that you would at least be able to bring that up.
I think that what OJ means is that we can see an em0 card listed.
They (and I) think that if you connect a cable to that card, you should be able to get an ip address.

Also, if Mint didn't load, and you have time, you might try with a Fedora workstation live DVD. I'm surprised Mint didn't load, and it makes me wonder if there's some wonky hardware in there.
I have no experience with hardware on laptops. How would I do this?
Like scottro says, connect a cable and you are likely to get an IP (connection) after you reboot. If not, with a cable attached, we can give you a simple command to make that work. That is, if there isn't something actually broken, which does happen sometimes. :)
That's one of the first things I tried but it didn't work. I tried it again with no luck. I'm going to try with a different cable.

edit didn't work. I have two more laptops to try.