No sound new 12.2 installation.

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

My system advises that the sound module is already loaded in the kernel.
cat /dev/sndstat says I have Realtek ALC892's (pcm0 to pcm3). One is shown as 'default', one 'play/rec' & two 'play'.
I have a head set.
How do I know which pcm to select? Is it just trial & error?
What is the code for installation & where do I install that activation code?

Thank You.
 

Alexander88207

Well-Known Member

Reaction score: 261
Messages: 469

How do I know which pcm to select? Is it just trial & error?

Yep mostly, just follow the instructions of Yampress and you are good to go.

If you have found the right PCM you can set it as default in /etc/sysctl.conf by just writing hw.snd.default_unit=3 for example.
 
OP
D

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

Thanks guys, now it's working (on all 4 pcms) but volume is low on all.

0=rear (analog) (play/rec)
1=front (analog)
2=rear (digtal) play
3=Kaby Lake (hdmi/DP 8 ch) (play)

mixer vol=50/50
" pcm=100/100
" speaker=unknown
" rec=35/35

Any ideas how to increase volume?

Thanks again
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,938
Messages: 36,872

Turn the volume knob on your speakers? Or increase the volume on your monitor/TV if it's connected with HDMI? Note that builtin speakers on monitors are generally quite low volume. At least they are on my (rather expensive) monitor, even on Windows.
 

Alexander88207

Well-Known Member

Reaction score: 261
Messages: 469

Thanks guys, now it's working (on all 4 pcms) but volume is low on all.

0=rear (analog) (play/rec)
1=front (analog)
2=rear (digtal) play
3=Kaby Lake (hdmi/DP 8 ch) (play)

mixer vol=50/50
" pcm=100/100
" speaker=unknown
" rec=35/35

Any ideas how to increase volume?

Thanks again

On the systemside you can use audio/mixertui to increase volume and more easily.
 
OP
D

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

I'm always using on the ear headsets, either cheapie or quality gaming headset because the family thinks that otherwise it detracts from their TV experience-each to his own! In this case both headsets are at the lower volume end with the latter somewhat louder but not appreciably so. Neither headsets have volume controls.

Could the problem be related to poor sound from the motherboard sound implementation?

The pkg install requires the sysctlbyname_improved_load="YES" entry in the boot/loader.conf file for the function to be used. What 'byname' is it referring to?
Thanks
 

Trihexagonal

Daemon

Reaction score: 1,685
Messages: 2,258

Turn the volume knob on your speakers? Or increase the volume on your monitor/TV if it's connected with HDMI?
It's always the little things that trip you up. :p

My system advises that the sound module is already loaded in the kernel.
cat /dev/sndstat says I have Realtek ALC892's (pcm0 to pcm3). One is shown as 'default', one 'play/rec' & two 'play'.
I have a Gateway laptop with Realtek ALC272 Audio that I listen to music through all the time and have been using up till a few days ago. I don't have it running to provide you with more details.

Although it might be outdated like me I use this in all my machines:

/et/rc.conf
snddetect_enable="YES"

And a pair of Koss KTXPRO1 Titanium Portable Headphones with Volume Control. They are the best.
 

Yampress

Active Member

Reaction score: 23
Messages: 136

try this too:
Code:
yampress@freebsd ~ % mixer
Mixer vol      is currently set to  90:90
Mixer pcm      is currently set to 100:100
Mixer speaker  is currently set to  74:74
Mixer line     is currently set to   1:1
Mixer mic      is currently set to  67:67
Mixer mix      is currently set to  74:74
Mixer rec      is currently set to  35:35
Mixer igain    is currently set to   0:0
Mixer ogain    is currently set to 100:100
Recording source: mic
yampress@freebsd ~ % mixer --help
usage: mixer [-f device] [-s | -S] [dev [+|-][voll[:[+|-]volr]] ...
       mixer [-f device] [-s | -S] recsrc ...
       mixer [-f device] [-s | -S] {^|+|-|=}rec rdev ...
 devices: vol, pcm, speaker, line, mic, mix, rec, igain, ogain
 rec devices: speaker, line, mic, mix
yampress@freebsd ~ % mixer vol 99
Setting the mixer vol from 90:90 to 99:99.
 
OP
D

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

Yampress;
what file are you saying this code should go to?
Thanks
 

alfonsosiciliano

New Member

Reaction score: 10
Messages: 8

Hi dalpets,

thank you for your report,
The pkg install requires the sysctlbyname_improved_load="YES" entry in the boot/loader.conf file for the function to be used. What 'byname' is it referring to?

Briefly: mixertui does not use sysctlbyname_improved, so you can ignore the pkg-message.

When an user presses "F2" or "F7" mixertui uses the sysctlmibinfo2 library (devel/libsysctlmibinfo2) to "request" to the kernel some info about the Sound System, properly sysctlmibinfo2 uses two kernel modules: sysctlinfo (an interface to explore the sysctl MIB) and sysctlbyname-improved (for a sysctl object name with an empty string level or with an extended name for passing an input to its handler, to know more sysctlbyname-improved). So when you install mixertui -> libsysctlmibinfo2, pkg installs also -> sysctlbyname-improved-kmod and tells you to load the module via kldload or boot/loader.conf.
Nevertheless, currently, the Sound System has not sysctl objects with special names so you can ignore sysctlbyname-improved.

To know more about 'byname': man.freebsd.org/sysctlbyname/3.
 
Top