No sound in wine games


Deleted member 67862


Im having issues with no sound in several games running wine-devel on Steam, such as Project Zomboid and Subnautica. I've tried to install faudio via winetricks and enable "openal32" native and builtin options in winecfg. I am using the wine OSS driver for sound and not all games are missing sound.

Ive seen similar unresolved problems and would like to solve this once and for all. Has anyone had this no sound issue and how did you fix it / do you have any ideas as to how to fix this?
Project Zomboid had working sound when it was still functioning using linux-steam-utils, but perhaps its because it was using alsa -> oss compatibility. Subnautica I have never tried until now. I will see if they use fmod.
The workaround is to build wine with an other sound system. Afaik the easiest way should be to rebuild wine-devel in poudriere with alsa enabled.

The built amd64 package can be installed normally and the i386 one with pkg32.
It appears both games use fmod nowadays. Is there a way to get fmod working?

Ah OK, I see.